[Plugin] Compo Spray 1.4.2 Updated

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby Didier Bur » Wed Feb 16, 2011 10:06 am

:?:


Say you have filled 3 dropdown lists with component named 'A' and filled the other lists with components 'B' 'C' 'D'.
The scripts randowmly selects what component to drop in a list that is, in our case [A,A,A,B,C,D].
That's-to-say, component 'A' has three times more chances to be selected than components B,C, and D.
A multiselect list would only provide a list in which a component appears once.
0
Didier Bur
Ecole Nationale Supérieure d'Architecture de Nancy (F)
http://rld.crai.archi.fr/rubylibrarydepot/
User avatar
Didier Bur 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby thomthom » Wed Feb 16, 2011 10:37 am

Gotcha!
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby zunkian » Sun Feb 20, 2011 8:12 am

Hi Didier!
First of all, thanks for a cool plugin for SketchUp.
Unfortunately, when I am adjusting the dials for altitude, steepness, scale, etc., the dials won't move!
It is sort of locked in their position.
What do you think is wrong?

Andy
0

zunkian 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby Didier Bur » Sun Feb 20, 2011 3:40 pm

Hi,
Several users reported such a weird behaviour of sliders.
I'm still wondering why this happens sometimes.
Please post here what your OS is, what web browser do you use, what version of Javascript is installed on your machine.
Regards,
0
Didier Bur
Ecole Nationale Supérieure d'Architecture de Nancy (F)
http://rld.crai.archi.fr/rubylibrarydepot/
User avatar
Didier Bur 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby TIG » Sun Feb 20, 2011 4:12 pm

Didier Bur wrote:Hi,
Several users reported such a weird behaviour of sliders.
I'm still wondering why this happens sometimes.
Please post here what your OS is, what web browser do you use, what version of Javascript is installed on your machine.
Regards,

I have had terrible problems getting consistency with sliders in webdialogs - what slider are you using ? I use 'tigra' [no connection!] and that seems the simplest and robust...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby mitcorb » Sun Feb 20, 2011 6:12 pm

I don't see how French kids ever learn to spell :mrgreen:
0
I take the slow, deliberate approach in my aimless wandering.
User avatar
mitcorb 
Top SketchUcator
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby JClements » Sun Feb 20, 2011 8:26 pm

Hi Didier:

Any chance you could add a "Help" button to the toolbar which would open the PDF file?

Regards, John
0
John
Illustrator
Beaverton, Oregon
User avatar
JClements 
Premium Member
Premium Member
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby Didier Bur » Sun Feb 20, 2011 11:57 pm

button to the toolbar which would open the PDF file

Why not, good idea.

what slider are you using

@TIG: I'm using a custom slider programmed in js by K. Gilbert http://kegisiteweb.com/presentation.php. It's copyright free but rather old, that's maybe why it freezes under some specific configurations os/web browser/javascript version ?
It is in the JS folder in CompoSpray folder, and I've only added some trivial functions at the end of the file.
0
Didier Bur
Ecole Nationale Supérieure d'Architecture de Nancy (F)
http://rld.crai.archi.fr/rubylibrarydepot/
User avatar
Didier Bur 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby gistman » Mon Mar 14, 2011 8:53 pm

"Plugin downloaded 12179 times" I just wanted to say thank you for all of your work. You and others here have made SU such a great tool.
0

gistman 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby Mra » Thu Mar 24, 2011 3:41 am

Anyone else getting the error "Cannot place component on selection" when it is just a basic ground mesh and assigning using the "point" method?
0

Mra 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby manwe » Thu Mar 24, 2011 12:56 pm

I've huge problem with using this plugin. Properties of this plugins is quite high & I've wide screen display so I can't reach the accept button...
0

manwe 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby Didier Bur » Thu Mar 24, 2011 4:53 pm

Hi,
@mra: check your altitudes settings in the dialog, possibly a bug in there :oops:
or did you select anything that isn't face(s) ?

@manwe: click on the Settings icon and tell the script to use sliders in the Style dialog list.

Hope this helps,

cs1.jpg
cs2.jpg
0
Didier Bur
Ecole Nationale Supérieure d'Architecture de Nancy (F)
http://rld.crai.archi.fr/rubylibrarydepot/
User avatar
Didier Bur 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby rpinkham » Tue Mar 29, 2011 2:57 pm

Hi,

I'm having some trouble with this tool not covering the selected face completely. It works on most but there are a handful of faces on this triangulated surface that clump my grass proxy together. I am pre-selecting the face and using the "selected faces" option.
Any ideas?
0

rpinkham 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby Didier Bur » Thu Mar 31, 2011 10:51 am

Hi,
@rpinkham: maybe do you have some other faces hidden ?
0
Didier Bur
Ecole Nationale Supérieure d'Architecture de Nancy (F)
http://rld.crai.archi.fr/rubylibrarydepot/
User avatar
Didier Bur 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby rpinkham » Thu Mar 31, 2011 2:24 pm

Didier,
Thanks for the reply. There is no hidden geometry. It happens in a few locations in this larger scale site model...
0

rpinkham 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby Didier Bur » Thu Mar 31, 2011 6:41 pm

Are some faces reversed ? (apparently not on your screenshot, but still searching for a cause...)
0
Didier Bur
Ecole Nationale Supérieure d'Architecture de Nancy (F)
http://rld.crai.archi.fr/rubylibrarydepot/
User avatar
Didier Bur 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby rpinkham » Thu Mar 31, 2011 10:54 pm

The faces are all oriented correctly. I deleted the face and re-drew it with the same results.
0

rpinkham 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby Didier Bur » Fri Apr 01, 2011 8:07 pm

:?: :? :shock: :(
0
Didier Bur
Ecole Nationale Supérieure d'Architecture de Nancy (F)
http://rld.crai.archi.fr/rubylibrarydepot/
User avatar
Didier Bur 
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby Fletch » Fri Apr 01, 2011 11:40 pm

Thanks for the update - looking forward to trying it out.

one tiny thing...
Searching the terms "component spray" and "compo spray"(without the quotes) on the Ruby Depot website via the link provided in the original post yeilds ZERO results. :|
"Your search - compo spray - did not match any documents. " (even if it claims to be a google search, I think the search is set up incorrectly somehow)

Here's the link to the Compo Spray tool on the Ruby Depot website. (had to do a "real" google search specific to the site to find it. :roll: )
http://modelisation.nancy.archi.fr/rld/ ... .php?id=76

(I didn't see the tiny "Discover it HERE" under the "blog post" on the Ruby Depot at first - which has the correct link)
C'est la vie, n'est-ce pas? :D
0

Fletch 
Twilight Render
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby Didier Bur » Sun Apr 03, 2011 5:41 pm

I think the search is set up incorrectly somehow

Hi Fletch,
Yes I know that, I must fix it for a long time :oops:
Note that even if the search return matches, these matches only direct you to the section, not the plugin page itself :thumbd:
0
Didier Bur
Ecole Nationale Supérieure d'Architecture de Nancy (F)
http://rld.crai.archi.fr/rubylibrarydepot/
User avatar
Didier Bur 
 

Re: [PLUGIN] Compo Spray 1.4.2 not working - solution

Postby t6nis » Fri Jul 15, 2011 7:13 am

I also had the problem Compo Spray was not working. The reason was, it is actually included in the SFC Powerbar set (didn't notice that!). So you have to remove it from there first. Or use the Powebar one.
0

t6nis 
 

Re: [PLUGIN] Compo Spray 1.4.2 not working - solution

Postby thomthom » Fri Jul 22, 2011 11:45 am

t6nis wrote:I also had the problem Compo Spray was not working. The reason was, it is actually included in the SFC Powerbar set (didn't notice that!). So you have to remove it from there first. Or use the Powebar one.

What is this SFC Powerbar?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [PLUGIN] Compo Spray 1.4.2 Updated 13 February 2011

Postby charly2008 » Fri Jul 22, 2011 12:36 pm

0
He who makes no mistakes, makes nothing
User avatar
charly2008 
 

Re: [Plugin] Compo Spray 1.4.2 Updated 13 February 2011

Postby thomthom » Mon Aug 08, 2011 1:48 pm

I tried to set up my plugins to be loaded from a custom folder so I could easily sync between multiple SketchUp versions and computers.
For the most of the plugins it went fine, but I got an error with Component Spray because it tries to load the language files from the SketchUp plugins folder instead of where the plugin is actually located.

If you use File.dirname( __FILE__ ) to get the path instead of Sketchup.find_support_file then it would solve this and the plugin could be installed to any location the user wants.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Compo Spray 1.4.2 Updated 13 February 2011

Postby 32bits » Tue Aug 09, 2011 6:20 pm

Hi,

I have problems with this plugin, could anyone help?
Here is what the console tells me:

Code: Select all
Error: #<FloatDomainError: Infinity>
(eval):2844:in `to_i'
(eval):2844:in `cs_n_points'
(eval):1905:in `facesBrushTool'
(eval):279:in `cs_dialog'
(eval):340:in `call'
(eval):340:in `show_modal'
(eval):340:in `cs_dialog'
(eval):116:in `compoSpray_main'
C:/Program Files (x86)/Google/Google SketchUp 8/Plugins/compoSprayToolbar.rb:17
(eval):2486:in `call'
(eval):2486


Thank you very much! :thumb:
0

32bits 
 

Re: [Plugin] Compo Spray 1.4.2 Updated 13 February 2011

Postby rock1 » Wed Aug 10, 2011 11:53 am

i'm havin' a problem using this tool i hv a horizontal resolution of 1024 pixels and i don't want to change that, i can't find the green tick button. please didier, can u tweak this window for me? :roll:
0
Signature removed by SCF Admin

rock1 
 

Re: [Plugin] Compo Spray 1.4.2 Updated 13 February 2011

Postby Didier Bur » Thu Aug 11, 2011 11:32 am

Hi,
As it is said in the doc, go to settings and change your dialog box style (with/without scrollbars)
settings.jpg
.
0
Didier Bur
Ecole Nationale Supérieure d'Architecture de Nancy (F)
http://rld.crai.archi.fr/rubylibrarydepot/
User avatar
Didier Bur 
 

Re: [Plugin] Compo Spray 1.4.2 Updated 13 February 2011

Postby rock1 » Thu Aug 11, 2011 1:44 pm

Didier Bur wrote:Hi,
As it is said in the doc, go to settings and change your dialog box style (with/without scrollbars)
settings.jpg
.


thanks a lot :berserk:
0
Signature removed by SCF Admin

rock1 
 

Re: [Plugin] Compo Spray 1.4.2 Updated 13 February 2011

Postby rock1 » Sat Aug 13, 2011 3:49 pm

Can this plugin be tweaked so that in the components lists, the thumbnails of the components be
shown, just like we see in the component window of the sketchup? 8-)
0
Signature removed by SCF Admin

rock1 
 

Re: [Plugin] Compo Spray 1.4.2 Updated 13 February 2011

Postby lapx » Sun Dec 11, 2011 4:56 pm

DB,

Thanks for such a useful program. I'm having more trouble with this one when I was having so much success with the old dialogue box :( I like the ideas though. I know it will work it self out.
What am I doing wrong here? tried to populate by selection not working well, "shape is not available yet". What is the "shape" refering to?

Is this tool similar to Chris's component on surface is similar?

Once again, thanks!
0

lapx 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: arctun, stanley98, zooen and 11 guests

Visit our sponsors: