Superslow SketchUp

The ideal place for beginners to get help using SketchUp

Superslow SketchUp

Postby bogsdolox » Fri Nov 30, 2007 2:50 pm

Hello everybody
I'm new here and pretty new with SketchUp as well. I'm coming across some difficulties in a model that I have been working on and I hope that there is a solution other than the model being too big or detailed. I'm basically making a model of a farm with greenhouses and an orchard. I've modeled the greenhouses myself and copied them eight times after which I downloaded one of the trees from the SketchUp download page and made an orchard of lets say almost 100 trees. Then I plunked a building from the 3D Warehouse into the model and that's it.. The model is now so slow that it will barely open without crashing (and not even allowing me to move around the model if it doesn't crash).

Is that it? Have I reached some sort of size limit of what a SketchUp model can be? The file size is 7,510 Kb.
I've got 2Mb Ram and a CPU that is over 3.0 (should be fine right?)

Please tell me I'm ignorant about something and that I forgot to flip a switch somewhere. Or is it that I should be working with much less detailed models?

Yours truly,
Frustrated Me :(
0

bogsdolox 
 

Re: Superslow SketchUp

Postby Krisidious » Fri Nov 30, 2007 2:51 pm

hey there... welcome.

I believe your issue will be with the 100 trees, to work on your model you'll need to go into the tree component and hide the tree... this will hide every tree that is the same in the whole model.

then when you are ready to render or take shots of the whole project. you'll turn those trees back on.

another option would be putting all your trees (normally very high poly) on a single layer called say "trees" and then turning this layer on and off as needed.

the size of file is pretty open to debate. are you using components for all copied objects and building and trees? are you using clean components? mirrored and cleaned of excess lines?

I take you mean 2gigs of Ram? then if so yes plenty of Ram... but what is your video card and processor type and speed?

hope this helps... if not let us know.
0
By: Kristoff Rand
Home Designer
Unique House Plans
User avatar
Krisidious 
 

Re: Superslow SketchUp

Postby Rodentpete » Fri Nov 30, 2007 2:51 pm

Also while you're working on the model switching off shadows and having faces set to monochrome will speed things up.
0

Rodentpete 
 

Re: Superslow SketchUp

Postby bogsdolox » Fri Nov 30, 2007 2:52 pm

Thanks for your replies.. all good advice.. and yes.. 2Gb :oops:
I didn't make components or use mirrors on my greenhouses but I've simplified them by making the outside surface light grey as opposed to semi-transparent and removed what was inside the structures. I thought I might aswell make two models instead with one being a model of the whole complex with the orchard and basic greenhouses which I could place into GoogleEarth and then a detailed second one of one of the greenhouses which I could use for a walkthrough presentation.

I thought it would be the trees with all the leaves and stuff so I thought I'd use a 2d face-me tree instead. I downloaded one and turned it into a component and told it to face me etc. The problem is that it pivots around the corner of the 2D image as opposed to the middle of the picture where I want it to pivot. Is there any way of changing the pivoting position?
0

bogsdolox 
 

Re: Superslow SketchUp

Postby Rodentpete » Fri Nov 30, 2007 2:52 pm

Right click on the component and select 'change axis', moving that to the middle should do the trick.
0

Rodentpete 
 

Re: Superslow SketchUp

Postby pmiller » Fri Nov 30, 2007 5:03 pm

With respect to your model size of 7 meg or so, be advised that the file size saved on disk is not a true index of your model complexitiy when you have multiple component instances. When you are actually working in sketchup all those trees are in memory -- a better index of true file size can be found under model info/statistics (with show nested components checked) -- namely the number of edges and faces. Some time back Alan Fraser posted a famous example of a model with 100 corinthian column components -- only 100 K or so "file size" but would bring the most powerful computer to a crawl or freeze.

That said, the advice to put your trees on a layer and hide that layer when working is sound, along with keeping shadows and textures turned off until you are ready to render.
0

pmiller 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Newbie Forum

Who is online

Users browsing this forum: Google Bot and 4 guests

Visit our sponsors: