Problème d'installation de plugin

Problème d'installation de plugin

Postby silic » Wed Oct 02, 2013 2:51 pm

Bonjour !

je viens d'installer le plugin dibac, lors de l'ouverture de sketchup il me dit qu'il ne trouve pas les fichiers :
02-10-2013 15-14-14.jpg

les fichiers demandés se trouvent
dans le répertoir plugin de sketchup 2013
0
Silic

Intel i7 CPU X990 3.47GHz-24 Go - Nvidia Quadro 4000 - windows 7 64 - Sketchup 8 pro -Shaderlight - Photoshop - vray - Thea Render...
User avatar
silic 
Premium Member
Premium Member
 

Re: Problème d'installation de plugin

Postby La DuF » Wed Oct 02, 2013 3:07 pm

Bonjour !

Vous avez fait l'installation à la main ? :)

Un seul fichier dans le répertoire "plugins" : iscarnet_dibac.rb

Tous les autres dans le sous-répertoire "plugins\iscarnet_dibac" et les fichiers de traduction des messages dans "plugins\iscarnet_dibac\resources\[xx]", ou [xx] est le code langue (fr pour französich).

Hope this helps,

François
0
User avatar
La DuF 
Premium Member
Premium Member
 

Re: Problème d'installation de plugin

Postby silic » Wed Oct 02, 2013 4:01 pm

ben oui c'est bien à ces emplacements que les fichiers en questions se trouvent !
0
Silic

Intel i7 CPU X990 3.47GHz-24 Go - Nvidia Quadro 4000 - windows 7 64 - Sketchup 8 pro -Shaderlight - Photoshop - vray - Thea Render...
User avatar
silic 
Premium Member
Premium Member
 

Re: Problème d'installation de plugin

Postby La DuF » Wed Oct 02, 2013 4:09 pm

Ha ?!

Bon, ben, méthode de bourrin avant d'appeler le support au secours : désinstaller le plugin, effacer les fichiers et sous-répertoires concernés et recommencer, en install de puis le plugin store.

Désolé, je n'ai pas d'idée plus intelligente.
0
User avatar
La DuF 
Premium Member
Premium Member
 

Re: Problème d'installation de plugin

Postby silic » Wed Oct 02, 2013 4:47 pm

c'est ce que je viens de faire..... pas de résultat, toujours même message....
merci quand même, je contact le support
0
Silic

Intel i7 CPU X990 3.47GHz-24 Go - Nvidia Quadro 4000 - windows 7 64 - Sketchup 8 pro -Shaderlight - Photoshop - vray - Thea Render...
User avatar
silic 
Premium Member
Premium Member
 

Re: Problème d'installation de plugin

Postby silic » Wed Oct 02, 2013 6:06 pm

apparemment je ne suis pas le seul à avoir ce problème.... sûrement un bug
0
Silic

Intel i7 CPU X990 3.47GHz-24 Go - Nvidia Quadro 4000 - windows 7 64 - Sketchup 8 pro -Shaderlight - Photoshop - vray - Thea Render...
User avatar
silic 
Premium Member
Premium Member
 

Re: Problème d'installation de plugin

Postby TIG » Wed Oct 02, 2013 6:24 pm

Do you have a file in [Avez-vous un fichier dans] ../Plugins/iscarnet_dibac named [qui est nommé] dibac_cmd.rbs

If so, then it should load.
[Si oui, alors il devrait charger]

Do you have FULL security permissions to the Plugins folder?
[Avez-vous des autorisations de sécurité complet vers le dossier Plugins?]

If you do not Windows can make it appear that a file/folder is installed, BUT it's actually in a VirtualStore, and then it won't load correctly in SketchUp !
[Si vous n'avez pas, donc Windows peut faire apparaître qu'un fichier/dossier est installé, mais il s'agit en fait d'une VirtualStore, et il ne sera pas charger correctement dans SketchUp!]
Sometimes there is a 'Compatibility Files...' link/button in the Windows Explorer top-bar.
[Parfois, il ya un «fichiers de compatibilité...» lien/bouton dans l'Explorateur Windows top-bar.]

To fix permissions...
As an admin [you may need to give yourself that capability in the Users Control-Panel].
Select the Plugins folder's icon.
Right-click.
Context-menu.
Properties.
Security.
Edit.
Give every user/group listed FULL read/write permissions.
Apply/OK
...
Also:
Select the SketchUp.exe file's icon.
Right-click.
Context-menu.
Properties.
Compatibility.
Tick the Check-box 'Always Run as Administrator'
Apply/OK

[Pour réparer les autorisations ...
En tant qu'administrateur [vous devrez peut-être vous donner cette capacité dans les utilisateurs du panneau de commande].
Sélectionnez l'icône du dossier Plugins.
Faites un clic droit.
Contexte-menu.
Propriétés.
Sécurité.
Modifier.
Donner à chaque utilisateur / groupe énumérés complet en lecture / écriture.
Appliquer / OK
...
Aussi:
Sélectionnez l'icône du fichier SketchUp.exe.
Faites un clic droit.
Contexte-menu.
Propriétés.
Compatibilité.
Cocher la case «Toujours exécuter en tant qu'administrateur"
Appliquer / OK]
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Problème d'installation de plugin

Postby silic » Thu Oct 03, 2013 5:16 pm

merci TIG, j'ai tout essayé, tous les fichiers sont présents, j'ai donné toutes les autorisations.... aucun effet, toujours le même message ! ....
0
Silic

Intel i7 CPU X990 3.47GHz-24 Go - Nvidia Quadro 4000 - windows 7 64 - Sketchup 8 pro -Shaderlight - Photoshop - vray - Thea Render...
User avatar
silic 
Premium Member
Premium Member
 

Re: Problème d'installation de plugin

Postby adebeo » Sun Oct 06, 2013 9:47 am

silic wrote:merci TIG, j'ai tout essayé, tous les fichiers sont présents, j'ai donné toutes les autorisations.... aucun effet, toujours le même message ! ....

Bjr, un accent ou un caractère special dans le nom d'utilisateur ?
0
adebeo
Nos Formations sketchup
Notre blog : www .adebeo.com/wp/
Nos tutoriels: www .youtube.com/adebeo

adebeo 
Premium Member
Premium Member
 

Re: Problème d'installation de plugin

Postby TIG » Sun Oct 06, 2013 10:15 am

Does it load OR give the same error, if you type this in the Ruby Console:
[Est-il charger ou donner la même erreur, si vous tapez ceci dans la Console Ruby:]
Sketchup::require('iscarnet_dibac/dibac_cmd.rbs')
I suspect that although the file/folder looks like it is in the Plugins folder, in fact it's in a VirtualStore.
Please double check that you [and everyone else listed] has FULL [read/write] security permissions to the Plugins folder, then reinstall the toolset and retry...
[Je soupçonne que si le fichier / dossier dirait qu'il est dans le dossier Plugins, en fait, c'est dans un VirtualStore.
Veuillez revérifier que vous [et tout le monde énumérés] a pleine [lire / écrire] des autorisations de sécurité dans le dossier Plugins, puis réinstaller l'ensemble d'outils et de réessayer ...]
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Problème d'installation de plugin

Postby silic » Sun Oct 06, 2013 10:15 pm

TIG wrote:Does it load OR give the same error, if you type this in the Ruby Console:
[Est-il charger ou donner la même erreur, si vous tapez ceci dans la Console Ruby:]
Sketchup::require('iscarnet_dibac/dibac_cmd.rbs')


c'est ok avec ta commande ça fonctionne :thumb:
mais je dois refaire la même manipulation à chaque ouverture de sketchup !
quel est le problème ? et comment corriger, est-ce que je peux modifier le fichier "iscarnet_dibac.rb" et comment ?
0
Silic

Intel i7 CPU X990 3.47GHz-24 Go - Nvidia Quadro 4000 - windows 7 64 - Sketchup 8 pro -Shaderlight - Photoshop - vray - Thea Render...
User avatar
silic 
Premium Member
Premium Member
 

Re: Problème d'installation de plugin

Postby TIG » Sun Oct 06, 2013 10:41 pm

Try this hack...
Edit ..Plugins/iscarnet_dibac.rb with Notepad [NOT a word-processor].
Find the line that says: dibac = SketchupExtension.new "Dibac","iscarnet_dibac/dibac_cmd.rbs"
Change it to read: dibac = SketchupExtension.new("Dibac","iscarnet_dibac/dibac_loader.rb")
Save it.
Make a new file in the folder ../Plugins/iscarnet_dibac named dibac_loader.rb
Add this line single line of code into it: Sketchup::require(File.join(File.dirname(__FILE__)), "dibac_cmd.rbs")
Save it.
Restart SketchUp... the 'loader.rb' should now sort out the 'rbs' file - I suspect it's because you have non-ASCII characters in your folder path to Plugins [perhaps é in some folder names ?] and the 'require' creation in the extension method can't cope with it...

I can't test this...
If it doesn't work revert back to the original, you are no worse off...


Essayez ce hack ...
Modifier ..Plugins/iscarnet_dibac.rb avec Notepad [PAS un 'traitement de texte'].
Trouvez la ligne qui dit: dibac = SketchupExtension.new "Dibac", "iscarnet_dibac/dibac_cmd.rbs"
Changer pour lire: diabc = SketchupExtension.new ("Dibac", "iscarnet_dibac/dibac_loader.rb")
Enregistrez-le.
Créez un nouveau fichier dans le dossier ../Plugins/iscarnet_dibac nommé dibac_loader.rb
Ajoutez cette ligne seule ligne de code dedans: Sketchup::require(File.join(File.dirname (__FILE__)), "dibac_cmd.rbs")
Enregistrez-le.
Redémarrez SketchUp... le 'loader.rb' devrait maintenant régler le dossier du 'rbs' - Je soupçonne que c'est parce que vous avez des caractères non-ASCII dans votre chemin de dossier Plugins et le 'require' création de l'extension [peut-être é dans certains noms de dossiers?] méthode ne peut pas composer avec elle...

Je ne peux pas tester cette ...
Si cela ne fonctionne pas revenir à l'original, vous êtes pas pire ...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Problème d'installation de plugin

Postby silic » Sun Oct 06, 2013 11:22 pm

j'ai essayé votre dernière démarche, un nouveau message d'erreur apparaît au lancement de sketchup :

wrong number of arguments (2 for 1)
Erreur de chargement du fichier iscarnet_dibac.rb
wrong number of arguments (2 for 1)
0
Silic

Intel i7 CPU X990 3.47GHz-24 Go - Nvidia Quadro 4000 - windows 7 64 - Sketchup 8 pro -Shaderlight - Photoshop - vray - Thea Render...
User avatar
silic 
Premium Member
Premium Member
 

Re: Problème d'installation de plugin

Postby TIG » Mon Oct 07, 2013 10:19 am

Sorry, a typo!
Add the like exactly like this:
Sketchup::require(File.join(File.dirname(__FILE__), "dibac_cmd.rbs"))
and <enter> [return]
:oops:
Désolé, une erreur de frappe!
Ajouter l'aime exactement comme ceci:
Sketchup::require(File.join(File.dirname(__FILE__), "dibac_cmd.rbs"))
et <enter> [retour]
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Problème d'installation de plugin

Postby silic » Mon Oct 07, 2013 2:00 pm

un tout GRAND Merci TIG, on est sur le bon chemin.

maintenant ça charge, et ça à l'air de fonctionner,

il reste 2 problèmes :

nouveau message d'erreur :
07-10-2013 14-53-27.jpg


et lorsque je clique sur un des 2 derniers icone de la boîte d'outil, les bontons viennent s'afficher à double :
07-10-2013 14-55-59.jpg

07-10-2013 14-57-04.jpg
0
Silic

Intel i7 CPU X990 3.47GHz-24 Go - Nvidia Quadro 4000 - windows 7 64 - Sketchup 8 pro -Shaderlight - Photoshop - vray - Thea Render...
User avatar
silic 
Premium Member
Premium Member
 

Re: Problème d'installation de plugin

Postby TIG » Mon Oct 07, 2013 5:00 pm

This is getting too complicated.
I suspect it's to do with my earlier point about non-ASCII characters in the path.
Because they have no simple 'rb' loaders to adjust, but rather compiled rbs files, it's all but impossible to resolve without their input !
You need to raise the issue direct with Dibac...
Cela devient trop compliqué.
Je soupçonne que c'est à voir avec mon point de vue tout à l'heure des caractères non-ASCII dans le chemin.
Parce qu'ils n'ont pas de chargeurs de 'rb' simples à régler, mais plutôt compilés fichiers 'rbs', il est tout simplement impossible à résoudre sans leur entrée !
Vous devez soulever la question directement avec Dibac ...

:(
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Problème d'installation de plugin

Postby silic » Mon Oct 07, 2013 5:24 pm

En tout cas merci beaucoup TIG pour le temps que tu as pris pour moi ! je vais investiguer plus loin directement chez iscarnet.

Merci
0
Silic

Intel i7 CPU X990 3.47GHz-24 Go - Nvidia Quadro 4000 - windows 7 64 - Sketchup 8 pro -Shaderlight - Photoshop - vray - Thea Render...
User avatar
silic 
Premium Member
Premium Member
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Français

Who is online

Users browsing this forum: Google Feedfetcher and 3 guests

Visit our sponsors: