[REQ/BUG] Scatter in components

General discusson for Skatter for SketchUp

Moderator: jiminy-billy-bob

[REQ/BUG] Scatter in components

Postby Pixero » Sat Oct 24, 2015 12:59 pm

Not sure what to call this if it's a bug or a missing feature.
I tried scattering an a plane inside a component and then copying the component and there were no scatter in the copied component. I also tried adding the copied component to the scatter but it says it's already selected.
Having scatter working with components would be great.
This would be very useful feature I think.
0
User avatar
Pixero 
 

Re: [REQ/BUG] Scatter in components

Postby jiminy-billy-bob » Sat Oct 24, 2015 5:10 pm

Could you make a small gif/video showing the issue? I'm not sure I understand.

Note that when you click "Generate" without "Render Only", the group containing all the scattered items will be created in the current context. It doesn't take into account the context of the surfaces you've picked.
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [REQ/BUG] Scatter in components

Postby Pixero » Sun Oct 25, 2015 2:54 pm

Scatter_in_component.skp


Here is a test scene with a grouped plane inside a component.
The one to the left is the original where I have skattered components as render only.
The one to the right is a copy of the first component and at render nothing shows up inside it.
If I click to add that surface in Skatter it says its already selected.
Not sure if it's a bug or a missing feature.

I think it would be very useful to be able to skatter things inside a component and then copy the component around and have the skattered items show up in rendering.

I hope this explains better what I'm trying to do.
0
User avatar
Pixero 
 

Re: [REQ/BUG] Scatter in components

Postby JQL » Sun Oct 25, 2015 8:51 pm

Of course Pixero, you don't want to scatter proxy components into those components (wich is already possible), what you want is that this happens at render time only right?

I'd also think this would be useful!
0
User avatar
JQL 
Premium Member
Premium Member
 

Re: [REQ/BUG] Scatter in components

Postby Pixero » Sun Oct 25, 2015 9:29 pm

Yes, at render time. I can see lots of uses for this.
0
User avatar
Pixero 
 

Re: [REQ/BUG] Scatter in components

Postby jiminy-billy-bob » Mon Oct 26, 2015 6:03 pm

Ok I see what you want to do.
I guess I could have an observer on selected surfaces to track when they are copied and ask you if you also want to copy the Skatter setup.
But I don't think it should be silent and default.

Pixero wrote:If I click to add that surface in Skatter it says its already selected.

This is not normal and shouldn't happen. I can't reproduce this.
Does it happen everytime?
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [REQ/BUG] Scatter in components

Postby Pixero » Mon Oct 26, 2015 6:29 pm

I tried the test scene again and opened the component and clicked to add the (copied) grouped surface. I didn't get the popup now but it won't add the surface.
0
User avatar
Pixero 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Skatter

Who is online

Users browsing this forum: No registered users and 1 guest

Visit our sponsors: