[BUG] Nothing on surface

General discusson for Skatter for SketchUp

Moderator: jiminy-billy-bob

[BUG] Nothing on surface

Postby Rich O Brien » Tue Dec 02, 2014 10:00 pm

---- Skatter ----
Processing surface 1M_APt$Xz2hxUHZeMx4fxz
Points to lines : 0.0 s
---

View redraw : 0.034027 s
Total : 0.055042 s
------ End ------
-----------------

I get nada ?
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [RELEASE] Alpha 0.0.3

Postby Rich O Brien » Tue Dec 02, 2014 10:01 pm

Code: Select all
Error: #<NoMethodError: undefined method `[]' for -0.22452:Float>
C:/Users/Rich/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/methods.rb:215:in `block (2 levels) in find_faces'
C:/Users/Rich/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/methods.rb:215:in `map'
C:/Users/Rich/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/methods.rb:215:in `block in find_faces'
C:/Users/Rich/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/methods.rb:215:in `map'
C:/Users/Rich/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/methods.rb:215:in `find_faces'
C:/Users/Rich/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/jbb_skatter/rb/tools.rb:58:in `onMouseMove'


A bit more
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [RELEASE] Alpha 0.0.3

Postby jiminy-billy-bob » Tue Dec 02, 2014 10:03 pm

Could you share the model?
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [RELEASE] Alpha 0.0.3

Postby Rich O Brien » Tue Dec 02, 2014 11:22 pm

marigold.skp
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [RELEASE] Alpha 0.0.3

Postby jiminy-billy-bob » Tue Dec 02, 2014 11:25 pm

Thank you.
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [BUG] Nothing on surface

Postby jiminy-billy-bob » Tue Dec 02, 2014 11:33 pm

Ok, I see the issue.
Your scale is wrong. The surface you are trying to scatter on is way too small compared to the default "spacing" value.
You can either scale up your objects, or decrease the the spacing (You'll get giant red spikes as preview)

As for the second error (not related to the first), it happens when you try to pick (as a surface or scattered object) the flowers. The issue is related to the hovering feedback, but you can still pick the object, it'll work.
I'll investigate and try to fix it.
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [BUG] Nothing on surface

Postby Rich O Brien » Tue Dec 02, 2014 11:38 pm

I thought I'd adjusted for that?

I'll experiment a bit more.
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [BUG] Nothing on surface

Postby jiminy-billy-bob » Tue Dec 02, 2014 11:43 pm

Rich O Brien wrote:I thought I'd adjusted for that?

Well, it's really small :)
I had to put 1 inch by 1 inch to see only two projected points.
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [BUG] Nothing on surface

Postby Rich O Brien » Wed Dec 03, 2014 10:49 am

Haha...i sent you the unscaled definition. at #1" tall. sorry.
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Skatter

cron

Who is online

Users browsing this forum: No registered users and 1 guest

Visit our sponsors: