Error in Profile builder 3

Error in Profile builder 3

Postby deaneau » Mon Aug 19, 2019 11:33 am

Profile Builder produces an error

in the secound picture: PB3 will not work with profiles 1-1-7mm. At 1,8mm the profile is broken.

thank you

https://1drv.ms/u/s!AoU3tpJxqmvto3fSKun ... 7?e=JRWFhG


0
MADE, BORN AND LIVING IN BERLIN
Big Thank You to all Programmers
Some German words are so long that they have a perspective. M.Twain
User avatar
deaneau 
 

Re: Error in Profile builder 3

Postby pbacot » Mon Aug 19, 2019 8:50 pm

Could this be the small face limitation in SketchUp not PB. Try: Make a component of your work. Make a copy of the component and scale up 1000x. Perform the operation on the big copy of the component. Check that changes were made correctly in the original instance of the component.
1
MacOSX Mojave ShetchUp Pro v19 Twilight Pro v2 M2 Kerkythea PowerCADD
User avatar
pbacot 
Top SketchUcator
 

Re: Error in Profile builder 3

Postby deaneau » Wed Aug 21, 2019 3:52 am

ProfileBuilder2 have not this problem (1mm profil in the foreground)
0
MADE, BORN AND LIVING IN BERLIN
Big Thank You to all Programmers
Some German words are so long that they have a perspective. M.Twain
User avatar
deaneau 
 

Re: Error in Profile builder 3

Postby Whaat » Fri Aug 30, 2019 7:26 pm

Can you try changing the extrude mode to Follow Me? You might get better results.

Can you please post the SKP file so I can test it? A lot of extrusion improvements were made in PB3 but there are some unusual situations that could give you strange results (eg. very small profiles combined with certain types of extrusion paths)

Thank you very much for the feedback
0

Whaat 
PluginStore Author
PluginStore Author
 

Re: Error in Profile builder 3

Postby deaneau » Thu Sep 05, 2019 7:57 am

0
MADE, BORN AND LIVING IN BERLIN
Big Thank You to all Programmers
Some German words are so long that they have a perspective. M.Twain
User avatar
deaneau 
 

Re: Error in Profile builder 3

Postby Whaat » Fri Sep 06, 2019 12:04 am

I'm not sure why PB2 worked, but PB3 has trouble with this due to a combination of the small scale of the model and also the type of path. There seems to be an issue with PB3 when extruding along a circular path where the path's axis is horizontal. The issue will not always occur. It depends on a number of things so this is somewhat of a corner-case that you have discovered.

We have logged this issue and will try to fix it in a future update. Thank you for bringing it to our attention.

As a workaround, avoid using very small profiles and try not to extrude around a circular path that has a horizontal axis.  It will more likely work if you extrude along a circular path where the axis of the circle points vertical.  Then, after creating the Profile Member, rotate it and move it into the proper position.
0

Whaat 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to Plugins

Who is online

Users browsing this forum: anana and 9 guests

Visit our sponsors: