MSPhysics 1.0.3 (16 October 2017)

Re: MSPhysics 0.9.3 (August 2, 2016)

Postby chrisjmitchell » Wed Oct 05, 2016 12:39 am

Still dead on my end. It's like it partially locks up. Once I click the play button it starts acting weird. When I try to push things around all it does is try and draw a selection box.
0
User avatar
chrisjmitchell 
 

Re: MSPhysics 0.9.3 (August 2, 2016)

Postby Anton_S » Wed Oct 05, 2016 7:53 am

@surfmike In case you're dealing with tiny objects in your model, you need to adjust some world parameters. For your model, changing gravity to -1.0 and setting world scale to 20 prevents the penetration. Furthermore, In order to get the servo to interact with objects A and B, more precisely have the servo rotate object B with respect to object A, you should group the servo joint with object A and then, use the Joint Connection Tool to connect the servo with object B. The connection can be done by activating the Joint Connection Tool, selecting the servo joint, holding down the control or shift button, and then selecting a desired group (object B in your case).

@chrisjmitchel, I don't know what may be causing the error. What you can do is open Ruby Console, press Toggle Play, and then try clicking on the objects. If there's an error it might be outputted in the console.
0

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.3 (August 2, 2016)

Postby Anton_S » Wed Oct 05, 2016 8:23 am

bambutec wrote:Hey Guys,

just dowloaded MSPhysics. Using a model like ray_test_0.9.skp , for me any change of properties like friction coefficients resp. change of materials do not reflect in how body´s behave. What could be the reason ?

My platform is a mac on OS X 10.11.4 with SketchUp Pro 2016 16.0.19913.

My intend is to simulate slide configurations and other attractions in Play and Leisure applications. Close to reality behavior is essential.

Would be so great if this works, it is very promising !!

Regards

Uli

My apologies for not responding, bambutec. I didn't see your post. I can indeed reproduce the friction bug on my Windows platform. I will notify you once it's fixed. Thanks for the report!
0

Anton_S 
PluginStore Author
PluginStore Author
 

Re: How can I install MSPhysics in Mac OS X?

Postby Anton_S » Wed Oct 05, 2016 8:32 am

realkim0123 wrote:There is the only install program for Window environments.
How can I install MSPhysics in Mac OS X?

Yes, at the moment there is no installer for Mac OS X. To install it on Mac OS X, download MSPhysics_0.x.y.rbz, open SketchUp, navigate and select (Menu) Windows -> Preferences. Then click on Extensions tab, "install Extension..." button, select MSPhysics_0.x.y.rbz and click open. Following these steps should install you MSPhysics on Mac OS X.
0

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.3 (August 2, 2016)

Postby Anton_S » Wed Oct 05, 2016 8:45 am

MALAISE wrote:Hallo Guys

Good to know ( on SketchUp2015 or 2016 /windows 32 bit), It seems that only the 60 first
pictures are exported. Perhaps, it's matter of Windows Version.

Pierre

Hello Pierre,

I tried recording your model and then exporting animation into PNG images, and I was able to export more than 60 of them. So, you do know the proper steps for recording and exporting animation, right? In order to export you need to record simulation, for a suitable time. If you recorded for 60 frames, then only a maximum of 60 frames would be exported (unless your speed was less that one). So, maybe you need to record it for a bit more time prior to exporting it. Another reason to that may be the export settings. The actual quantity of images exported in an animation is ("End Frame" - "Start Frame") / "Speed". Maybe altering one of these parameters in the export settings might fix the issue on your end.

Hope that helps,
Anton
0

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.3 (August 2, 2016)

Postby surfmike » Wed Oct 05, 2016 9:01 am

Anton_S wrote:@surfmike In case you're dealing with tiny objects in your model, you need to adjust some world parameters. For your model, changing gravity to -1.0 and setting world scale to 20 prevents the penetration.


Group the joint with object A worked out way better. Thanks.
However the other "sink into ground" issue still remains.
Do I have the right settings?

Also the test file "curvy_joints.skp" have the same issue...

Screen Shot 2016-10-05 at 09.57.17.png
0

surfmike 
 

Re: MSPhysics 0.9.3 (August 2, 2016)

Postby Anton_S » Wed Oct 05, 2016 4:41 pm

How about you try setting material thickness to 1.0. Maybe that will prevent the issue. In Newton, there is always fraction al penetration however you can adjust world properties to minimize it.
0

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.3 (August 2, 2016)

Postby surfmike » Thu Oct 06, 2016 8:34 am

Nope, material thickness 1.0 made it even worse. The objects also started shattering...
0

surfmike 
 

Re: MSPhysics 0.9.3 (August 2, 2016)

Postby chrisjmitchell » Thu Oct 06, 2016 6:05 pm

Thanks Anton, that did produce an error, though I don't understand it.
Here is what it gave me:

Code: Select all
Error: #<NoMethodError: undefined method `solver_model=' for #<MSPhysics::World:0x0000001036bf18 @address=287093504>>
C:/Users/Chris/Dropbox/Sketchup Stuff/Plugins/MSPhysics/simulation.rb:2632:in `activate'
C:/Users/Chris/Dropbox/Sketchup Stuff/Plugins/MSPhysics/simulation.rb:27:in `select_tool'
C:/Users/Chris/Dropbox/Sketchup Stuff/Plugins/MSPhysics/simulation.rb:27:in `start'
C:/Users/Chris/Dropbox/Sketchup Stuff/Plugins/MSPhysics/main.rb:575:in `block in <top (required)>'
SketchUp:1:in `call'
Error: #<NoMethodError: undefined method `valid?' for #<MSPhysics::World:0x0000001036bf18 @address=287093504>>
C:/Users/Chris/Dropbox/Sketchup Stuff/Plugins/MSPhysics/simulation.rb:3181:in `getExtents'
Error: #<NoMethodError: undefined method `valid?' for #<MSPhysics::World:0x0000001036bf18 @address=287093504>>
C:/Users/Chris/Dropbox/Sketchup Stuff/Plugins/MSPhysics/simulation.rb:2761:in `deactivate'
C:/Users/Chris/Dropbox/Sketchup Stuff/Plugins/MSPhysics/simulation.rb:35:in `select_tool'
C:/Users/Chris/Dropbox/Sketchup Stuff/Plugins/MSPhysics/simulation.rb:35:in `reset'
C:/Users/Chris/Dropbox/Sketchup Stuff/Plugins/MSPhysics/simulation.rb:2164:in `abort'
C:/Users/Chris/Dropbox/Sketchup Stuff/Plugins/MSPhysics/simulation.rb:2148:in `rescue in call_event'
C:/Users/Chris/Dropbox/Sketchup Stuff/Plugins/MSPhysics/simulation.rb:2141:in `call_event'
C:/Users/Chris/Dropbox/Sketchup Stuff/Plugins/MSPhysics/simulation.rb:2948:in `onMouseMove'


Thanks for looking at this!

Never mind.... It was idiot error! I had installed it through Sketucation AND through the Ext Warehouse and that was causing the problem.

Thanks again!
1
User avatar
chrisjmitchell 
 

Re: MSPhysics 0.9.3 (August 2, 2016)

Postby Anton_S » Thu Oct 06, 2016 10:32 pm

surfmike wrote:Nope, material thickness 1.0 made it even worse. The objects also started shattering...

Sutfmike does that happen to the sample model you posted here?
0

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.3 (August 2, 2016)

Postby surfmike » Fri Oct 07, 2016 7:20 am

Anton_S, yes it does, also the same happens in the "curvy_joints.skp" file as well.
We're talking of a minor sag, but still...
0

surfmike 
 

Re: MSPhysics 0.9.3 (August 2, 2016)

Postby Anton_S » Sat Oct 08, 2016 8:44 am

Surfmike, one last thing I can recommend is changed solver model to 64 passes.
0

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.4 (8 October 2016)

Postby faust07 » Mon Oct 10, 2016 1:37 pm

A new version 0.9.4 in the first post but I can not find any information about what has been changed...?
0

faust07 
 

Re: MSPhysics 0.9.4 (8 October 2016)

Postby Pixero » Mon Oct 10, 2016 3:28 pm

I recently saw a IKEA presentation where they used a custom plugin in Max for placing things more naturally. It had no setup if I'm not mistaken.
Would it be possible for a quick use mode where you with minimal input could simulate things like pens in a mug or stacked items like plates, books and such?
The key word is "minimal input" for quick, one time simulations like the above examples.
1
User avatar
Pixero 
 

Re: MSPhysics 0.9.4 (8 October 2016)

Postby Anton_S » Mon Oct 10, 2016 6:12 pm

Faust, I fixed the friction bug and improved start performamce witb joints in this, 0.9.4, version . However, I did break some things in the dialog. So I guess you're going to have to wait till next week for the fix.

Pixero, that's interesting. At the moment there is no simple way of simulating for siref groups till they stop, however, I added this to the list.
0

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.4 (8 October 2016)

Postby Pixero » Wed Oct 12, 2016 8:29 am

Here is some more info on IKEA's "earthquake" plugin:
http://vimeo.com/163789781

It starts approx 23 minutes in but the whole video is very interesting to watch.

Martin says in the comments:
"The physics simulation is using a physics engine and is a plugin. Only one button setup. All hidden geometry is not used. All non selected will be unyeilding and all selected gets hardbody physics properties."

Something like this would be very useful in SketchUp.
0
User avatar
Pixero 
 

Re: MSPhysics 0.9.4 (8 October 2016)

Postby faust07 » Thu Oct 13, 2016 7:54 pm

Not new - but SketchUp + MSPhysics. The rendered version looks much better... :fro:
Time: Modelling and MSPhysics 0,5 h; Layout and GIF-Output for this post 1,5 h (max. 2 MB)...
Edit: + a quick indigo render frame...
2

faust07 
 

Re: MSPhysics 0.9.4 (8 October 2016)

Postby SynSuka3D » Mon Oct 17, 2016 5:54 pm

hello
how to change the color of a solid?
-----------
I tried :
onStart{
@box = simulation.find_body_by_name("box")
or
@box = simulation.find_group_by_name("box")
}

onUpdate{
if key("up") == 1
@box.material.color = [0, 255, 0]
Else
@box.material.color = [255, 255, 255]
end
}



Envoyé de mon PRO 5 en utilisant Tapatalk

help me if please.
0

SynSuka3D 
 

Re: MSPhysics 0.9.4 (8 October 2016)

Postby PituPhysics » Tue Oct 18, 2016 6:06 am

SynSuka3D wrote:hello
how to change the color of a solid?
-----------
I tried :
onStart{
@box = simulation.find_body_by_name("box")
or
@box = simulation.find_group_by_name("box")
}

onUpdate{
if key("up") == 1
@box.material.color = [0, 255, 0]
Else
@box.material.color = [255, 255, 255]
end
}



Envoyé de mon PRO 5 en utilisant Tapatalk

help me if please.


Hi, select the Paint Bucket and add material to group and try again.
0

PituPhysics 
 

Re: MSPhysics 0.9.4 (8 October 2016)

Postby Anton_S » Tue Oct 18, 2016 7:23 am

Pixero, I'm working on that feature.


Faust, that's a stunning piece of animation!


SynSuka3d, like Istvan implied, you can add material to group prior to changing its color. You can also do it with script, in case the group doesn't have a material associated with it. However, if the inner faces are already colored by a different material, you must decolor them to default material, both front and back faces, so that the group's top level material is able to color them.

Note that the object that contains the script should be part of simulation, that is not ignored; otherwise, the script of that object won't execute.

Now, to answer your question, if the script is associated within the body you're coloring, you can have @box = this.group. Otherwise, it should be @box = simulation.find_group_by_name("box"). Note that the name is case sensitive and considers all the blank spaces. Anyway, here is the script containing it all:
Code: Select all
onStart{
  @box = simulation.find_group_by_name("box")
  # Add material to the box in case the box has no material.
  if @box.material.nil?
    mat = Sketchup.active_model.materials.add("BoxMaterial")
    @box.material = mat
    mat.color = [255,255,255] # optional
  end
  # Record starting color, just so we can reset it in the end
  @starting_color = @box.material.color
  # Utilize 'flag' variable to avoid coloring group the same color multiple times.
  # Just for optimization purpoposes...
  @flag = nil
}

onUpdate{
  if key("up") == 1
    if @flag != 1
      @box.material.color = [0, 255, 0]
      @flag = 1
    end
  elsif @flag == 1
    @box.material.color = [255, 255, 255]
    @flag = 0
  end
}

onEnd {
  # Reset color (also optional).
  @box.material.color = @starting_color
}
2

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.4 (8 October 2016)

Postby SynSuka3D » Tue Oct 18, 2016 2:35 pm

Thank you Anton_S
Good !!! :mrgreen:

manage transparency of objects ?
alpha ? script

Envoyé de mon PRO 5 en utilisant Tapatalk
0

SynSuka3D 
 

Re: MSPhysics 0.9.4 (8 October 2016)

Postby Anton_S » Tue Oct 18, 2016 10:30 pm

SynSuka3D, to change opacity, you have to utilize the material's alpha function: http://www.sketchup.com/intl/en/developer/docs/ourdoc/material#alpha=. For your model it would look like this: @box.material.alpha = 0.5 or any other alpha ranging from 0.0 (transparent) to 1.0 (opaque).
1

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.4 (8 October 2016)

Postby ITman496 » Mon Oct 31, 2016 9:07 am

I have a bug to report, maybe. I've noticed that if you use programmed ratios for things, such as gear reduction, if you leave objects as default (where they can sleep when still) you can cause things to sort of slip, and lose sync with each other. (example: gear teeth phase into each other)

The only way to stop this seems to be to make them never sleep. Is this behaving as intended?

I also have a file that causes crashes when I try to make a door work, but it seems to have stopped doing it. I will attempt to re-create the bug and post the file here.
0

ITman496 
 

Re: MSPhysics 0.9.5 (31 October 2016)

Postby Anton_S » Mon Oct 31, 2016 9:54 am

Announcing version 0.9.5!
This version comes with more compatibility with Mac OS X. Now keyboard input and MIDI work on Mac OS X too. Also, a few new features were added, such as another play button, along with plenty of fixes, upgrades, and improvements. Check out the ChangeLog for more information.
0

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.5 Installation

Postby count_olaf » Tue Nov 01, 2016 2:34 pm

Hi. Hope you can help as I'm unable to get past an install error on Windows (64 bit machine). I'm using Sketchup Pro 2015 and attempting to install on a device connected to a workplace network which I think is the cause of the problem. I can install it successfully on a separate standalone (at home) laptop. I am installing with network administrator rights.

Having installed both the ams library v3.4.0 and ms physics v0.9.5 through the sketchucation plugin store button within sketchup, they both give confirmation messages that they have successfully installed. They both appear in the window>preferences>extensions list and are checked. At this point no toolbars are available, so I restart sketchup. I then receive this message...

Error Loading File C:/Users/SS7U6035/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/MSPhysics/main.rb
Error: #<Exception: An exception occurred while loading MSPhysics library. The exception occurred due to one or more of the following reasons:
- LoadError: 161: The specified path is invalid. - C:/Users/SS7U6035/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/MSPhysics/win64/2.0/msp_lib.so
- LoadError: 161: The specified path is invalid. - C:/Users/SS7U6035/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/MSPhysics/win64/2.0/msp_lib_no_sdl.so
>
F:/Sketchup/Sketchup 2015/Tools/extensions.rb:197:in `require'
F:/Sketchup/Sketchup 2015/Tools/extensions.rb:197:in `load'
C:/Users/SS7U6035/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/MSPhysics.rb:90:in `register_extension'
C:/Users/SS7U6035/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/MSPhysics.rb:90:in `<module:MSPhysics>'
C:/Users/SS7U6035/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/MSPhysics.rb:72:in `<top (required)>'

All the files and paths listed in the error message are present and correct in those locations. Grateful for any suggestions.

Thanks
0

count_olaf 
 

Re: MSPhysics 0.9.5 (31 October 2016)

Postby Anton_S » Tue Nov 01, 2016 7:08 pm

Thank you for your insightful report, count_olaf. I will investigate it as soon as possible.
0

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.5 (31 October 2016)

Postby faust07 » Tue Nov 01, 2016 9:05 pm

Update from 9.3 to 9.5 did not work with installation in Extension Store. The old files ams_Lib.hash and MSPhysics.hash are not deleted and old models did not work. Installation per hand by deleting the old directories and copy the new to the plugin folder works...
The new selection functions are great to test parts of large models - fantastic!!!
0

faust07 
 

Re: MSPhysics 0.9.5 (31 October 2016)

Postby Anton_S » Tue Nov 01, 2016 9:35 pm

Oh that explains the issue. I didn't sign the extensions due to technical issues. Why did the plugin packaging had to become more complicated? Really! That's why y'all got errors. Anyway, so, count_olaf, as faust suggested, to fix that you have to delete original versions first and then install the new ones. This process might not be necessary after the extensions will be signed, which I will so shortly.
0

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.5 (31 October 2016)

Postby Anton_S » Tue Nov 01, 2016 11:05 pm

Well, I just tried signing my extensions and unfortunately the extension signature tool doesn't work. So, y'all have to do it the hard way for now, that is first delete original AMS Library and MSPhysics versions and then install the new ones in place (do not overwrite).
0

Anton_S 
PluginStore Author
PluginStore Author
 

Re: MSPhysics 0.9.5 (31 October 2016)

Postby SynSuka3D » Tue Nov 01, 2016 11:10 pm

[LOUDLY CRYING FACE]

0

SynSuka3D 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: ria21, TRANTHAIQUI and 10 guests

Visit our sponsors: