[Plugin] RichSection V0.5.8 UPDATED march 2015  Topic is solved

Re: [Plugin] RichSection [Demo]

Postby ArCAD-UK » Wed Dec 04, 2013 1:15 am

Sorry. I thought you might be more receptive to end user / potential customer feedback.

Obviously I'm wasting my time testing the demo. :?
0

ArCAD-UK 
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Wed Dec 04, 2013 7:52 am

Rich O Brien wrote:Try again


GOT IT, Thanks :thumb:
0

pgarmyn 
PluginStore Author
PluginStore Author
 

[Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby pgarmyn » Wed Dec 04, 2013 8:49 pm

RichSection is now in the 'SketchUcation Plugin Store' browser...
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby JQL » Thu Dec 05, 2013 2:02 am

Hi pgarmyn, I've been willing to test your plugin since a while now.

It is very good, fast and does what it purposes. Though in my workflow I still have some issues because of what I told you about in some posts earlier, I can see it becoming useful in the near future.

What I really like about it is that it creates instantly the ortho scenes (I must agree that so much "twin" scenes is a bit too much though. (for style saving wouldn't 1 of this scenes be enough? Well I suppose not...)

The projection feature by itself is a must but it will be erased by delete guides for sure every now and then. SU should be able not to delete at least the guides that are inside a locked group...

I have probably a bug and a question for you though, and you can look at attached images and file for more info on BUG and QUESTION

RICHSECTION - Test.png


BUG (?) - I deleted a material that I previously have used as rich section (#Insulation) and then inserted a new material and named it after the deleted one. Rich section doesn't deal with the new (#Insulation) material. All groups in Layer Insulation now are getting sections on the #default material.

RICHSECTION - Wall.png


QUESTION - Would you consider adding a feature that would find loops in sections corresponding to groups inside other groups? Now, if you have those cases, sections from different groups will not intersect. They wiil only juxtapose/interfere on each other creating the effect that happens with two coplanar faces with different textures applied. It would probably be a viable alternative for getting some more detail in models.

RICHSECTION - Column.png


Right now this feature and the fact that a lot of layers, materials and scenes are created that I don't need, are the only things keeping me waiting for further developments.

RICHSECTION - Test.skp


Congratulations again and best regards,

JQL
0
User avatar
JQL 
Premium Member
Premium Member
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby pgarmyn » Thu Dec 05, 2013 8:09 am

@JQL
I will take some time this evening to look at your file.
About the number of files and scenes: At this moment I need at least a scene and a style with the sectionplan active and visible, and without the camera applied. They are activated before changing parameters and (re)calculation. But the purpose is to use the result directly in Layout. To use it, the camera must be applied by and the sectionplan should be made invisible. Therefore I need a second scene. there is no way to hide a scene(?) I could load and save one scene on disk, but that will slow down, give a lot off crashes, and will give problems with the Undo-action.

I will continue this evening....
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby mladen90 » Thu Dec 05, 2013 1:08 pm

Hello again.

I wouldn't like to bore you with my problems,
my intention is to help with development of this great plugin.

New version fixed expiration problem.
But I'm afraid plugin is not working for me at all.
Rich section creates scenes and materials, but no new faces are added.

I did a fresh install of skp without all plugins but problem remains.
Ruby console doesn't report any exception.

I attached screenshot to describe problem...

It is sketchup 2013 on Win7 and newest release of RS from sketchucation plugin manager.
Maybe i'm missing some of extended or inherited rb's?
I hope it's problem on my side, so others can enjoy this plugin.
But i thought this should be reported as well.
0

mladen90 
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby pgarmyn » Thu Dec 05, 2013 1:38 pm

@mladen90

Your screenshot is very complete :
I see that you have 0 groups and 0 component-instances.
RS generates only sectionplans of grouped elements or components (as explained in the first post)
The sectionplan can't be within de same context (= within the group or a component).

OK :?: Was that the solution :?:
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby JQL » Thu Dec 05, 2013 2:32 pm

Thanks for taking your time to answer pgarmyn, I understand the need for those scenes and the workarounds you have to acomplish to get this working. As it is right now it is a very automatic process wich is excellent.

For simple presentations it's excellent, but for complex projects it probably creates some confusion with those extra scenes and layers. However there are viable alternatives for managing that too so you don't have to feel you should alter the scheme you have (wich you probably can't because of the limitations you described).

The problem is that the plugin has already so much potential, that I'll keep testing it and sometimes bothering you a bit. I hope you don't mind.

Best regards and thanks,

JQL
0
User avatar
JQL 
Premium Member
Premium Member
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby mladen90 » Thu Dec 05, 2013 6:46 pm

pgarmyn wrote:@mladen90

Your screenshot is very complete :
I see that you have 0 groups and 0 component-instances.
RS generates only sectionplans of grouped elements or components (as explained in the first post)
The sectionplan can't be within de same context (= within the group or a component).

OK :?: Was that the solution :?:


I feel like such dumbass.
Works very well.
Thank you so much, and sorry for bothering you without reading...
0

mladen90 
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby pgarmyn » Thu Dec 05, 2013 10:07 pm

@JQL

About the Bug that isn't one : There was a blanc space in the beginning of your “ #Insulation” material. If you use the right name “#Insulation” and recalculate the scene, you will see your material.

Q :Would you consider adding a feature that would find loops in sections corresponding to groups inside other groups? : RS calculates group by group. Groups nor nested groups can interfere with each other. But I see other solutions to achieve the same visual effect. Thanks for this idea. :D I will work on it but it will take time. Actually I don't have much time. I started this plugin in march 2012. ;)

Right now this feature and the fact that a lot of layers, materials and scenes are created that I don't need : I will work on it. But les layers, scenes … will give restrictions or strange behavior. I
still have the 231 previous versions of this RS plugin, but I can already imagine the posts if they were published.

Try it out and show me the result .... 8-)
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby micione » Thu Dec 05, 2013 10:37 pm

pgarmyn,
from SketchUcation Plugin Store : the file seems to be broken.
0
User avatar
micione 
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby pgarmyn » Thu Dec 05, 2013 10:51 pm

@micione :
I installed yesterday on SU8 and SU2013 from the pluginstore (sketchucation Tools), and didn't change anything since. What happend. Did you used the plugin installer?
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby micione » Thu Dec 05, 2013 11:37 pm

No. I just tried to open it as a file .Zip
0
User avatar
micione 
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby pgarmyn » Fri Dec 06, 2013 7:50 am

micione wrote:No. I just tried to open it as a file .Zip

But you have SU2013. Why not using the installer ? Do you need it for older SU versions ? The same files (as RBZ and ZIP) are also on the first post.
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby JQL » Sat Dec 07, 2013 12:04 am

pgarmyn wrote:@JQL

About the Bug that isn't one : There was a blanc space in the beginning of your “ #Insulation” material. If you use the right name “#Insulation” and recalculate the scene, you will see your material.


LOL. Actually I'm starting to get worried by those spaces I'm always having them in materials sometimes... It must be related to space being the key for select tool, that cancels other commands. In those complex projects I tend to waste a lot of time looking for materials just to find them on top of the list...

Sorry to have wasted your time on this...

pgarmyn wrote:Q :Would you consider adding a feature that would find loops in sections corresponding to groups inside other groups? : RS calculates group by group. Groups nor nested groups can interfere with each other. But I see other solutions to achieve the same visual effect. Thanks for this idea. :D I will work on it but it will take time. Actually I don't have much time. I started this plugin in march 2012. ;)


Actually I'd prefer you didn't do it! It might seem strange but if you develop the plugin this way... I'll be forced to rethink and most probably change my modeling methodology completely, probably a lot of plugins I don't bother to think about will start making sense after all, Layout will never be the same again... You'll spread chaos in here, and you wouldn't want it because it seems you're actually trying to help!

pgarmyn wrote:Right now this feature and the fact that a lot of layers, materials and scenes are created that I don't need : I will work on it. But les layers, scenes … will give restrictions or strange behavior. I
still have the 231 previous versions of this RS plugin, but I can already imagine the posts if they were published.

Try it out and show me the result .... 8-)


Do you count versions late at night when you can't sleep? :D

Well it really feels like you put an great amount of effort in this as it has a lot of innovative and functional features.

Thanks for all your work.

Best regards,

JQL
0
User avatar
JQL 
Premium Member
Premium Member
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Sun Dec 08, 2013 11:52 am

ladcwei wrote:Yes,it's a temple ...... However,in some complex models,the plugin could give section lines but never fill the hole,I don't know is there some problem has not been solved? It seems to work right.


Hi ladcwei

:arrow: Could it be that your complex model is in the same context as the sectionplan.
To produce a RichSection, the model must be in a group (or component) or composed by (groups or components). If the RichSection-sectionplan is within a group, there will be only RichSection-faces produced for the nested groups or components. Is that the problem ?

:arrow: If not, could you send me a model (private I necessary) ?

Placing a RichSection-sectionplan within a group or component is still experimental. You will have to update it manually if you move the sectionplan.

Once again : Magic model. :sketchstatic:
How did you made the helix ?
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby ladcwei » Mon Dec 09, 2013 4:49 pm

Here is my model,wish you could solve all problems...

This model is made by Max,then it is transformed by 3DS format to SK,big software produce big models :P
0
User avatar
ladcwei 
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby pgarmyn » Tue Dec 10, 2013 10:22 pm

quote="ladcwei"]Here is my model,wish you could solve all problems...

This model is made by Max,then it is transformed by 3DS format to SK,big software produce big models :P[/quote]

Hi ladcwei,

Big sofware, big problems... :berserk: .... after conversion to SKP.
The problem is not the complexity. Even with a small part or the Max model, no intersection will be generated. It could be that adjacent faces dont share the same edge. Some faces have superposed edges.There are lot of coplanar faces subdivided without any reason. I tried to clean-up (plugins, by hand...).... no change,,,,
For_ladcwei-01.png


I’ve built in SU a model with the same complexity (not as beautiful as yours),
I used two excellent plugins : drawhelix14 from JIM and Extrusion-tools from TIG,
The section shown below (without projection) is generated in 3 seconds (For_ladcwei-02.png)
For_ladcwei-02.png

This image with projection, but les faces, was generated in 3,8 seconds, (For_ladcwei-03r.png)
For_ladcwei-03r.png



PS : I only could read the first skp file the second is corrupted (tried to download 3 times...) :!:

My SKP-file
QueJi Tower-1-v13-cor4.zip
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby takesh h » Wed Dec 11, 2013 4:13 am

pgarmyn wrote:Do you use components or groups? Are they closed in the sectionplan?
Test it with a Solid without changing any parameter in the dialog box?

Is there any error on the Ruby panel?


I tried it with a solid group, still no result.
There is an error reported in Ruby panel. It goes;

"Error: #<TypeError: reference to deleted DrawingElement>
(eval):2134:in `layer='
(eval):2134:in `procesRS'
(eval):1456:in `updateRichSection1'
(eval):1373:in `createRichSection'
(eval):1318:in `toolRScreate_part2'
(eval):97:in `onElementAdded'
(eval):2134"

BTW I updated RichSection to the latest version.
0
User avatar
takesh h 
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Wed Dec 11, 2013 7:51 am

takesh h wrote:I tried it with a solid group, still no result.
There is an error reported in Ruby panel. It goes;

"Error: #<TypeError: reference to deleted DrawingElement>...
BTW I updated RichSection to the latest version.


Thanks for the errordump. I will look this evening ....
If you have Sketchucation tools .... Can you try running the plugin alone, after switching off other plugins (+ restart SU)?
Let me know if that makes the difference .....

:D
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby takesh h » Wed Dec 11, 2013 10:01 am

pgarmyn wrote:Can you try running the plugin alone, after switching off other plugins (+ restart SU)?
Let me know if that makes the difference ..... :D


If RichSection is running alone, it works.
Then I added "offset.rb" which I no longer needed back to Plugins folder, RichSection stopped working. So I figured it was "offset.rb", I erased it from Plugins folder and put everything else back in. Then RichSection stopped working again and I got the error message:
"Error: #<TypeError: reference to deleted DrawingElement>
(eval):2134:in `layer='
(eval):2134:in `procesRS'
(eval):1456:in `updateRichSection1'
(eval):1373:in `createRichSection'
(eval):1318:in `toolRScreate_part2'
(eval):97:in `onElementAdded'
(eval):2415"

Hmmm, there must be a bad guy hidden inside my Plugins folder. I have something like 200 plugins, where should I start...
0
User avatar
takesh h 
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby takesh h » Wed Dec 11, 2013 10:35 am

pgarmyn,

I thought this might be getting nowhere with 200+ plugins, so I did a big cleanup of my Plugins folder for the first time in 10years, cut them down to around 100.
Those are indispensable 100s, so I was really nervous when re-starting SU... Voila! your RS worked (so did everything else)!
Thank you for the wonderful plugin, now I have to taste a dip of it.
0
User avatar
takesh h 
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby pgarmyn » Wed Dec 11, 2013 9:46 pm

@takesh h
+200 plugins : could you find your way ?
Let me know if - after installing the other plugins - you have again problems.....

In 'procesRS' I have only twice 'layer='

It can't be the first:

grp_section.name="Section_Grp"
grp_section.layer=section_layer


because if grp_section doesn't exist, the error should be in the line 'grp_section.name='

It must be in these lines :

grp_sectionplan = grp_section.entities.add_group
f = grp_sectionplan.entities.add_face sectionplanepoints
f.hidden=true
grp_sectionplan.hidden=true
grp_sectionplan.entities.each{|ent| ent.layer= section_layer}


The freshly created group (grp_sectionplan) contains only 4 edges and a face; but one of them (ent) doesn't exist any more, 5 lines after the creation:
Error: #<TypeError: reference to deleted DrawingElement .
I can't see why. Mystery :roll:

I will put a some errorhandling these lines...
Thanks :thumb:
0
Last edited by pgarmyn on Fri Dec 27, 2013 10:32 pm, edited 1 time in total.

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby takesh h » Wed Dec 11, 2013 10:17 pm

If I'm in a minority who is having trouble using RichSection, it must be because of something esoteric in my Plugins folder... a recent plugin, not a kind that everybody installs...

pgarmyn wrote:In 'procesRS' I have only twice 'layer='
It can't be the first:


Layer? layer... Let me check, I'm not a "layer" person, I'm rather a "group" person, I don't have many layer-oriented plugins. In fact, I have only one: Layers Panel.
viewtopic.php?f=323&t=52225

I reinstalled Layers panel and then tried RS, it doesn't work.
I uninstalled Layers panels and tried RS again, it works. Gotcha.
0
User avatar
takesh h 
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby pgarmyn » Thu Dec 12, 2013 1:34 pm

@takesh h

Great for this information: I will test it out with Layers panel

Thanks
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby jiminy-billy-bob » Thu Dec 12, 2013 2:00 pm

I'll take a look myself when I got time. Don't hesitate to PM me, pgarmyn.
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby jiminy-billy-bob » Thu Dec 12, 2013 9:39 pm

I will soon release a fix for Layers Panel.
I tested and it does not work with the current 0.9 version. But since this one I rewirted a whole bunch of code to avoid nested operations. I tested with this new version and it works fine. So it's probably related :)

You should thank TT who pushed me to get rid of nested operations. :D
0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby jiminy-billy-bob » Thu Dec 12, 2013 10:17 pm

0
User avatar
jiminy-billy-bob 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby pgarmyn » Fri Dec 13, 2013 7:50 am

jiminy-billy-bob wrote:I will soon release a fix for Layers Panel. I tested and it does not work with the current 0.9 version. But since this one I rewirted a whole bunch of code to avoid nested operations. I tested with this new version and it works fine. So it's probably related :)
You should thank TT who pushed me to get rid of nested operations. :D


THANK YOU. jiminy-billy-bob
THANK YOU TT
:D
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] UPDATED 4 dec 2013

Postby fionmacool » Fri Dec 27, 2013 8:46 pm

Awesome plugin pgarmin. It is exactly what i've been looking for as an automated approach to the methodology in my book "Construction Documents Using SketchUp Pro & LayOut". There are one or two small refinements I would like to see that will really make this singPlease email me: paul @ viewsion.ie to let me know if you're interested in co-authoring a publication. Thanks. :fro:
0
Zere are still some architectes zat do not know ow to use ze SketchUp..... Zis is unbelievable....
User avatar
fionmacool 
Premium Member
Premium Member
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: digilight, ronsino and 11 guests

Visit our sponsors: