[Plugin] RichSection V0.5.8 UPDATED march 2015  Topic is solved

Re: [Plugin] RichSection [Demo]

Postby ladcwei » Thu Nov 28, 2013 4:56 pm

Yes,it's a temple for new year,it attracts much people to ring the bell on the three floors,it is supposed to be a kind of memorial tower.

However,in some complex models,the plugin could give section lines but never fill the hole,I don't know is there some problem has not been solved? It seems to work right.
1
User avatar
ladcwei 
 

Re: [Plugin] RichSection [Demo]

Postby ArCAD-UK » Thu Nov 28, 2013 5:53 pm

ladcwei wrote:However,in some complex models,the plugin could give section lines but never fill the hole,I don't know is there some problem has not been solved? It seems to work right.

Missing faces also happens with :ugeek: TIG's Section Cut Face. He has done a lot of checks on it but there can still be situations in a model where a face can be missing without reason. :?
0

ArCAD-UK 
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Thu Nov 28, 2013 7:43 pm

sexypox69 wrote:Cant get it to work like in the videos....it just works as sketchup native section cut, also sketchup crashed a few times (bugsplat)....but i love the intention. It would save me the time to go put in hatches in my layout documents

Hallo,
To know what is going on first exclude this :
  • ...as native Sketchup : Did you used groups or components ?
  • Did you activate the plugin? (Menu Windows/preferences >> extensions). Is there RichSection-panel and a RichSection menu ?
  • Open de Ruby console (open the 'Windows' menu, and then click 'Ruby Console'): do you have any errors here while placing RIchSection cuts?
  • Bug Splat : What other plugins are installed? There can be incompatibility : see first post. Unactivate all other plugins, restart SU and test again the RichSection plugin. This should work !

I see you have SU 8 installed. I suggest to install SU2013 make (you can keep SU8). It faster and much more stable.
Then install (first and only) the RichSection plugin. It should work ! If it is the case, instal the other plugins, and test after each installation.

Please tell me if you got it working :D
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Thu Nov 28, 2013 9:18 pm

ladcwei wrote:Yes,it's a temple for new year .....
However,in some complex models,the plugin could give section lines but never fill the hole,I don't know is there some problem has not been solved? It seems to work right.

Nice to have some feedback. B
Beautifull and complex models :!: :sketchstatic:

RichSection and also TIG's plugin use a method of the Ruby Sketchup-API (entities.intersect_with). :!: Indeed ArCAD-UK :!: This method handels the Intersection and automatically creates faces with speed. My experience is that the method can't handel very small faces Sometimes you can avoid this limit by scaling the model (x100 ... x1000).
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby ArCAD-UK » Thu Nov 28, 2013 10:41 pm

@Pgarmyn

My missing faces were in repeated components and should have formed a 50 x 100mm face in a rectangular box, so size wasn't the issue. The final solution in that case was to delete the failing group and create a fresh box. TIG spent time updating his plug using some of my models but I can still get face errors with abutting groups for no obvious reason. If you and TIG are both seeing this then you may need to get Trimble to look at the API.
0

ArCAD-UK 
 

Re: [Plugin] RichSection [Demo]

Postby ivreich » Fri Nov 29, 2013 5:09 am

Hi Joel

Supposing
  • Model : you used layers L1 and L2
  • Model : you applied the following materials to groups and components : N1 and N2
First possibility :
  • Model : existing materials in library 'in model' : #L1.... / NOT existing materials : #L2
  • RS-options : prefix = #
  • RS-options : default material = #default
  • RS-options : section material = prefix+layername, default
  • RS section materials for a group or component in layer L1 : #L1
  • RS section materials for a group or component in layer L2 : #default (because #L2 doesn't exist)
2nd possibility :
  • Model : existing materials in library 'in model' : #N1.... / NOT existing materials : #N2
  • RS-options : prefix = #
  • RS-options : default material = #default
  • RS-options : section material = prefix+materialname, default
  • RS section materials for a group or component with material N1 assignd: #N1
  • RS section materials for a group or component with material N2 assignd: #default (because #N2 doesn't exist)

Got it :?: :D



Thanks...I managed to get both material names and layer names working (apparently I can't use default material names straight from the SU library; I have to change them for them to work), but I still don't understand the difference between the two richsection options highlighted in the attached image:


Thanks!
Joel
0

ivreich 
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Fri Nov 29, 2013 8:10 am

ivreich wrote:Thanks...I managed to get both material names and layer names working (apparently I can't use default material names straight from the SU library; I have to change them for them to work), but I still don't understand the difference between the two richsection options highlighted in the attached image:
Thanks!
Joel

It's a matter of priority
Supposing
  • Model : you used layers L1 and L2
  • Model : you applied the following materials to groups and components : N1 and N2
  • Model : Group1 in layer L1 and material N1 (assignd to the group)
  • Model : Group2 in layer L2 and material N2 (assignd to the group)

First case :
  • Model : existing materials in library 'in model' : #L1,#N1,#N2....
  • Model : NOT existing materials in library 'in model' : #L2
  • RS-options : prefix = #
  • RS-options : default material = #default
  • RS-options : section material = prefix+layername, prefix+materialname, default
  • RS section materials group1 (L1,N1) : #L1 (priority for prefix+layername)
  • RS section materials group2 (L2,N2) : #N2 (#L2 doen't exist)
2nd case :
  • RS-options and model as before, except:
  • RS-options : section material = prefix+materialname, prefix+layername, default
  • RS section materials group1 (L1,N1) : #N1 (priority for prefix+materialname)
  • RS section materials group2 (L2,N2) : #N2

Like for standard materials : nested groups can inherit the RichSection-material of a parent group

:bounce: :bounce:
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Fri Nov 29, 2013 8:46 pm

ArCAD-UK wrote:@Pgarmyn

My missing faces were in repeated components and should have formed a 50 x 100mm face in a rectangular box, so size wasn't the issue. The final solution in that case was to delete the failing group and create a fresh box. TIG spent time updating his plug using some of my models but I can still get face errors with abutting groups for no obvious reason. If you and TIG are both seeing this then you may need to get Trimble to look at the API.


My experience is that SU (and his ruby method 'intersect_with') can't create an intersection-face if:
  1. small faces; small is relative : it depends of the extends of the model
  2. to many entities (edges, faces) in the same context (context = in the same group or component)
  3. to many (complex) loops to create in the same context

ArCAD-UK, for the repeated 'small' components, does SU recognizes them as a solid? What are the dimensions of the model?
Maybee jou can send me the problematic skp-file (private if necessary, I will only use it for testing....)
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby mladen90 » Sun Dec 01, 2013 1:12 pm

This is unbelivable! Thank you soo much pgarmyn for sharing this.
It is just what i have been searching for for years. Now sketchup could be finally used as a proper drawing tool, without worrying are cetions up to date, visible to other scenes etc.

I downloaded it yesterday via sketchucation plugin manager and it says it's expired back in march 2014?.
https://dl.dropboxusercontent.com/u/350 ... xpired.jpg

I thought i should report this.
Thank you again pgarmyn!
0

mladen90 
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Sun Dec 01, 2013 6:02 pm

mladen90 wrote:This is unbelivable! Thank you soo much pgarmyn for sharing this.
It is just what i have been searching for for years. Now sketchup could be finally used as a proper drawing tool, without worrying are cetions up to date, visible to other scenes etc.

I downloaded it yesterday via sketchucation plugin manager and it says it's expired back in march 2014?.
https://dl.dropboxusercontent.com/u/350 ... xpired.jpg

I thought i should report this.
Thank you again pgarmyn!


Yes, thanks for reporting this.
Indeed this (full) DEMO expires on 1 march 2014. I will replace it by a free (limited) and a FULL version. But strange that you have this message.
Are you living in the future :?: Did you changed the date of your computer :?:
Is the licence-file in de directory (plugin/PiGa_RichSection/RichSectionLicense.rb) :?:

Let me know....
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby mladen90 » Sun Dec 01, 2013 6:19 pm

I haven't change my date on PC.
I have resources folder, RichSection.rbs and RichSectionLicence.rb in folder you mentioned.

I have had experienced similar thing with RealSection, but that was common problem ( It truly had expired and nobody continued to work on it). I guess RichSection doesn't use any of RealSections libs? Could this be the problem?

Thanks for your quick reply.
1

mladen90 
 

[Plugin] RichSection : NEW VIDEO

Postby pgarmyn » Sun Dec 01, 2013 6:29 pm

:bounce: New video added to the first post... :bounce: :idea: :bounce:
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Sun Dec 01, 2013 7:04 pm

mladen90 wrote:I haven't change my date on PC.
I have resources folder, RichSection.rbs and RichSectionLicence.rb in folder you mentioned.

I have had experienced similar thing with RealSection, but that was common problem ( It truly had expired and nobody continued to work on it). I guess RichSection doesn't use any of RealSections libs? Could this be the problem?

Thanks for your quick reply.

Strange, you are the first having this problem after 380 downloads!
The RichSection plugin can't interfere with other plugins.
When did you got this message. Directly after putting the first RichSection? .... When updating?


Can you switch 'on' logging in the menu (plugins/RichSection/settings) and open the ruby console.
What is printed in the Ruby console, when you place a RichSection... :?:
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby mladen90 » Sun Dec 01, 2013 8:10 pm

Wow! Astonishing new video. Just what I imagined it cold be done with RichS.

Considering expiration problem. I did enable logging.
It happens when I try to make real section (via menu-bar or right click).

Here is the log:

---------------------------onElemAdd : Sketchup::SectionPlane
toolRScreate_part2 :
toolRScreate_part2: createRS :
_________________________
Plugin: RichSection
Copyright: 2013X, All rights reserved for RichSection plugin : Name, code and functionality are the intellectual property of the author. Distribution, reproduction or integration of code or functionality, even partly, is only permitted with the explicit permission of the author
Version: V00.01-2013.11.17-18:00 DEMO_________________________
:
proc createRichSection :
licensefile found : C:/Program Files (x86)/SketchUp/SketchUp 2013/Plugins/PiGa_RichSection/RichSectionLicense.rb
licensed for computer: : any
licensed for MAC-adress: : any
licensed for version: : V00.01-2014.11.17-20:00 DEMO
licensed until: : Sat Mar 01 00:00:00 UTC 2014
license type: : DEMO, valid until 2014-03-01
license to (name): : Everybody
license to (mail): :
key1: : SoftwarekeyForTheDemoLicenseUntil-2014-03-01
key2: : fz1njmunn7pfa45t9o1bv0yatdvaln7wvrpl8oitml3301vizcszy0cjyepk1r14mkve
Faces : 12
Instances : 1
Definitions : 1
@modelcomplexity : 0
thisRSversion = V00.01-2014.11.17-20:00 DEMO? : V00.01-2014.11.17-20:00 DEMO
License VALID :

I hope that this help.
0

mladen90 
 

Re: [Plugin] RichSection [Demo]

Postby pomelo3d » Sun Dec 01, 2013 8:31 pm

thank you very much for this fantastic plugin.
On my computer, now shows the same error message, because the plugin expired.
you can fix that? thank you very much
0

pomelo3d 
 

Re: [Plugin] RichSection [Demo]

Postby ArCAD-UK » Sun Dec 01, 2013 8:44 pm

I was about to check the models TIG worked with and got the same EXPIRED DEMO message.
0

ArCAD-UK 
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Sun Dec 01, 2013 10:51 pm

ArCAD-UK wrote:I was about to check the models TIG worked with and got the same EXPIRED DEMO message.

And others. ......

Sorry. childhood illness
I'll fix that tomorrow. :roll: :oops: :oops: :oops:
1
Last edited by pgarmyn on Sat Apr 05, 2014 2:28 pm, edited 1 time in total.

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby pilou » Mon Dec 02, 2013 12:15 am

The RichSection plugin can't interfere with other plugins.


But sems at least 2 plugins "windowizer.rb" and "wxSU.rb" bugsplat it! ;)
0
Frenchy Pilou
Is beautiful that please without concept!
Speedy Galerie
User avatar
pilou 
Top SketchUcator
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Mon Dec 02, 2013 7:48 am

Pilou wrote:But sems at least 2 plugins "windowizer.rb" and "wxSU.rb" bugsplat it! ;)


As i said before, every method, variable in the RichSection plugin is declared in the RichSection namespace.

As Windowizer ads a base method and extends SU classes, it interfears with ALL the SU plugins!
I didn't look at the wxSU code.....
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo] V00.02 UPDATE

Postby pgarmyn » Mon Dec 02, 2013 8:21 am

:bounce: UPDATED, but probably not yet on the plugin store. (Need time to find out if I can do this by myself... ) :bounce:
0
Last edited by pgarmyn on Mon Dec 02, 2013 12:09 pm, edited 1 time in total.

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby emerald15 » Mon Dec 02, 2013 10:54 am

pgarmyn wrote:
emerald15 wrote:I use RichSection to great effect. I really like all the additional optional colours, line types & infills.

May we see the result :?: 8-)


Here's the section part of the drawing. Having all the none visible objects shown in dashed lines really helped.
1
User avatar
emerald15 
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Mon Dec 02, 2013 1:18 pm

@emerald15

Thanks for sharing your work.
You are the first using projected information :!:
Maybee you have to use a non white section-material :?:
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby Rich O Brien » Mon Dec 02, 2013 1:21 pm

@P

You need help updating store?
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Mon Dec 02, 2013 6:49 pm

@Rich
Thanks for the quick reply.
TIG gave me alreardy a very complete explanation on the Sketchucation-tools-page,
But I will need to find some time to work it out.... .
Where can I find the Authors' Guide.
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby TIG » Mon Dec 02, 2013 11:15 pm

pgarmyn wrote:@Rich
Thanks for the quick reply.
TIG gave me alreardy a very complete explanation on the Sketchucation-tools-page,
But I will need to find some time to work it out.... .
Where can I find the Authors' Guide.

viewforum.php?f=382
First sticky: viewtopic.php?p=475671#p475671
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] RichSection [Demo]

Postby ArCAD-UK » Tue Dec 03, 2013 12:19 am

Had a play tonight. Just some thoughts:

1. I still maintain creating two scenes is unnecessary. If there are a lot of plans and sections then the screen soon becomes cluttered with tabs. It is easy and less confusing to click on the projecting scene and then "Display Section Planes" for editing.

2. I know why you create a Style for each section but allowing selection from [user] styles generated within SU may be easier to manage. I usually only have one or two cut styles and I note you have two for each section e.g. #001 AND #001P

3. There should be the option to use SU's default material rather than the default created by Rich Section

4. I'm not a fan of raster hatches, but they are easy enough to Purge. I don't know what other's feel but some may prefer to load them as an option?

5. Would an additional layer "__Profiles" which had just the outlines of the RS cut be possible so that they remain visible when turning off individual entity layers?
0

ArCAD-UK 
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Tue Dec 03, 2013 9:37 pm

ArCAD-UK wrote:Had a play tonight. Just some thoughts: 1 2 3....



1. Extending Sketchup with Ruby is not as
"driving a car without a steering wheel"
but some controls are missing :!:
Steering-wheel_2625587b.jpg

The SU ruby API has no (direct) method to create, activate, hide or show a sectionplan. some control is possible using a Scene or a Style. Thus, I NEED THOSE TWO SCENES AND STYLES, to save my settings, to switch things on/off... .

Many methods to control a 'scene' or a 'style' are missing. A workaround to create a style with the sectionplane activated is to load a style from a file, (a file created before with visibility and active sectionplan as needed) and update it with the active style-settings. What complicates the whole thing is that some methods (like loading a style from a file) can't be in the undo DB. Roughly, my plugin is 30% core code, 30% input & data management and 30% workaround.
2 see 1
3. The shortest workaround is that YOU save YOUR default material (white, red, hached or not), and select it as default in the RS-settings. You can also (at your ouwn risk) eliminate or replace the bitmaps in plugins/PiGa_RichSection/resources/mat. They are loaded at the creation of the first RS. But the plugin needs at least a #default.png (bitmaps applied with dim. 30x30cm). I plan to replace the bitmaps by a .skm library, but you keep me busy with ....
4. I have tons of ring and bels to install, but first I have to upload a working version to the plugin store.
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Tue Dec 03, 2013 9:55 pm

TIG wrote:http://sketchucation.com/forums/viewforum.php?f=382
First sticky: viewtopic.php?p=475671#p475671


About the Converter tool: You are not authorised to download this attachment. (after login) :?: :? :?
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection [Demo]

Postby Rich O Brien » Tue Dec 03, 2013 10:35 pm

Try again
1
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [Plugin] RichSection [Demo]

Postby pgarmyn » Tue Dec 03, 2013 10:43 pm

@Rich
thanks,
that wil be for Tomorrow.....
(I'm now on my tablet)
I need to be on a PC to save it.....
0

pgarmyn 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: agarawal, blackmonk75, fredo6, Google Bot, maconrua, nguyenminhhien030997 and 17 guests

Visit our sponsors: