[Plugin] RichSection V0.5.8 UPDATED march 2015  Topic is solved

Re: [Plugin] RichSection V0.5.5 UPDATED dec 2014

Postby srx » Thu Dec 18, 2014 8:01 pm

Still, there is no download in plugin store...
0
www.saurus.rs
User avatar
srx 
 

Re: [Plugin] RichSection V0.5.5 UPDATED dec 2014

Postby pgarmyn » Thu Dec 18, 2014 8:04 pm

You will have to wait for an update.
V0.5.4 won't work on SU 2015 if SU 2014 wasn't installed before
V0.5.4 and V0.5.5 won't work on 2014 and 2015 if the user folder for materials isn't defined (even if you see the default path in 'preferences') or if it isn't writable
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection V0.5.5 UPDATED dec 2014

Postby srx » Fri Dec 19, 2014 11:39 am

OK. Thanks.
0
www.saurus.rs
User avatar
srx 
 

[Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby pgarmyn » Sat Dec 20, 2014 11:40 pm

[Plugin] RichSection V0.5.6 UPDATED dec 2014

PLUGINSTORE
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection V0.5.5 UPDATED dec 2014

Postby pgarmyn » Sun Dec 21, 2014 12:04 am

rhott311 wrote:Plugin does not display correct input panels in OS X Yosemite in SU 08, textured section does not appear at all. Previous versions of this plugin did not work either. Are there known panel issues for OS X?


Hy rhott311

I can not test all combinations of Sketchup versions and Systems.
The last version has been tested on OS X (10.9.4), Sketchup 2014 and 2015
The input panel works on OS X

There was a bug (only on OS X) with the previous versions : Textures displayed only after switching them 'off' and 'on' again
(Menu : View/Face_Style/Shaded and View/Face Style/Shaded_with_Textures)

Try again here : PLUGINSTORE

Thanks for the interest.
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby maxosmedia » Sun Dec 21, 2014 9:53 am

Sketchup Launch:
RS: ERROR RichSection: REINSTALL THE PLUGIN : could not find file :
RS: /Users/uusername/Library/Application Support/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/resources/RS-create-icon.png


Console:
Error: #<TypeError: no implicit conversion of nil into String>
/users/uusername/library/application support/sketchup 2015/sketchup/plugins/piga_richsection/richsection.rbs:4866:in `small_icon='
/users/uusername/library/application support/sketchup 2015/sketchup/plugins/piga_richsection/richsection.rbs:4866:in `<module:PiGaRSection>'
/users/uusername/library/application support/sketchup 2015/sketchup/plugins/piga_richsection/richsection.rbs:114:in `<main>'
/Users/uusername/Library/Application Support/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/RSloader.rb:25:in `eval'
/Users/uusername/Library/Application Support/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/RSloader.rb:25:in `require'
/Users/uusername/Library/Application Support/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/RSloader.rb:25:in `<module:PiGa>'
/Users/uusername/Library/Application Support/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/RSloader.rb:3:in `<top (required)>'
/Applications/SketchUp 2015/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require'
/Applications/SketchUp 2015/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load'
/Users/uusername/Library/Application Support/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection.rb:40:in `register_extension'
/Users/uusername/Library/Application Support/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection.rb:40:in `<module:PiGa>'
/Users/uusername/Library/Application Support/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection.rb:17:in `<top (required)>'
0

maxosmedia 
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby pgarmyn » Sun Dec 21, 2014 10:18 am

@maxosmedia and OTHERS
Install again, missing files have been added ! SORRY :oops:
1

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby maxosmedia » Sun Dec 21, 2014 10:40 am

Sketchup frozen on hit "Update RichSection" button. No section results.
The plugin does not work now :(

(Mac OS X 10.9.5 SU2015Pro (15.2.686)
0

maxosmedia 
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby 2Harry » Tue Dec 23, 2014 3:58 am

Installed V0.5.6 in Sketchup2015 Pro on Win8.1.

Works great now. Will be experimenting over the next few days.

Thank you for your focused efforts to get it running for everyone.

Regards
0

2Harry 
Premium Member
Premium Member
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby Sl!m » Wed Dec 24, 2014 4:36 am

Hi There,

Seems like a very powerful plugin, Well done and thanks for sharing!
I have a question though:

I'm using pro SKetchup pro 2015.
When i have already created cut plans and select one of them, right click and "make realsection", nothing happens. I pressed "show real section" but doesn't make any difference.

What M'I doing wrong ?

Thank you
Sl!m
0

Sl!m 
Premium Member
Premium Member
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby pgarmyn » Wed Dec 24, 2014 10:02 am

Sl!m wrote:Hi There,

Seems like a very powerful plugin, Well done and thanks for sharing!
I have a question though:

I'm using pro SKetchup pro 2015.
When i have already created cut plans and select one of them, right click and "make realsection", nothing happens. I pressed "show real section" but doesn't make any difference.

What M'I doing wrong ?

Thank you
Sl!m


Realsection is another plugin. Mine is RichSection.
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby Sl!m » Thu Dec 25, 2014 2:20 am

pgarmyn wrote:
Sl!m wrote:Hi There,

Seems like a very powerful plugin, Well done and thanks for sharing!
I have a question though:

I'm using pro SKetchup pro 2015.
When i have already created cut plans and select one of them, right click and "make realsection", nothing happens. I pressed "show real section" but doesn't make any difference.

What M'I doing wrong ?

Thank you
Sl!m


Realsection is another plugin. Mine is RichSection.


Wow so sorry I got confused and completely missed that!
I would rather erase my thread as it is not useful for other users.

Merry Christmas!
Sl!m
0

Sl!m 
Premium Member
Premium Member
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby srx » Fri Dec 26, 2014 5:22 pm

I tried it and can now say that this is very useable and useful plugin. Thank you!
0
www.saurus.rs
User avatar
srx 
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby Sl!m » Wed Jan 28, 2015 10:32 am

Hi there,

Everything was working very well... Until yesterday when I played with the settings.
After that the RichSection wouldn't cut through, just show the section line.
I even loose the ability to activate the original Sketchup section tool and had to restart Sketchup.
Any idea what's wrong ?



Using sketchup 2015, windows7 ultimate 64.
Thank you
Sl!m
0

Sl!m 
Premium Member
Premium Member
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby pgarmyn » Wed Jan 28, 2015 1:04 pm

(deleted) answer sended twice
0
Last edited by pgarmyn on Wed Jan 28, 2015 1:07 pm, edited 1 time in total.

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby pgarmyn » Wed Jan 28, 2015 1:05 pm

Yes I had the same experiance. Sketchup stops cutting elements, and only showing the section lines, until restarting SU.
I only had it with SU2015 on win 8.1. I suppose it is linked to that SU version (?)
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby simsmt » Fri Feb 06, 2015 4:03 pm

This plugin is not working for me. I have Win7 SketchUp 2014 Pro. It will not create scenes but I can use exiting scenes to use the hatch but then it leaves the line when going to another scene.
0

simsmt 
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby pgarmyn » Fri Feb 06, 2015 6:48 pm

simsmt wrote:This plugin is not working for me. I have Win7 SketchUp 2014 Pro. It will not create scenes but I can use exiting scenes to use the hatch but then it leaves the line when going to another scene.

I have it working on windows 7, SU Pro 2014 and 2015. Can you switch on logging to ruby console in the menu Plugins/Richsection/Setting and send me the errors, if there are?
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection V0.5.6 UPDATED dec 2014

Postby arquitetopaulofil » Sat Feb 21, 2015 7:37 pm

Here is the mensage of ruby console
RS0.5.6|56.018|RichSection: Valid time-limited FULL WORKING license, until : 2015-02-28 21:00:00 -0300
RS0.5.6|0.078|optionsRShnew: new RS--sectionId150221-154208 : rs150221-154208
CAMBIADA
Error: #<NoMethodError: undefined method `[]' for nil:NilClass>
c:/users/paulovisk/appdata/roaming/sketchup/sketchup 2015/sketchup/plugins/piga_richsection/richsection.rbs:3607:in `block in changeOptionsRSh'
c:/users/paulovisk/appdata/roaming/sketchup/sketchup 2015/sketchup/plugins/piga_richsection/richsection.rbs:3606:in `each_pair'
c:/users/paulovisk/appdata/roaming/sketchup/sketchup 2015/sketchup/plugins/piga_richsection/richsection.rbs:3606:in `changeOptionsRSh'
C:/Users/PAULOVISK/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/RSpanel.rb:386:in `block in create'
C:/Users/PAULOVISK/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/SKUI/events.rb:82:in `call'
C:/Users/PAULOVISK/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/SKUI/events.rb:82:in `block in trigger_event'
C:/Users/PAULOVISK/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/SKUI/events.rb:78:in `each'
C:/Users/PAULOVISK/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/SKUI/events.rb:78:in `trigger_event'
C:/Users/PAULOVISK/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/SKUI/window.rb:364:in `event_control_callback'
C:/Users/PAULOVISK/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/SKUI/window.rb:318:in `callback_handler'
C:/Users/PAULOVISK/AppData/Roaming/SketchUp/SketchUp 2015/SketchUp/Plugins/PiGa_RichSection/SKUI/window.rb:276:in `block in add_callback'
SketchUp:1:in `call'
0

arquitetopaulofil 
 

Re: [Plugin] RichSection V0.5.8 UPDATED march 2015

Postby nmhai » Mon Mar 02, 2015 6:24 am

error for me. i install: richsection and dibac(solid section).
win8.1 x64 sketchup 2015
0

nmhai 
 

Re: [Plugin] RichSection V0.5.8 UPDATED march 2015

Postby kylintz » Thu Mar 05, 2015 8:41 am

The new plugin crash when I use rich section on sketchup without texture.

And it only create 1 scene for each section now, unlike the version before this where I got 2 scenes for each rich section. I tried to search on the rich section setting on the "scene created for each rich section", there's only one option available "scene, section plane visible, no camera aplies."

I tried to reset the setting with no results. I can't get 2 scenes for each rich section that I create. I missed that auto paralel camera and auto hide section plane visibility whenever I create rich section.
0

kylintz 
 

Re: [Plugin] RichSection V0.5.8 UPDATED march 2015

Postby agmgpro » Thu Mar 05, 2015 2:18 pm

Hi,

where can I find the older version (0.5.4)? In this latest version there's no option in "settings" to create 2 scenes...??? It's crashing a lot too. Installed on SKU2015 Pro. Version 0.5.4 was working just fine, and the option for creating 2 scenes (without camera + aligned to section), is very important for us! Please help! Appreciate your attention, Gabriel
1

agmgpro 
 

Re: [Plugin] RichSection V0.5.8 UPDATED march 2015

Postby kylintz » Thu Mar 05, 2015 4:34 pm

I have the same problem like you agmgpro haha
1

kylintz 
 

Re: [Plugin] RichSection V0.5.8 UPDATED march 2015

Postby pgarmyn » Fri Mar 06, 2015 7:36 am

You can create as much scenes as you want, but, after scene creation, you will have to switch the section layer on, set section plan visibility ... and update the scene. 2 Scenes (in the settings) will come back, but i can't make 0.5.4 available because the data structure (for richsection information) saved in your file has changed.
About crashing : what other plugins are you using?
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection V0.5.8 UPDATED march 2015

Postby kylintz » Fri Mar 13, 2015 5:08 am

I think the crashing is caused by the #default material. On a fresh sketchup file, if i create a scene without applying #default rich section material to random object first, the sketchup would crash after creating rich section.

And about the 2 scenes, I couldn't get it work. I couldn't make the option to create 2 scenes automaticaly for each rich section to work. There's only one option available on rich section setting for "Scenes created for each richsection" : Scene, sectionplan visible, no camera applied.
0

kylintz 
 

Re: [Plugin] RichSection V0.5.8 UPDATED march 2015

Postby pgarmyn » Sat Mar 14, 2015 3:24 pm

@kylintz:
Maybee my answer was not clear : the option for creation of 2 scenes doesn't exist in the latest version (it will come back). You can create yourself extra scenes as described before.

About problems with loading #default : is the plugin installed in the default folder?
To be able to help you, i need :
If you switch on the ruby console : are there errors ?
Please fill in your profile : windows version, Sketchup version ...
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection V0.5.8 UPDATED march 2015

Postby Esense3d » Sat Mar 14, 2015 6:30 pm

Hello
Itmakes sektions without Material ?

Win 7 su 2015


Thank you
0

Esense3d 
 

Re: [Plugin] RichSection V0.5.8 UPDATED march 2015

Postby pgarmyn » Sat Mar 14, 2015 11:28 pm

@esense3d:
Did you tried without changing the parameters?
0

pgarmyn 
PluginStore Author
PluginStore Author
 

Re: [Plugin] RichSection V0.5.8 UPDATED march 2015

Postby agmgpro » Tue Mar 17, 2015 3:20 pm

Thanks pgarmyn,

waiting then for 2 scenes to come back!

(it's possible for you to send me the older version via email??? If yes, my email is agmgpro@gmail.com)

Thanks again!
0

agmgpro 
 

Re: [Plugin] RichSection V0.5.8 UPDATED march 2015

Postby bik » Fri Apr 17, 2015 11:26 am

I have a problem with the setting panel.
When I click on the button to call the setting panel, nothing happens.
(My Sketchup is the last one 15.3.331 64 bit)

And most of time I encounter a bug splat windows when I just click on "create" for a first Rich Section. The section become grey, and everything close.
An other information for you : When I succeed to create one, I don't have a lot of color section choice, only wide stripes by default and Black (plain color)...

I don't understand why I'm alone to have this problem.

I use sketchup for a professional need and I'm aware about how the sketchup plugins works.
I have tried to remove your plugin, and install again... But it's the same problem all the time.

If any conflicts, just look below. My only plugins installed are :
Sketchucation
Bezierspline
ExtrudeTools
PipeAlongPath
tt_cleanup
tt_material_replacer
Projection
jf_addlayer
Fredo6_RoundCorner
Mirror

If any idea ?
0

bik 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: Astro designer, mmoore12 and 15 guests

Visit our sponsors: