[Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby Ahmed0007 » Sun Oct 06, 2019 5:07 pm

and latest version of JPP is working fine with SU2017
0

Ahmed0007 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby Dave R » Sun Oct 06, 2019 5:14 pm

You never answered my question about proper installation of SketchUp. Did you install SketchUp 2018 and 2019 correctly?
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby Ahmed0007 » Sun Oct 06, 2019 7:13 pm

Dave R wrote:You never answered my question about proper installation of SketchUp. Did you install SketchUp 2018 and 2019 correctly?


sorry i don't remember that how i had installed.
but give main an hour to reinstall as you said.
0

Ahmed0007 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby TIG » Sun Oct 06, 2019 7:18 pm

You do not need to 'reinstall'.
Login as your normal Windows user-account.
Ensure SketchUp is closed.
Find the SketchUp installer file's exe icon - it's probably in your Downloads folder.
Then select it, right-click > context-menu > "Run as administrator"
When prompted choose "Repair"
Done.

It will not harm your existing set up - just 'repair' it, if that is necessary
2
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby Ahmed0007 » Sun Oct 06, 2019 7:24 pm

TIG wrote:You do not need to 'reinstall'.
Login as your normal Windows user-account.
Ensure SketchUp is closed.
Find the SketchUp installer file's exe icon - it's probably in your Downloads folder.
Then select it, right-click > context-menu > "Run as administrator"
When prompted choose "Repair"
Done.

It will not harm your existing set up - just 'repair' it, if that is necessary


oh! Thanks :thumb:
0

Ahmed0007 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby Ahmed0007 » Sun Oct 06, 2019 7:37 pm

Dave R wrote:You never answered my question about proper installation of SketchUp. Did you install SketchUp 2018 and 2019 correctly?


i have done proper installation of SketchUp.
and i have still same issue.
0

Ahmed0007 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby fredo6 » Sun Oct 06, 2019 10:29 pm

Ahmed0007 wrote:i have done proper installation of SketchUp.
and i have still same issue.

Since the bugsplat is reproducible on your environment and is not on Dave's or mine, there must be something on your side, possibly a conflict with another plugin (maybe a redefinition of random methods).

If you have time, could you remove suspicious plugins, in general not mainstream, and check if you get the bug splat.

Many thanks

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby Ahmed0007 » Sun Oct 06, 2019 11:52 pm

fredo6 wrote:
Ahmed0007 wrote:i have done proper installation of SketchUp.
and i have still same issue.

Since the bugsplat is reproducible on your environment and is not on Dave's or mine, there must be something on your side, possibly a conflict with another plugin (maybe a redefinition of random methods).

If you have time, could you remove suspicious plugins, in general not mainstream, and check if you get the bug splat.

Many thanks

Fredo


i already tried with only JPP and fredoLib installed. but this also not work.
but you're right there is something wrong with my pc.
today i tested JPP on my brother pc and it's working fine there.
i don't know what i should do to fix this issue.
reinstall windows?
any suggestion?
and Thanks for your time.
0

Ahmed0007 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby fredo6 » Mon Oct 07, 2019 8:47 am

No need to reinstall Windows...

Did you try with another model file?

Also, can you confirm that
- you get the bugsplat only when using the Random feature of JPP
- whether this happens for both Normal and Joint tools (since both have a random option)

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby Ahmed0007 » Mon Oct 07, 2019 2:58 pm

fredo6 wrote:No need to reinstall Windows...

Did you try with another model file?

Also, can you confirm that
- you get the bugsplat only when using the Random feature of JPP
- whether this happens for both Normal and Joint tools (since both have a random option)

Fredo


with all JPP tools and with any model
Video : https://streamable.com/upjw5
0

Ahmed0007 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby Dave R » Mon Oct 07, 2019 3:06 pm

When you get the Bug Splats are you sending them in with your e-mail address attached? As a licensed SketchUp Pro user with up-to-date Maintenance and Support, you could file a ticket with their Technical Support folks and ask them to look at the Bug Splat reports and decipher what is happening to cause the splat. At this point, since you seem to be the only one having a problem and we can't reproduce the Bug Splats even with your file, more information is needed.
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby Ahmed0007 » Mon Oct 07, 2019 6:57 pm

Ahmed0007 wrote:Getting a bugsplat when trying to change the random push pull values. in sketchup 2019 and 18
any solution?


problem fixed after doing following steps:

Uninstall sketchup (2019 and 18) with revo uninstall (also delete Leftovers items and registry files)

Reinstall only su19
after opening first time this give me this error "mfc140u.dll" Missing

install Visual C++ Redistributable for Visual Studio 2015
and
uninstall Visual C++ Redistributable for Visual Studio 2017

Done!

Thank you Fredo6 and Dave R for response.
0

Ahmed0007 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby fredo6 » Mon Oct 07, 2019 8:23 pm

Glad to see that it now works for you.

Still, this is puzzling, and I don't really see why JointPushPull would specifically crash in relation to the version of C++, since it is pure Ruby.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby Box » Wed Feb 05, 2020 1:52 pm

Hi Fredo,
I was just doing a gif to show something in JPP and noticed it breaks the dimension connection.
Checked 2018,19,20.
FredoScale for example doesn't break the connection.

Not sure if it has always been that way and I just don't remember it being like that.
0
User avatar
Box 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby pilou » Wed Feb 05, 2020 3:14 pm

Breaking also in the 2017! ;)
0
Frenchy Pilou
Is beautiful that please without concept!
Speedy Galerie
User avatar
pilou 
Top SketchUcator
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby fredo6 » Wed Feb 05, 2020 3:54 pm

JointPushPull technically creates faces (and thus new vertices), whereas FredoScale just uses a scaling transformation and therefore keeps the faces and vertices homologous.

JointPushPull does not use native pushpull methods, due to the fact that it is multi-face tool.

So it is normal that JPP loses the dimension connections.

Reconstructing them is maybe possible, but probably some work due to the variety of topological situations, and also the poor support of the API for dimensions. I have to check if the connections are exposed in the API and can be reconstructed.

EDIT: just checked that for linear dimensions, there is a possibility to manage the attachment, but as of SU2019.
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby Box » Wed Feb 05, 2020 9:26 pm

Thanks for letting me know, I was just pointing it out incase it was a bug, just one of those things I hadn't noticed before.
0
User avatar
Box 
 

Re: [Plugin Library] LibFredo6 - v9.5g - 09 Feb 20

Postby hugoakio » Mon Feb 10, 2020 11:29 pm

I need a help. I'm trying to export an object and experimenting the folling error at the "erase coplanar edges":
An error occurred in Round Push Pull
Error in generation of the geometry

reference to deleted Entity

jointpushpullgeometry.rbe: 1023 -- entityID
jointpushpullgeometry.rbe: 1023 -- block in geometry_coplanar_edges
jointpushpullgeometry.rbe: 1020 -- each
jointpushpullgeometry.rbe: 1020 -- geometry_coplanar_edges
jointpushpullgeometry.rbe: 366 -- block in geometry_robot_erase_coplanar_edges
jointpushpullgeometry.rbe: 362 -- each
jointpushpullgeometry.rbe: 362 -- geometry_robot_erase_coplanar_edges
jointpushpullgeometry.rbe: 220 -- robot_call_action
jointpushpullgeometry.rbe: 183 -- geometry_robot_exec
jointpushpullgeometry.rbe: 166 -- geometry_robot
jointpushpullgeometry.rbe: 81 -- block in geometry_execute
lib6operation.rbe: 370 -- step_geometry
lib6operation.rbe: 305 -- block in yield?

What i'm doing wrong?
0

hugoakio 
 

Re: [Plugin Library] LibFredo6 - v9.5g - 09 Feb 20

Postby fredo6 » Tue Feb 11, 2020 8:54 pm

hugoakio wrote:What i'm doing wrong?

Nothing a priori.

I have fixed the problem itself (to go in a next version of JPP), but that does not mean you will get a correct result, because you must likely be in a special situation of topology (which RoundPushPull is very sensitive to).

It would help if you posted the model and indicate which operation you were trying to perform.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby daniabreu1 » Wed Apr 01, 2020 6:10 pm

Hi, I am having a problem with this plugin SU2020 - Trying to use the jointpushpull= and a little grade surface keep showing up and the tool doesn't work. Any solutions?
0

daniabreu1 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby Dave R » Thu Apr 02, 2020 1:56 pm

You've given no useful information making it impossible to help. Share your SketchUp file and give a clear description of what you are trying to accomplish. Also show us what settings you are using with the extension.
1
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby daniabreu1 » Fri Apr 03, 2020 7:59 pm

Thanks Dave. Somehow I uninstall it and installed again and it works. Thank you for trying to help tho! :)
0

daniabreu1 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby daniabreu1 » Thu Apr 16, 2020 1:54 am

Good evening everybody,

Again I am having problem ith the thickener.


Date: 15-Apr-20 20:31:28
An error occurred in Thickener
Error in generation of the geometry

Cannot convert argument to Geom::Point3d

jointpushpullgeometry.rbe:: 531 -- vector_to
jointpushpullgeometry.rbe:: 531 -- geometry_block_reversal
jointpushpullgeometry.rbe:: 243 -- geometry_robot_prepare_mesh
jointpushpullgeometry.rbe:: 212 -- robot_call_action
jointpushpullgeometry.rbe:: 183 -- geometry_robot_exec
jointpushpullgeometry.rbe:: 166 -- geometry_robot
jointpushpullgeometry.rbe:: 81 -- block in geometry_execute
lib6operation.rbe:: 370 -- step_geometry
lib6operation.rbe:: 419 -- start_execution
jointpushpullgeometry.rbe:: 81 -- geometry_execute
jointpushpulltool.rbe:: 1118 -- go_preview_or_geom
jointpushpulltool.rbe:: 844 -- dragging_stop
jointpushpulltool.rbe:: 1399 -- execute_validate
jointpushpulltool.rbe:: 1590 -- onReturn

I have LibFredo6v9.5k and using SU2020. There is a post describing almost the same thing:

"It's a fairly complex surface - a piece of terrain that is a hill with sections cut out of it (I draped a road onto the surface so that counts as a separate surface, for example)."

It was solve with Libfredo 9.0 but I have 9.5 version.

Any idea?

Thank you all.
0

daniabreu1 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby fredo6 » Thu Apr 16, 2020 12:05 pm

I fixed the error in the code, but somehow this reflects a problem or complexity in the generated geometry. It may be helpful to get the model where it happens.

I am no longer able to publish updates to my plugins, pending Sketchup changes to their releasing process for developers.

So the fix will go in the next version whenever I can resume publishing.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby rv1974 » Wed May 06, 2020 11:57 am

Hi Fredo,
Say I have a surface cut to non-coplanar patches by visible edges.
I can't find a proper combination of Borders+Surface selection settings to perform a global JPP so every patch would get an independent border by contour (BTW there's some negative molding).
I'm able to JJP manually patch-by-patch (demonstrated in attached gif) but there's no way to process all surface en-masse instantly.
Would it be possible to implement please?
0

rv1974 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby fredo6 » Wed May 06, 2020 2:20 pm

First, you could select the 4 surfaces at once
- select the first surface
- Move over the other surfaces with SHIFT pressed
- Release Shift

Second, if you do it surface by surface, you should toggle on the button "Neighbour influence" in the 'Misc' sub-palette.

Extend Faces.png
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby rv1974 » Wed May 06, 2020 6:03 pm

Fredo, I don't understand. Could you please show 'one click' procedure (not strip by strip clicks). thank you in advance.
0

rv1974 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby fredo6 » Wed May 06, 2020 6:27 pm

rv1974 wrote:Fredo, I don't understand. Could you please show 'one click' procedure (not strip by strip clicks). thank you in advance.

I am not clear. Do you want a 'valley' between each surface or have them joined.

If you wish the valleys, then you have to select the surfaces one by one. Otherwise, you would mold the whole terrain.

JPP RV1974 Terrain.gif
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby rv1974 » Wed May 06, 2020 7:28 pm

:lol: you just exactly reproduced the way I created the 'wanted' model.
Originally I just wanted clarity (or request ;)) maybe there's some combination of settings that allows to achieve the 'wanted' result without tedious 'one by one' clicking
0

rv1974 
 

Re: [Plugin] JointPushPull Interactive - v4.4e - 02 Jun 19

Postby fredo6 » Wed May 06, 2020 7:38 pm

rv1974 wrote::lol: you just exactly reproduced the way I created the 'wanted' model.
Originally I just wanted clarity (or request ;)) maybe there's some combination of settings that allows to achieve the 'wanted' result without tedious 'one by one' clicking

Many things can be done, but it would make the UI more complex...
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: Google Bot and 10 guests

Visit our sponsors: