[Plugin] FredoTools - v4.0a - 17 May 20

Re: [Plugin] FredoTools - v4.0a - 17 mai 20

Postby Ste34 » Mon May 25, 2020 11:10 pm

Bonjour,

Je n'arrive pas à lancer votre plugin, L'erreur ci-dessous s'affiche lors du lancement de sketchup :
Auriez vous une solution à me proposer ?

Cordialement

Erreur de chargement du fichier Fredo6_!LibFredo6.rb
Error: #<Errno::EACCES: Permission denied @ rb_sysopen - C:/Users/ST1DCE~1/AppData/Local/Temp/Fredo6_LibFredo6_TemporaryFiles/LibFredo6Trace_17_1590444009629.txt>
c:/users/sté/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:113:in `initialize'
c:/users/sté/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:113:in `open'
c:/users/sté/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:113:in `log'
c:/users/sté/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:166:in `startup'
C:/Users/sTé/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:65:in `process'
C:/Users/sTé/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:72:in `<module:LibFredo6_Loader>'
C:/Users/sTé/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:30:in `<top (required)>'
Erreur de chargement du fichier Fredo6_FredoTools.rb
Error: #<TypeError: can't convert nil into an exact number>
C:/Users/sTé/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:81:in `-'
C:/Users/sTé/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:81:in `<top (required)>'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Program Files/SketchUp/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Users/sTé/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_FredoTools.rb:47:in `<module:Fredo6>'
C:/Users/sTé/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_FredoTools.rb:26:in `<top (required)>'
0

Ste34 
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby Avex » Thu May 28, 2020 7:59 pm

Exactly the same over here...
0

Avex 
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby TIG » Thu May 28, 2020 8:12 pm

You have an accented character in your Windows user-name:
c:/users/sté/appdata/...
This used to be the kiss-of-death to older Ruby versions, but with the newer 'encode' methods most user's paths can be re-encoded into a 'Ruby-safe' format...
Clearly something is going wrong !
I'm sure that Fredo will have ideas, and a solution...
Watch this space...

Vous avez un caractère accentué dans votre nom d'utilisateur Windows:
c:/users/sté/appdata/...
Auparavant, c'était le baiser de la mort pour les anciennes versions de Ruby, mais avec les nouvelles méthodes d'encodage, la plupart des chemins de l'utilisateur peuvent être ré-encodés au format 'Ruby-safe' ...
De toute évidence, quelque chose ne va pas!
Je suis sûr que Fredo aura des idées et une solution ...
Surveillez cet endroit...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby CTH1963 » Tue Jun 02, 2020 12:29 am

CTH1963 wrote:
fredo6 wrote:
CTH1963 wrote:
Hi,

Since the 4.0a release I get an error when starting Sketchup (screenshot attached).

All other updates have been fine...

Please note that I do not support evolution for my plugins for versions prior to SU2017 (so up to SU2016). This is due to a change of policy in the releasing of extension by Trimble.

For convenience, I kept the legacy versions in this place.


Thanks, I was hoping to get a link to the prior version - much appreciated.


Ok, I've now installed LibFredo v9.5k from the Sketchucation store which says it's OK for SU versions up to 2016. When Skethcup restarts, I get a dialog saying:

"This legacy version of LibFredo6 can ONLY be used for Sketchup version prior to SU2016"

This implies: new LibFredo only for SU >=2017
legacy LibFrdeo only for SU <= 2015

No provision for SU2016?!?

I look in Fredo6_!LibFredo6.rb and see one of the first the lines is:

if Sketchup.version.to_i < 16

Thinking this was a typo I edited it to test for '< 17' and now the result is:

"Wrong installation: Folder Fredo6_!LibFredo6 is missing in <my plugins location>"

I can confirm the folder is present in the location that it's complaining about.

I'm not sure what's going on here - any help appreciated.
0

CTH1963 
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby Dave R » Tue Jun 02, 2020 12:50 am

What is your "plugins location"? What version of SketchUp are you using? Please complete your profile.
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby fredo6 » Tue Jun 02, 2020 4:55 am

@CTH1963,

Thanks for signaling this problem. I have updated the Prior2017 - LibFredo6 - Archived version on the Sketchucation Extension Store.

Initially, I thought I could exclude SU2016 from legacy, but there are other elements that will be deprecated in Sketchup also in this version. So I ended up to consider Legacy all SU versions <= 2016.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby Avex » Tue Jun 02, 2020 6:03 am

fredo6 wrote:@CTH1963,

Thanks for signaling this problem. I have updated the Prior2017 - LibFredo6 - Archived version on the Sketchucation Extension Store.

Initially, I thought I could exclude SU2016 from legacy, but there are other elements that will be deprecated in Sketchup also in this version. So I ended up to consider Legacy all SU versions <= 2016.

Fredo


Fredo, I have 2019 and the problem remains.
0

Avex 
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby fredo6 » Tue Jun 02, 2020 6:39 am

@Avex

Your problem is related to permission of Sketchup to access the AppData directories.

Code: Select all
Erreur de chargement du fichier Fredo6_!LibFredo6.rb
Error: #<Errno::EACCES: Permission denied @ rb_sysopen -
C:/Users/ST1DCE~1/AppData/Local/Temp/Fredo6_LibFredo6_TemporaryFiles/LibFredo6Trace_17_1590444009629.txt>


I guess this is related to setting the proper security parameters.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby TIG » Tue Jun 02, 2020 11:35 am

@Avex

As Fredo says it's caused by your computer not having permissions set up correctly.
This is usually because the user double-clicked the installer's exe file to 'Run' it.
You can do a 'Repair' as follows...

While logged into Windows as your normal user-account, ensure that SketchUp is closed.
Find the SketchUp installer's exe file - usually in your Downloads folder ?
Select the installer's exe file's icon and right-click > context-menu > "Run as administrator"
When prompted choose "Repair" [note that for a brand new installation that would be "Install"].
When it completes retry and seem if the permissions are now set right...

Sometimes permissions to extension's own Temp files like this can be messed up and you need to delete the folder:
C:/Users/ST1DCE~1/AppData/Local/Temp/Fredo6_LibFredo6_TemporaryFiles
When SketchUp is next started it'll be recreated with good permissions

These folders are hidden, but pasting C:/Users/ST1DCE~1/AppData/Local/Temp/ in a Windows Explorer path-bar should take you there...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby CTH1963 » Wed Jun 03, 2020 12:39 am

Dave R wrote:What is your "plugins location"? What version of SketchUp are you using? Please complete your profile.


Plugin folder:

c:\Users\Chris\AppData\Roaming\SketchUp\SketchUp 2016\SketchUp\Plugins

So you can see the Sketchup version is 2016.

The permissions on the ../Appdata/.. tree of directories is 'Full Control' for 3 users:

SYSTEM
Chris (me - member of Users and Administrators)
Administrators

So I can't imagine that Sketchup should have any problems with accessing the plugins folder - it never has in the past 4 years & it's running on the same PC for all that time.

I'll try applying the updated build Fredo mentions below.

Thanks for all the suggestions.
0

CTH1963 
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby CTH1963 » Wed Jun 03, 2020 1:28 am

CTH1963 wrote:
Dave R wrote:What is your "plugins location"? What version of SketchUp are you using? Please complete your profile.


Plugin folder:

c:\Users\Chris\AppData\Roaming\SketchUp\SketchUp 2016\SketchUp\Plugins

So you can see the Sketchup version is 2016.

The permissions on the ../Appdata/.. tree of directories is 'Full Control' for 3 users:

SYSTEM
Chris (me - member of Users and Administrators)
Administrators

So I can't imagine that Sketchup should have any problems with accessing the plugins folder - it never has in the past 4 years & it's running on the same PC for all that time.

I'll try applying the updated build Fredo mentions below.

Thanks for all the suggestions.


Update:
Installing the updated plugin (via sketchucation Plugin Store extension) still results in the dialog "Wrong installation..." per my previous reply. I can see the Fredo6_!LibFredo6 folder and associated Fredo6_!LibFredo6.rb file is present in the plugins directory.

@Fredo, I have nothing in Appdata/local/temp with "Fredo" in it's name but cleared all anyway with no difference in result. BTW, can you pls explain how to get the error log example quoted in your reply?

Thx.
0

CTH1963 
 

Solved - Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby CTH1963 » Wed Jun 03, 2020 2:03 am

CTH1963 wrote:
CTH1963 wrote:
Dave R wrote:What is your "plugins location"? What version of SketchUp are you using? Please complete your profile.


Plugin folder:

c:\Users\Chris\AppData\Roaming\SketchUp\SketchUp 2016\SketchUp\Plugins

So you can see the Sketchup version is 2016.

The permissions on the ../Appdata/.. tree of directories is 'Full Control' for 3 users:

SYSTEM
Chris (me - member of Users and Administrators)
Administrators

So I can't imagine that Sketchup should have any problems with accessing the plugins folder - it never has in the past 4 years & it's running on the same PC for all that time.

I'll try applying the updated build Fredo mentions below.

Thanks for all the suggestions.


Update:
Installing the updated plugin (via sketchucation Plugin Store extension) still results in the dialog "Wrong installation..." per my previous reply. I can see the Fredo6_!LibFredo6 folder and associated Fredo6_!LibFredo6.rb file is present in the plugins directory.

@Fredo, I have nothing in Appdata/local/temp with "Fredo" in it's name but cleared all anyway with no difference in result. BTW, can you pls explain how to get the error log example quoted in your reply?

Thx.


I think I found the issue: The line below in Fredo6_!LibFredo6.rb

Code: Select all
file_encrypted = (Sketchup.version.to_i >= 16) ? folder + ".rbe" : folder + ".rbs"


selects the .rbe file which doesn't exist - the .rbs file *does*. Changing the version test to >=17 solved the problem.

Thanks everyone for your attention to the issue.
1

CTH1963 
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby CTH1963 » Wed Jun 03, 2020 2:50 am

FWIW, there's also a version test in Fredo6_RoundCorner.rb (v3.3a):

Code: Select all
if Sketchup.version.to_i < 16


that should be changed to '<= 16'...

@Fredo FYI
I tried installing FredoCorner v1.8b which lists the only dependency as LibFredo6 9.1b (archive legacy ver I have installed is 9.5k) but it complains that SU2017 or newer is required. The 'More Info' page says it should work for SU2016 and above...

Cheers,
Chris.
0

CTH1963 
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby fredo6 » Wed Jun 03, 2020 8:30 am

@CTH1963

If you run Sketchup SU2016, then you MUST use the legacy versions of my plugins.

There are here.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools - v4.0a - 17 May 20

Postby gridlandscape » Tue Oct 20, 2020 11:17 pm

this plug in is always very useful. thankyou so much
0

gridlandscape 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

Previous


 

Return to Plugins

Who is online

Users browsing this forum: ayyasnaufal, ge92028 and 20 guests

Visit our sponsors: