[Plugin] FredoTools - v3.8a - 18 Nov 19

Re: [Plugin] FredoTools 1.1j - 11 Apr 12

Postby Oxer » Thu Apr 12, 2012 8:49 pm

Thanks Fredo!! :berserk: :thumb:
Spanish Language
FredoTools_ES.lang
0
"The result is the end what is important is the process" by Oxer
http://www.oxervision.blogspot.com/
User avatar
Oxer 
 

Re: [Plugin] FredoTools 1.1j - 11 Apr 12

Postby fredo6 » Thu Apr 12, 2012 8:53 pm

Oxer wrote:Thanks Fredo!! :berserk: :thumb:
Spanish Language
FredoTools_ES.lang

Oxer,

Thanks very much.
I just realized that I did not make the Help of VCB and shortcuts translatable. So I'll make it in a next release. This means that there will be some additional strings to translate.

Thanks again

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools 1.1j - 11 Apr 12

Postby Oxer » Thu Apr 12, 2012 8:58 pm

There isn't problem Fredo, i'll translate it and thanks again for these incredible tools. :thumb:
0
"The result is the end what is important is the process" by Oxer
http://www.oxervision.blogspot.com/
User avatar
Oxer 
 

Re: [Plugin] FredoTools 1.1j - 11 Apr 12

Postby Oxer » Thu Apr 12, 2012 11:49 pm

I'm testing the FredoTools plugin and i have found some problems:
- The arrows keys don't work on Mac.
- When you use the first time "Remove Lonely Vertices" and you select "Remove" then if you push the icon "Launch FredoTools plugins from a list" the window of the list don't appears.
For the moment the rest of the features works fine on Mac.
0
"The result is the end what is important is the process" by Oxer
http://www.oxervision.blogspot.com/
User avatar
Oxer 
 

Re: [Plugin] FredoTools 1.1m - 14 Apr 12

Postby notareal » Sun Apr 15, 2012 9:33 am

Nice update!
0
Welcome to try Thea Render, Thea support | kerkythea.net -team member

notareal 
Thea Render Support
Thea Render Support
 

Re: [Plugin] FredoTools 1.1m - 14 Apr 12

Postby schnydix » Sun Apr 15, 2012 11:17 am

Thanks Fredo Nice Work
Need Help Can not Save my new german translation ??
and in 000_AdditionalPluginFolders i got the message:

2ERRORS The Following plugins had errors and may not be fully loaded
Plugin: LMapExt.so
Folder:C/ProgramFiles(x86)Google/GoogleSketchup8/Plugins
ERROR: (eval):1: uninitialized constant
AdditionalPluginFolder6;;LMap
(I Have Not createt an extra Plugin Folder)
and
Plugin: win 32api.so
ERRER: 127
Init_win32api
C/ProgramFiles(x86)Google/GoogleSketchup8/Plugin/win 32api.so

Thanks for help

SU8 on win7
0

schnydix 
 

Re: [Plugin] FredoTools 1.1m - 14 Apr 12

Postby fredo6 » Sun Apr 15, 2012 11:54 am

schnydix wrote:Thanks Fredo Nice Work
Need Help Can not Save my new german translation ??
and in 000_AdditionalPluginFolders i got the message:

2ERRORS The Following plugins had errors and may not be fully loaded
Plugin: LMapExt.so
Folder:C/ProgramFiles(x86)Google/GoogleSketchup8/Plugins
ERROR: (eval):1: uninitialized constant
AdditionalPluginFolder6;;LMap
(I Have Not createt an extra Plugin Folder)
and
Plugin: win 32api.so
ERRER: 127
Init_win32api
C/ProgramFiles(x86)Google/GoogleSketchup8/Plugin/win 32api.so

Thanks for help

SU8 on win7

This does not seem related to my scripts.
Maybe some users could tell what is this LmapExt.so file

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools 1.1m - 14 Apr 12

Postby Rich O Brien » Sun Apr 15, 2012 11:59 am

It's associated with LightUp and it should be in the Tools folder
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [Plugin] FredoTools 1.1n - 21 Apr 12

Postby maddesign » Sun Apr 22, 2012 8:26 am

I downloaded last FredoTools 1.1 and LibFredo 44, all tools works good except ThruPaint. When i paint by texture(not by colour!) ScetchUp8 crushes! What is a reson of it?
0

maddesign 
 

Re: [Plugin] FredoTools 1.1n - 21 Apr 12

Postby JClements » Sun Apr 22, 2012 5:20 pm

Could "Reverse Faces" be available in the context menu of Thru Paint?
0
John
Illustrator
Beaverton, Oregon
User avatar
JClements 
Premium Member
Premium Member
 

Re: [Plugin] FredoTools 1.1n - 21 Apr 12

Postby fredo6 » Sun Apr 22, 2012 8:58 pm

JClements wrote:Could "Reverse Faces" be available in the context menu of Thru Paint?

I think this is possible, but the Auto-flip option was there precisely to flip faces on the same side.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools 1.1n - 21 Apr 12

Postby fredo6 » Sun Apr 22, 2012 9:00 pm

maddesign wrote:I downloaded last FredoTools 1.1 and LibFredo 44, all tools works good except ThruPaint. When i paint by texture(not by colour!) ScetchUp8 crushes! What is a reson of it?

Is it reproducible and systematic?
Are you sure this is only with texture, never with color?

Thanks

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools 1.1n - 21 Apr 12

Postby rv1974 » Mon Apr 23, 2012 10:04 am

Fredo why don't you incorporate 'LibFredo' files with 'Fredo tools' pack?
0

rv1974 
 

Re: [Plugin] FredoTools 1.1n - 21 Apr 12

Postby fredo6 » Mon Apr 23, 2012 10:32 am

rv1974 wrote:Fredo why don't you incorporate 'LibFredo' files with 'Fredo tools' pack?

Simply because LibFredo6 is used by many of my other plugins and that you usually need to have the latest version installed.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools 1.1n - 21 Apr 12

Postby rv1974 » Mon Apr 23, 2012 11:39 am

Fredo6 wrote:
rv1974 wrote:Fredo why don't you incorporate 'LibFredo' files with 'Fredo tools' pack?

Simply because LibFredo6 is used by many of my other plugins and that you usually need to have the latest version installed.

Fredo

So incorporate all your stuff (which ~90% is a 'must have') in ONE megapack (with ability to selectively install\uninstall)
Just like another guru does:
http://www.neilblevins.com/cg_tools/soulburnscripts/soulburnscripts.htm
0

rv1974 
 

Re: [Plugin] FredoTools 1.1n - 21 Apr 12

Postby maddesign » Mon Apr 23, 2012 12:25 pm

Fredo6 wrote:
maddesign wrote:I downloaded last FredoTools 1.1 and LibFredo 44, all tools works good except ThruPaint. When i paint by texture(not by colour!) ScetchUp8 crushes! What is a reson of it?

Is it reproducible and systematic?
Are you sure this is only with texture, never with color?

Thanks

Fredo

Yes, Fredo. This is systematic and this is with textures only. As i put brush with texture to an object, it stay panted by texture,red clocks of waiting appears and program fly out immediately! All other plugins and programmes works properly.
Thanks.
TrP.JPG
0

maddesign 
 

Re: [Plugin] FredoTools 1.1n - 21 Apr 12

Postby Didier Bur » Fri Apr 27, 2012 1:02 pm

Hi Fredo,
Apart from all my congatulations for this marvelous plugin, just one wish: would it be possible to set the font size used in the dialog boxes and palettes ? (See below)
fredoToolsFontSize.jpg

Best regards,
0
Didier Bur
Ecole Nationale Supérieure d'Architecture de Nancy (F)
http://rld.crai.archi.fr/rubylibrarydepot/
User avatar
Didier Bur 
 

Re: [Plugin] FredoTools 1.1n - 21 Apr 12

Postby fredo6 » Fri Apr 27, 2012 3:45 pm

Didier Bur wrote:Hi Fredo,
Apart from all my congatulations for this marvelous plugin, just one wish: would it be possible to set the font size used in the dialog boxes and palettes ? (See below)
fredoToolsFontSize.jpg

Best regards,

Didier,

I have no control over the font size of text displayed within a Tool (i.e. view.draw_text).
Do you know how to do it?

Thanks

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools 1.1n - 21 Apr 12

Postby saber » Tue May 01, 2012 8:22 pm

help me plz.....when i start sketch up 7, i vizit this massage (undefined method `register_plug' for FredoTools:ModuleError ) any many of this plugin dosent work....whats my solve?
0

saber 
 

Re: [Plugin] FredoTools 1.1n - 21 Apr 12

Postby TIG » Wed May 02, 2012 11:16 am

saber wrote:help me plz.....when i start sketch up 7, i vizit this massage (undefined method `register_plug' for FredoTools:ModuleError ) any many of this plugin dosent work....whats my solve?
Have you downloaded the supporting folder [LibFredo...]?
It is linked from the main download page.
If you do not have that folder installed most of the Fredo tools will not work!
If you have installed it then make sure that it is installed properly - as explained on its own download page...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] FredoTools 1.2a - 08 May 12

Postby fredo6 » Tue May 08, 2012 10:43 pm

NEW RELEASE: FredoTools v1.2a - 08 May 12

This update is dedicated to ThurPaint 1.2. It fixes some bugs and introduces Painting of Components, groups, text labels and Dimensions. See this post for details.

See main post of this thread for download of FredoTools.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools 1.2a - 08 May 12

Postby jorge2011 » Sat Aug 04, 2012 5:25 pm

fredo, is possible add other tool?
a tool that with one click an item or unlocking hidden + hide.
and another for displaying the items hidden.

is it possible? thanks
0

jorge2011 
 

Re: [Plugin] FredoTools 1.2a - 08 May 12

Postby TIG » Sat Aug 04, 2012 6:30 pm

jorge2011 wrote:fredo, is possible add other tool?
a tool that with one click an item or unlocking hidden + hide.
and another for displaying the items hidden.
is it possible? thanks
Can't you do most of this from the context-menu [lock/unlock & hide/unhide] and/or a simple shortcut-key to hide/unhide geometry [view-menu], combined with shortcut-keys to 'hide-rest of model' and 'hide similar components' [view>component-edit]... and the Entity-Info or Layer-drop-down list to give objects an 'off' layer etc... these add up to a powerful set of tools - without the need for an extra tool...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] FredoTools 1.2a - 08 May 12

Postby smicha » Thu Aug 30, 2012 11:05 am

I just noticed strange behavior of "Remove lonely vertices" tool. It wants to remove not lonely vertices on a circle - look at the screenshot.
Is this due to the new version of SU 8.0.15158?
0

smicha 
 

Re: [Plugin] FredoTools 1.2a - 08 May 12

Postby TIG » Thu Aug 30, 2012 11:46 am

I can't get that problem to repeat.... unless I make extreme segmentation of an arc - to unreasonable extents.
To check if a vertex with two edges is 'unneeded' the tool checks if those two edges are parallel and if they are then the vertex is removed. The accuracy of Sketchup's vector checks for them to be considered parallel, is to a tiny fraction of a degree.
A curve with very small segments might appear to have its adjacent edge segments that are then effectively 'parallel'. However, you will need to have very tiny segment lengths relative to the curve's radius; e.g. ~1mm segments for a 500mm radius... which is then running into hundreds of segments...
So for me it only gets confused if you have 'extreme segmentation'.
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] FredoTools 1.2a - 08 May 12

Postby smicha » Thu Aug 30, 2012 12:17 pm

TIG,
Thank you. The distance between consecutive vertices on the circle is 0.0582 cm (72 segments per circle), so your explanation is correct. I just noticed that sometimes the plugin wants to remove vertices, sometimes it works fine on a similar sized circle.
0

smicha 
 

Re: [Plugin] FredoTools 1.2a - 08 May 12

Postby smicha » Thu Aug 30, 2012 12:27 pm

TIG,
I set number of segments per circle from 72s to 48s and the problem gone.

Thank you.
0

smicha 
 

Re: [Plugin] FredoTools 1.2a - 08 May 12

Postby solid-wood » Thu Aug 30, 2012 9:29 pm

Hi Fredo6,

Thanks for very good tools.
I just have a problem with the new upgrades. I get a lot of german in most of the displays. Can't change it.
Buttons get german text...look at the pictures. Plus the black backgrounds! Is there anything to do?..as I don't speak german to good.
I am on a Mac, latest OS.
Thanks again for great tools.

1.png


2.png


3.png


5.png
0
User avatar
solid-wood 
 

Re: [Plugin] FredoTools 1.2a - 08 May 12

Postby fredo6 » Fri Aug 31, 2012 1:30 pm

Jan,

Can you check in the menu Windows > LibFredo6 Settings... > Preferred lqnguages.

As there is no Swedish translation (yet), I guess you'll prefer the "No Preference", which defaults to (my) English.

Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

Re: [Plugin] FredoTools 1.2a - 08 May 12

Postby solid-wood » Fri Aug 31, 2012 3:13 pm

Fredo6 wrote:Jan,

Can you check in the menu Windows > LibFredo6 Settings... > Preferred lqnguages.

As there is no Swedish translation (yet), I guess you'll prefer the "No Preference", which defaults to (my) English.

Fredo


Hi Fredo,
Thank You for fast response.
I had since before - English - as 1st choice, but left 2nd for Norwegian and 3rd to German. Now I changed all to English.
That help some, but I still get a lot of german in the drop-downs.
When I go back to do what You said "window-....." it is German in the drop-downs again and 1st choice is English and 2nd & 3rd is auto-changed to "none" ? FredoScale is really "German" ...there is still german in all of them, more or less.
Anything else I can do?
Sincerely
0
User avatar
solid-wood 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: amirhosein, KFGNature and 16 guests

Visit our sponsors: