[Plugin] QuadFaceTools

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby Gaieus » Wed Oct 05, 2011 10:44 am

Sensational, TT. Now I can make my Arch texturing tutorial #3! :ecstatic:
0
User avatar
Gaieus 
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby thomthom » Wed Oct 05, 2011 10:45 am

Gaieus wrote:Sensational, TT. Now I can make my Arch texturing tutorial #3! :ecstatic:

Looking forward to it!
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby jorge2011 » Wed Oct 05, 2011 10:46 am

thank you very much for this excellent update. is excellent.
unfortunately I have a problem:). sketchup generates the following error:

Error al cargar archivo C:/Archivos de programa/Google/Google SketchUp 8/Plugins/TT_QuadFaceTools/core.rb
undefined method `to_l' for nil:NilClassError al cargar archivo tt_quadface.rb
undefined method `to_l' for nil:NilClass

how I can fix this?
0

jorge2011 
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby thomthom » Wed Oct 05, 2011 10:47 am

jorge2011 wrote:thank you very much for this excellent update. is excellent.
unfortunately I have a problem:). sketchup generates the following error:

Error al cargar archivo C:/Archivos de programa/Google/Google SketchUp 8/Plugins/TT_QuadFaceTools/core.rb
undefined method `to_l' for nil:NilClassError al cargar archivo tt_quadface.rb
undefined method `to_l' for nil:NilClass

how I can fix this?

When do you get this error?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby jorge2011 » Wed Oct 05, 2011 10:57 am

when I start sketchup
0

jorge2011 
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby thomthom » Wed Oct 05, 2011 11:16 am

What version of TT_Lib2 do you have?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby jorge2011 » Wed Oct 05, 2011 4:27 pm

the last version
0

jorge2011 
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby jorge2011 » Wed Oct 05, 2011 4:28 pm

is odd. install this plugin yesterday and worked well.
Today I went back to start and generated that error sketchup
0

jorge2011 
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby thomthom » Wed Oct 05, 2011 4:46 pm

jorge2011 wrote:the last version
Can you check exactly what version you have to be sure? Type TT::Lib::VERSION into the Ruby Console. I just want to make sure as I've had cases before where users thought they had the latest, but turned out that they didn't.


Does it give you that error every time?
If so, after you started SU, can you open the Ruby Console and type: load 'tt_quadface.rb' and post back any errors if there is any.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby jorge2011 » Wed Oct 05, 2011 5:32 pm

TT::Lib::VERSION 2.5.8
When I write load 'tt_quadface.rb' , ruby console generates the following message:
load 'tt_quadface.rb'
C:/Archivos de programa/Google/Google SketchUp 8/Plugins/tt_quadface.rb:20: warning: already initialized constant PLUGIN
C:/Archivos de programa/Google/Google SketchUp 8/Plugins/tt_quadface.rb:21: warning: already initialized constant PLUGIN_ID
C:/Archivos de programa/Google/Google SketchUp 8/Plugins/tt_quadface.rb:22: warning: already initialized constant PLUGIN_NAME
C:/Archivos de programa/Google/Google SketchUp 8/Plugins/tt_quadface.rb:24: warning: already initialized constant PLUGIN_VERSION
C:/Archivos de programa/Google/Google SketchUp 8/Plugins/tt_quadface.rb:27: warning: already initialized constant PATH_ROOT
C:/Archivos de programa/Google/Google SketchUp 8/Plugins/tt_quadface.rb:28: warning: already initialized constant PATH
C:/Archivos de programa/Google/Google SketchUp 8/Plugins/tt_quadface.rb:29: warning: already initialized constant PATH_ICONS
Error: #<NoMethodError: C:/Archivos de programa/Google/Google SketchUp 8/Plugins/TT_Lib2/settings.rb:51:in `[]': undefined method `to_l' for nil:NilClass>
(eval)
C:/Archivos de programa/Google/Google SketchUp 8/Plugins/TT_Lib2/settings.rb:90:in `set_default'
C:/Archivos de programa/Google/Google SketchUp 8/Plugins/TT_QuadFaceTools/core.rb:45
C:/Archivos de programa/Google/Google SketchUp 8/Tools/extensions.rb:36:in `require'
C:/Archivos de programa/Google/Google SketchUp 8/Tools/extensions.rb:36:in `load'
C:/Archivos de programa/Google/Google SketchUp 8/Plugins/tt_quadface.rb:41:in `register_extension'
C:/Archivos de programa/Google/Google SketchUp 8/Plugins/tt_quadface.rb:41
(eval):0:in `load'
(eval):0

----
I use
Sketchup 8 in Spanish y windows xp sp3
0

jorge2011 
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby jorge2011 » Wed Oct 05, 2011 6:03 pm

thom thank you very much for your time.
but.

re-install the program sketchup, and now the plugin works fine. I can not have that problem occurred but works fine


:) thank
0

jorge2011 
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby thomthom » Wed Oct 05, 2011 6:11 pm

It works? Good - glad it does.

That last error you posted guides me to where to look. I'll look at the code and see what I can do to avoid it.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby notareal » Wed Oct 05, 2011 7:05 pm

thomthom wrote:Version 0.4.0

Important!
This version redefines what a QuadFace is. In order to use quad face meshes used by older versions you must update them.
Tools > QuadFace Tools > Convert > Sandbox Quads to QuadFace Quads


:sketchstatic: Stunning... You have done amazing work. I hope this will inspire others too. Thank you!
0
Welcome to try Thea Render, Thea support | kerkythea.net -team member

notareal 
Thea Render Support
Thea Render Support
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby Pixero » Wed Oct 05, 2011 7:37 pm

Thanks soo much. Will study it.
0
User avatar
Pixero 
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby thomthom » Fri Oct 07, 2011 10:24 am

Has anyone gotten around to try the UV mapping feature?

I know it has some issues and the UI needs improving.

What worked and what didn't work? What's unclear and what is not?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby Rich O Brien » Fri Oct 07, 2011 11:08 am

I did some quick tests.

When using "Unwrap Picked Grid" it'd be nice if it used inferencing.

Sometimes the texture reverses though I haven't reproduced this regularly.

Other than that it's nomnomnomnomnomnomnomnomnomnomnom

ThomThomQuadQuadYesYes.png
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby thomthom » Fri Oct 07, 2011 11:40 am

Rich O'Brien wrote:When using "Unwrap Picked Grid" it'd be nice if it used inferencing.

For placing the grid?

Rich O'Brien wrote:Sometimes the texture reverses though I haven't reproduced this regularly.

O'RLY? o_O Let me know if you can reproduce it. And even if you can't, post the result?

Btw, that UV test tile you got there... ?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby Rich O Brien » Fri Oct 07, 2011 11:42 am

What about my UV test tile? You don't like it?
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby Rich O Brien » Fri Oct 07, 2011 11:43 am

yes for placing the grid
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby TIG » Fri Oct 07, 2011 11:44 am

Here are a couple I use.
UV_Test_Map.jpg
UVtestTile.jpg
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby thomthom » Fri Oct 07, 2011 12:04 pm

Rich O'Brien wrote:What about my UV test tile? You don't like it?

Yea I do. I gives a larger illustration of the UV flow.

TIG wrote:Here are a couple I use.

:thumb: :thumb:
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby Pixero » Fri Oct 07, 2011 12:37 pm

Hmm, for some reason I'm having trouble selecting the V direction.
(Especially if I try to click on an outer edge.)
Usually, selecting the U direction works.
Then for V it doesnt select what I'm clicking on. :?
When I click the edge on the other side of the selected U edge, "mirrored from the first", it works more often, but the texture isn't applied as I would like. :(
I'm having this problem with every model I tried.
SU 8, Windows 7 64.
0
User avatar
Pixero 
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby derei » Fri Oct 07, 2011 12:40 pm

Hello, I noticed a error when opening a a second SU instance (if I have one already opened and I want a second one), you can see it here.
Thank you.
0
DESIGNER AND ARTIST DEREI.UK
User avatar
derei 
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby thomthom » Fri Oct 07, 2011 12:59 pm

Pixero wrote:Hmm, for some reason I'm having trouble selecting the V direction.
(Especially if I try to click on an outer edge.)
Usually, selecting the U direction works.
Then for V it doesnt select what I'm clicking on. :?
When I click the edge on the other side of the selected U edge, "mirrored from the first", it works more often, but the texture isn't applied as I would like. :(
I'm having this problem with every model I tried.
SU 8, Windows 7 64.

Screenshots? Video?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby thomthom » Fri Oct 07, 2011 1:04 pm

dereeei wrote:Hello, I noticed a error when opening a a second SU instance (if I have one already opened and I want a second one), you can see it here.
Thank you.

Does that happen every time?
After you've gotten such an error, what do you get if you open the Ruby Console and type load 'tt_quadface.rb'?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby Rich O Brien » Fri Oct 07, 2011 1:09 pm

Here's a little library of 10 UV maps.

SCF UV Maps.zip


Here's the pretty one you like...

Rich_UV_Map.jpg
0
There's a frontroom and a backroom....reverse faces
User avatar
Rich O Brien 
Administrator
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby derei » Fri Oct 07, 2011 1:57 pm

thomthom wrote:Does that happen every time?
After you've gotten such an error, what do you get if you open the Ruby Console and type load 'tt_quadface.rb'?

It does every time.
If I load it from console, it happens this:
QuadFace_reload.png
0
DESIGNER AND ARTIST DEREI.UK
User avatar
derei 
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby thomthom » Fri Oct 07, 2011 2:21 pm

Thanks - will look into it.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby cmeed » Fri Oct 07, 2011 5:01 pm

great to see a video and what amazing work you put into this forum. really well done.

I'm trying this out for the first time and am having some trouble, the problem is that i can put a texture in but then cant change it to a new one

Its basically only works once and you can't map anything else to that shape. or i've missed something. - I'm on a mac

(suggestion - is there a roll over help pop up that can be used that when you leave the curser ove an icon a pop up help describes the function?)
0
User avatar
cmeed 
Premium Member
Premium Member
 

Re: [Plugin] QuadFaceTools (0.4.0b) — 04 October 2011

Postby fredo6 » Fri Oct 07, 2011 5:12 pm

Tom,

Here is the model where I have problem (I get the UV axes, but the texture does not appear).
Quad-mapping Fred.png


Fredo
0
User avatar
fredo6 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: Google Bot, Jonilson, tamachan and 16 guests

Visit our sponsors: