[Plugin] UV Toolkit

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby usen » Mon Nov 19, 2012 1:48 pm

Thanks. :thumb:
0
User avatar
usen 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby mannomann » Thu Dec 06, 2012 7:08 pm

Hi,
sorry for that question: I put the plugin into the plugin folder. But no plugin is in SU. What is wrong?
J.
Cannot read 23 pages for installing problems. Tried to use the search, but no results for that problem.
0

mannomann 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby Gaieus » Thu Dec 06, 2012 7:27 pm

mannomann wrote:...Cannot read 23 pages for installing problems...

Just read the first post and make sure you follow the instructions carefully. Have you also installed the TT_Lib library for instance?
1
User avatar
Gaieus 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby mannomann » Thu Dec 06, 2012 7:45 pm

Didn´t and don´t find installing instructions. And in the downloaded file I also do not see the TT_lib library.
0

mannomann 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby mannomann » Thu Dec 06, 2012 7:51 pm

Ok - thank you.
The missing TT_Lib was the problem.
Best regards
0

mannomann 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby The Firle Fanz » Wed Dec 19, 2012 2:31 pm

Hi,
I already installed the TT_UV_Toolkit at my Laptop at home.
Here on my businesss PC I don´t know anymore and can´t remember where to put the TT_Lib???!!!
And I still do not find a installing instructions for that.
Would somebody please be so kind and show me the install passage?
Or any hint?
Thanks in advance MM

OK - found it.
MM
0

The Firle Fanz 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby dickorama » Thu Jan 24, 2013 5:42 pm

You sure these UV things work on Sketchup 8? I've been getting a lot of errors, namely:

Error Loading File C:/Program Files (x86)/Google/Google SketchUp 8/Plugins/TT_UV_Toolkit/loader.rb
no such file to load -- TT_Lib2/core.rbError Loading File tt_uv_toolkit_2.rb
no such file to load -- TT_Lib2/core.rb

And before you ask, creating the TT_Lib2 folder and placing core.rb in it did not work well. And it's not really my job to try and "hack" plugins so they work.
0

dickorama 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby thomthom » Thu Jan 24, 2013 9:42 pm

dickorama wrote:You sure these UV things work on Sketchup 8? I've been getting a lot of errors, namely:

Error Loading File C:/Program Files (x86)/Google/Google SketchUp 8/Plugins/TT_UV_Toolkit/loader.rb
no such file to load -- TT_Lib2/core.rbError Loading File tt_uv_toolkit_2.rb
no such file to load -- TT_Lib2/core.rb

And before you ask, creating the TT_Lib2 folder and placing core.rb in it did not work well. And it's not really my job to try and "hack" plugins so they work.

It's also not my job to create plugins. I create tools to do my job and I release them for the public to use as is. The least you can do is take a moment to read the instructions of the free tool you're trying to use.

If you go back you will see at the bottom of the thread the footprint of where the files should be. You should not manually create a TT_Lib2 folder and move the core.rb file from UV Toolkit into it. You should install the required TT_Lib2 support library as link right above the UV Toolkit download button, labeled Requirements. It's all there, at a glance. In no way are you supposed to "hack" anything! :roll:

If you have trouble installing plugins you can use this utility: viewtopic.php?f=323&t=42315&p=375454#p375454
It let you install RBZ and ZIP packages. It's an RBZ package itself so follow the instructions in the thread (lots of screenshots) on how to use the Install Extension feature in SketchUp.

For a complete breakdown on installing plugins: http://www.thomthom.net/thoughts/2012/0 ... -sketchup/

(However, installing them to the correct location wasn't the issue here, it was because you didn't read the instructions!)
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby rv1974 » Thu Feb 28, 2013 8:55 am

I've got constant 'Don't panic!' pop-up that 'fixes' the error after applying 'front face mat to back face' (as a result backfaces are messed). Could you take a look at the attachment?
0

rv1974 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby thomthom » Thu Feb 28, 2013 10:08 am

rv1974 wrote:I've got constant 'Don't panic!' pop-up that 'fixes' the error after applying 'front face mat to back face' (as a result backfaces are messed). Could you take a look at the attachment?


I got a warning when I first opened the model. When I said fix problems that reset the backside textures. But when I ran the plugin again, front side to backside and used the Fix Problems button - I got no errors.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby rv1974 » Thu Feb 28, 2013 10:48 am

it will get back sporadically. Any clue what could be the reason?
0

rv1974 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby thomthom » Thu Feb 28, 2013 10:51 am

No. And without being able to reproduce it it's even harder. :s
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby rv1974 » Thu Feb 28, 2013 12:24 pm

I PM-ed you some example. If you interested in some bug hunting it could be useful.
0

rv1974 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby mingjae » Sat Mar 02, 2013 11:53 am

Hello sir,

I am trying to create a golf course, grassy golf course..
and I follow your instruction by creating a plane with segment using sandbox from scratch,
remember the UV> smoove the textured plane > and restore the UV..

I am using a displacement map and render it using vray, this is the result:


on the left is a rectangle plane, and on the right is the smooved sandbox scratch plane,
but seem the grass displacement had a gap (the gray coloured grass)

can u help me how to smooth the grass placement?

edit:
Solved sir, Explode the grouped plane and restore the UV works fine,
before, seems the materials not mapped correctly..
0

mingjae 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby ClausGS » Sat Mar 23, 2013 11:00 am

TIG wrote:Is there a very tiny facet that returns invalid coordinates, that are regarded as the same because of the 'rounding' of its very close vertex-points ?

I just had a perhaps somewhat similar issue with my Octane Exporter [on their forum]... Someone has made a very small object that would have had overly tiny facets when created, if they hadn't scaled it up to process and then back down when done - the small facets can exists, it's just making them that's the issue. So far so good... now they exported it to OBJ format for use in Octane and there were tiny holes in the object when it rendered. Octane requires the OBJ to be in 'm' and have triangulated faces. In processing the meshes my tool uses the API methods to triangulate the mesh's faces. I now think that what was happening was that the triangulation of some tiny quad faces resulted in two triangulated facets that are so small that they have two vertices that 'round' to be at the 'same point' [the OBJ format is set to 'm' 6 d.p.] - therefore that new facet can't exist as its only a 'line' at best, and the two parts can then be missed, out leaving a small quad shaped hole when the object is reformed from the OBJ data...
This could of course also mess with the tiny face's texture mapping ?


HI Tig and Thomthom
I have a similar issue when i try to use the quardface tool to triangulate the surfaces on a rounded corner. some surfaces are not triangulated and instead it have removed the surface, what makes a hole in the surface.
Attached is a pic of before and after triangulation.
Am i doing something wrong here? is it the model issue, or something with the plugin.??

I learned from another post that i can come around this issue by scaling the model 10 times bigger and then do the triangulation, and then scale it down again to the original size. That work's, but that should be possible to incorporate in to the plugin or?

Claus S
0

ClausGS 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby thomthom » Sun Mar 24, 2013 11:10 am

You will get constant problem like this I'd working on models in SketchUp with tiny dimensions.

Adding scaling up and down trick to every tool would be impractical and also be slowing down the tool.

I'd just keep the model scaled up.

Sent from my LT25i using Tapatalk 2
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby Adin0002 » Wed Apr 17, 2013 10:37 pm

hey :) im an architecture student and i need to create a twisted structure onsketchup. can i download UV toolkit on mac OSX version 10.8 ?
0

Adin0002 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby rayisaacs » Wed May 29, 2013 11:21 am

tying to install the uv toolkit and getting this message:

Error Loading File /Library/Application Support/Google SketchUp 8/SketchUp/Plugins/TT_UV_Toolkit/loader.rb
no such file to load -- TT_Lib2/core.rbError Loading File tt_uv_toolkit_2.rb
no such file to load -- TT_Lib2/core.rb

any ideas?

ray
0

rayisaacs 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby TIG » Wed May 29, 2013 12:05 pm

rayisaacs wrote:tying to install the uv toolkit and getting this message:

Error Loading File /Library/Application Support/Google SketchUp 8/SketchUp/Plugins/TT_UV_Toolkit/loader.rb
no such file to load -- TT_Lib2/core.rbError Loading File tt_uv_toolkit_2.rb
no such file to load -- TT_Lib2/core.rb

any ideas?

ray
Yes.
You omitted downloading and installing the TT_Lib2 that this tool needs.
It is clearly explained in the tools download page / info...
Please read any tool's instructions carefully.
Many of Thomthom, Fredo and Chris Fullmer's tools require some 'helpers' [typically a 'Lib' folder or another .rb] - which you need to install before you install the main tool: this requirement is clearly spelled out in each tool's thread and links provided so you can read about / get the needed downloads...
If you are using the 'SketchUcation Plugin Store' then please read the 'Info...' link, then if it needs a Lib download/install it [or AutoInstall it if it's from within SketchUp itself] - this can be done from the 'Plugin Store' too, before you do the same for the plugin itself...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby thomthom » Wed May 29, 2013 12:15 pm

I haven't gotten around to update the versions here on SCF, but the ones I uploaded on the Extension Warehouse all got a better detection for missing TT_Lib2 (or outdated version).

Once I get the SCF Store plugins updated, and removed the downloads from the threads, it should be clearer to users what is missing. But I have 50+ plugins... it'll take time. :s I haven't gotten around to update them all for EW yet.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby rayisaacs » Wed May 29, 2013 1:39 pm

thanks. it works now.

ray
0

rayisaacs 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby karllarsen » Tue Jul 02, 2013 12:40 am

DOES NOT INSTALL

Your rbz file installs your library folder in the plugin directory but does NOT include or install the rb file in the plugin folder...

I know I know - SU8Pro Win7 64bit
0

karllarsen 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby thomthom » Tue Jul 02, 2013 7:15 am

The files are all there in the RBZ file. SketchUp does the extraction and installation of the files - so I have no control over that.

Could this be a permission problem?
Do you have a user account or admin account? Do you have UAC enabled or disabled?
Have you tried running SU as admin when installing the plugins?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby Carloh » Wed Jul 31, 2013 8:19 pm

hello thom,
first i'd like to thank you for your plugin! somehow i don't get the uv restore to work...i draw a quadface plane, than go into the group, hit "remember uv", model it with the sandbox forming tool, than hit "restore uv" , and nothing happens? is it because i' working in the group or what could be the problem?

thanks in advance! :)
0
User avatar
Carloh 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby thomthom » Wed Jul 31, 2013 8:31 pm

Can you post a sample model? Bonus points if you post a small video clip of what you do.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby HASIAH » Thu Aug 01, 2013 1:39 am

Hello Thom,

Please I have been trying to install UV Toolkit but it is not showing in my google sketchup pro 8. I downloaded the softaware...google sketchup 8>plugins but it still not showing in sketchup when I start.
0

HASIAH 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby TIG » Thu Aug 01, 2013 9:37 am

@Hasiah

Have you also downloaded/installed the TT_Lib2 as instructed on this tool's download page...
Have you definitely installed everything with the exact 'footprint' for files and subfolders, as also explained on that page?
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby thomthom » Thu Aug 01, 2013 5:50 pm

Ditto what the tiger said.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby Carloh » Fri Aug 02, 2013 7:55 am

i will post the model shortly when i have a little freetime during writing my bachelor thesis :)
0
User avatar
Carloh 
 

Re: [Plugin] UV Toolkit (2.2.2) — 06 February 2011

Postby Carloh » Fri Aug 02, 2013 3:22 pm

i gave it another try at my desktop pc with windows 7 and it worked! somehow it has to be something with OS X then....
0
User avatar
Carloh 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: cyril thomas, KW, SalishSea, shongyon and 17 guests

Visit our sponsors: