[Plugin] Shape Bender Beta

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby Dave R » Sat Jun 02, 2012 11:40 pm

You can play the distance thing to your advantage so it the curve is the centerline of the bent shape, you'll put the straight line on the centerline of the unbent form.

I found 13 unused materials also.
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby pbacot » Sun Jun 03, 2012 12:22 am

Thanks. Yeah, I forgot to look at the materials!
0
MacOSX Mojave High Sierra SketchUp Pro v19 Twilight v2 Thea v2 PowerCADD
User avatar
pbacot 
Top SketchUcator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby sags » Mon Jun 11, 2012 7:18 am

thank you for the shape bender sir.. :thumb:
0

sags 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby huntress_ss » Tue Jun 12, 2012 10:53 am

Hey Chris,
I've tried ading this plug-in to my sketch-up but it's not working. Show's up with error load with "Error Loading File clf_shape_bender_loader.rb
no such file to load -- progressbar.rb"

Any suggestions on how to get this working?
0

huntress_ss 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby Gaieus » Tue Jun 12, 2012 11:04 am

Please, read the instructions carefully. Chris clearly wrote that you (also) need to install progresbar.rb.
0
User avatar
Gaieus 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby mwm5053 » Mon Jun 25, 2012 4:33 am

Not sure if this has been covered but getting error when using Shape bender with a slew of plugins in plugin folder when all are removed but
Shape Bender it works fine screen shot on ruby console
Thanks in advance.
0
2011 iMac
SU 2015 Pro, 2017 Make
V2 Twilight
macOS Sierra 10.12.5

mwm5053 
Premium Member
Premium Member
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby TIG » Mon Jun 25, 2012 11:25 am

This is an odd error... it relates to a variable that should be set to a number by one of the tool's methods in line #676, clearly it's failing to do that hence the 'nil' error message when its used for a '/' divide calculation...
@offset = @y_total / 6
This is set around line #641, as either
@y_total = @line_y - @ymin
or
@y_total = @ymax - @ymin
So it seems the get_max_y method is failing somehow.
That is turn is called from the get_geom_ents method; which is in turn called in line #249 when the user has picked the required objects to trigger the 'bending'...

This suggests that if there's no error in the script [used without issue by thousands?] then perhaps another script is making an 'unwrapped' call of its method[s] with similar names and thereby causing the issue - unlike the usual rogue scripts which redefine how Sketchup treats Groups etc, which is far more awkward...
A 'fix' could be to do a find/replace on all of the code in the script [using Notepad osa], so that all of the get_max_y become say get_max_y_CLF and get_geom_ents become get_geom_ents_CLF - then any clash with other scripts might be averted...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby thomthom » Mon Jun 25, 2012 11:49 am

Hasn't that error been described and explained earlier in this thread? Think it comes up pretty often. Might be a bug in the code itself. Might be worth adding it to the first post (when we work out what it was again.)
Wasn't there something about the orientation of the geometry?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby cris_santiago » Mon Jun 25, 2012 10:06 pm

hell yeah :knockout:
!!!
0

cris_santiago 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby VictorB » Sun Jul 01, 2012 9:51 pm

I'm hoping you guys might be able to help me out on this crash I'm getting while using Shape Bender. I'm trying to make a bangle/cuff bracelet for a friend's bday. I've designed the bracelet as a flat bar, and then was going to use shape bender to curve it into a bracelet shape. When I run Shape Bender, it says that it's calculating the curve and angles, and that it's breaking the component into 13 pieces, and then shortly after it starts processing, it just crashes.

I've tried rescaling the component so that it's true to size, and I still get the same crash. I'm at a stand still right now and don't know if it's a problem with SketchUp or Shape Bender. I'm still a total design newb (this is only the 2nd thing I've designed), so there is a great chance there is a flaw with my work.

I've attached the file I'm working with if anyone wants to try to bend it and see if they get the same crash. Any help or words of wisdom are greatly appreciated.

Thanks!
0

VictorB 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby Dave R » Sun Jul 01, 2012 10:01 pm

Where's the curve to which you want the thing bent? It's a lot of geometry to deal with. Perhaps you could split it into smaller chunks and process them one at a time?

It looks like you could do a lot of clean up. Delete coplanar edges and correct the face orientation.
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby TIG » Sun Jul 01, 2012 10:15 pm

Ok...
A few pointers.
It has some very small facets so works at say x100 scaled up, then scale down back to 'real size'.
Small facets can exist but making/manipulating them is problematical.
Presumably the bracelet is for 3d printing ?
It'll probably needs to be a 'solid'...
You have several reversed faces - make all seen-faces off-white and all unseen back-faces the blue - use 'reverse' or 'orient'.
You have several 'nested' parts - e.g. the letters - these need exploding into one set of 'raw' geometry inside the 'container'.
Some of these letters will have coincident edges with the 'studding' below them and probably inner faces when merged - therefore these edges will have more than 2 faces - the requirement for a solid - the form is edges/faces only and all edges in the form have only 2 faces [now more no fewer]. You'll need to do some editing to relocate or remove these so it will be 'solid'...

I assume you want to bend it with the lettering on the outside - it might therefore be easier to set the object on its side and bend it around that way ?

The model is far from a disaster - you can readily fix it up, and bend it as needed, with a little thought and effort... :geek:
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby VictorB » Mon Jul 02, 2012 12:10 am

Thanks for the input guys. I think what I'll do is start from scratch and try to do things the proper way. Again, this was only my 2nd design ever on SU and in 3d at all. I'm going to take everyone's advice here and see if I can make this new version much, much cleaner.

Thanks for the input! I appreciate it.
0

VictorB 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby TIG » Mon Jul 02, 2012 12:24 am

VictorB wrote:Thanks for the input guys. I think what I'll do is start from scratch and try to do things the proper way. Again, this was only my 2nd design ever on SU and in 3d at all. I'm going to take everyone's advice here and see if I can make this new version much, much cleaner.
Thanks for the input! I appreciate it.
As I said it quite salvageable as it is... just relocate slightly and explode the nested bits, reverse some back-faces, use section-cuts to see inside and erase 'partitions' etc, erase coplanar edges [several free tools for that] - Entity Info reports it as a "solid" when it's fixed; scale up x100, then orient the object on its side and shape-bend it... finally scale down.
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby markitekt » Tue Jul 10, 2012 5:33 pm

I haven't read through every post here, but I am unable to get this script to work in version 8. It works fine in version 7 but I'm unable to make it work in 8. It may be due to other plugins since I use quite a few. I was just wondering if anyone else had run into problems with other plugins or if its a version 8 issue.
Mark
0

markitekt 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby Dave R » Tue Jul 10, 2012 5:45 pm

Hi Mark. Long time, no see.

I use it on SU8 without problems. Does anything happen for you when you try to run it? Do you get anything in the Ruby console if you have it open while trying to run it?
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby markitekt » Tue Jul 10, 2012 6:06 pm

Hi Dave,
I've attached the error from the ruby console. I have no clue what it means as I'm not a ruby guy.
I have a feeling it must be related to some other plugin.
Thanks for any help,
Mark
0

markitekt 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby Dave R » Tue Jul 10, 2012 6:15 pm

Thanks for posting that. Can you temporarily rename your Plugins folder and create a new one? Then add only the Shape Bender plugin to it and reopen SketchUp. See if it will run, then.
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby markitekt » Tue Jul 10, 2012 7:36 pm

Thanks Dave,
I went back to a clean install plugins folder with the shape bender and all is working. Now, I just have to figure out which plugin is the culprit.
Mark
0

markitekt 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby Dave R » Tue Jul 10, 2012 7:41 pm

I'm glad that worked but with a large number of plugins, the trick is sorting out which one is the culprit. Copy half of them and put them into the new Plugins folder and see what happens. If it still works, copy half of the remaining ones and put them in. When it quits working again you'll know you got the conflicting plugin. There have been a few plugins mentioned as being problematic. I'll try to find them for you.

Edited to add: I see that Walt had the same error messages you have but I don't see the resolution. Perhaps he'll see this and chime in.
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby rendermaster » Thu Jul 26, 2012 11:23 pm

my test

thanks for the plugins
0

rendermaster 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby nebin asharaf » Sat Jul 28, 2012 11:12 am

hi...........same problem here......selecting...selecting but its not getting selected....tried many times....
gone through your forums.....just like you said i tried right click..yes now the line is getting selected but the function is not working...........................please help i really like this plugin...wanna try something.....help helpppppppppp
0

nebin asharaf 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby TIG » Sat Jul 28, 2012 1:00 pm

You need three things.
A group or component instance that is preselected before you start the tool.
A line parallel to the red/x axis which determines the extent of the bending - this line cannot touch any other geometry and must be in the same active-entities as the preselected group/component.
You are asked to pick it.
A curve determining the bent shape - this cannot touch any other geometry and must be in the same active-entities as the preselected group/component/red-line.
You are asked to pick it.
Do you get prompts or special cursors?
Are the start/end text flags added?
What happens?
If you open the Menu > Window > Ruby Console before starting the tool do you get any error messages?
Answer or fix these and we might get you moving...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby nebin asharaf » Mon Jul 30, 2012 6:22 am

error: #<typeerror: no implicit conversion from nil to integer>
C:/PROGRA~1/Google/GOOGLE~4/Plugins/clf_shape_bender.rb:168:in `set_cursor'
C:/PROGRA~1/Google/GOOGLE~4/Plugins/clf_shape_bender.rb:168:in `onSetCursor'
C:/PROGRA~1/Google/GOOGLE~4/Plugins/clf_shape_bender.rb:233:in `onLButtonUp'
C:/PROGRA~1/Google/GOOGLE~4/Plugins/clf_shape_bender.rb:168


this is what comes in ruby console
0

nebin asharaf 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby TIG » Mon Jul 30, 2012 9:22 am

The tool can't find the cursor file.
This comes in a subfolder, with other files that are vital to the tool's operation.
This suggests very strongly that you have not installed the toolset properly.
Inside your Plugins folder there should be a file called
clf_shape_bender_loader.rb
and a subfolder called
clf_shape_bender
In that subfolder are several vital 'support files'.
Capture.PNG
The cursor PNG images are clearly shown.
Reinstall ensuring this is indeed the case.
If you have accidentally put files into Plugins that belong only in the subfolder you must remove them, because otherwise they will break things.
If you are on Vista/Win7 the system can prevent you from adding files/subfolders unless you have FULL security permissions - the Sketchup folder's subfolders - like Plugins - must have FULL permissions set to avoid issues. It might look like you installed it OK but if there's a 'Compatibility Files' button [or similar wording] on the Plugins-folder explorer-window top-bars it suggests you haven't - that's the only clue Windows gives you!
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby nebin asharaf » Tue Jul 31, 2012 9:42 am

thank u thank u......................but now a new problem ..............
1)i made the object group
2)selected the bender option
3)selected line
4)selected curve..........
5)that's it......nothing is coming here.....
a green skelton suppose to come right???
nothing is coming...........................
0

nebin asharaf 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby Dave R » Tue Jul 31, 2012 10:11 am

How about at least a screen shot showing the setup? :roll:

Is the shape oriented along the red axis? Is the straight line parallel to the red axis?
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby nebin asharaf » Wed Aug 01, 2012 4:27 am

yes it is......parallel to red
0

nebin asharaf 
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby Dave R » Wed Aug 01, 2012 10:16 am

nebin asharaf wrote:yes it is......parallel to red


:roll:

If you want assistance with sorting this, you have to meet us half way. Post the SKP file so we can see what you're doing wrong.
0
Etaoin Shrdlu


%

(THERE'S NO PLACE LIKE)

G28 X0.0 Y0.0 Z0.0

M30

%
User avatar
Dave R 
Global Moderator
 

Re: [Plugin] Shape Bender Beta v0.55 UPDATED April 21, 2010

Postby TIG » Wed Aug 01, 2012 10:20 am

Try with the Ruby Console open in case there are any error messages appearing in there...
0
TIG
User avatar
TIG 
Global Moderator
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: luongtungart and 19 guests

Visit our sponsors: