[Plugin] V-Ray Tools

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby retep37 » Sun Feb 13, 2011 4:59 pm

thomthom,

I have been testing V-Ray Toys 1.2.0 with V-Ray 1.48.89 and Sketchup 8.0.4811 (the latest.) V-Ray and Sketchup are working; however we are seeing some delays with V-Ray loading that seem to be worse with more complex SKP files. Earlier in the thread, “sadyo” mentioned seeing delays of 15 - 20 minutes and while I am not seeing anything that severe, perhaps their experience is related to mine. I am not sure how much the delays are specifically related to V-Ray Toys, but either way I think you may be able to help (or at least explain what is occurring.)

With just a blank SKP loaded from the template it takes V-Ray about 6 - 10 seconds to finish loading. (I should say that the V-Ray toolbar appears immediately, but that Sketchup cannot be used until after the 6 - 10 second time period. These seems normal to me.)

With complex SKP files I have seen V-Ray take anywhere from 30 seconds to 2 minutes to load. I am thinking that perhaps this is unrelated to V-Ray Toys and simply that V-Ray needs to analyze materials or other apsects of the SKP file before being "ready" for use. (I am not sure that this experience is normal. One of my co-workers mentioned it took V-Ray 3 - 4 minutes to load for a SKP file, but I have not been able to duplicate a time such as that.)

Any thoughts on what is "normal" in this regard?
0

retep37 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby thomthom » Mon Feb 14, 2011 10:16 am

VfSU is slow to load. I disable the extension from Window > Preferences > Extensions - that way it doesn't load when SU loads. I then use V-Ray Toys to load it on demand.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby retep37 » Mon Feb 14, 2011 7:17 pm

Agreed, it is slow to load and loading on demand is useful. Do you find that the time it takes V-Ray to load (either by demand or not) can vary based on the complexity of the SKP file being opened? Just wondering if seeing one minute or longer on some files for V-Ray to load is normal. (Also, I do not remember as much as a delay on earlier versions...)
0

retep37 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby thomthom » Mon Feb 14, 2011 7:19 pm

Yes, bigger/more complex files load slower. And I get the feeling that if you open a model from an older VfSU version it adds even more load time. (Though this is a one time thing because it'd updating the project.)
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby milkshark » Wed Mar 09, 2011 7:11 am

Awesome Plugin!! :berserk:
0

milkshark 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby focpt » Fri Mar 11, 2011 3:23 pm

ThomThom,

First of all, thank you for all your hard work on plugins. Really great stuff.

I'm having trouble with V-Ray Toys. I have SU8, with the latest VfSU 1.48xxx. I did the following:

1. Unchecked Vray from preferences.
2. Closed SU
3. Copied Vray toys into plugin folder.
4. Opened SU
5. Used Vray drop down to start VRay.

However there is no Vray Toys tool bar anywhere. Also, when I close SU I get a bugsplat. Any ideas?

I'm really just interested in the camer sync option right now. Is there a way to use that ruby only? Or some way to manually sync the cameras.

Cheers,
Nathan
0
- Nathan
http://www.focalpointstudio.net

SU8, VRay 1.49
User avatar
focpt 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby thomthom » Fri Mar 11, 2011 4:16 pm

focpt wrote:However there is no Vray Toys tool bar anywhere.

The V-Ray Toys toolbar should be available before loading V-Ray. From the View > Toolbar menu.
Did you mean the V-Ray for SketchUp toolbar? (if so - do you get errors when you try to start V-Ray?)

focpt wrote:Also, when I close SU I get a bugsplat. Any ideas?

Never experienced this. You don't get this without V-Ray Toys?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby focpt » Fri Mar 11, 2011 5:10 pm

thomthom wrote:
focpt wrote:However there is no Vray Toys tool bar anywhere.

The V-Ray Toys toolbar should be available before loading V-Ray. From the View > Toolbar menu.


Did you mean the V-Ray for SketchUp toolbar? (if so - do you get errors when you try to start V-Ray?)

focpt wrote:Also, when I close SU I get a bugsplat. Any ideas?

Never experienced this. You don't get this without V-Ray Toys?


Ahhh, don't know why I didn't check the view>toolbar menu... it was late. I'll try again tonight.


No I don't. Do I need to change permissions on my programs>google>su folder? When I copy paste plugins it asks for permissions (windows vista).

Thanks
0
Last edited by focpt on Fri Mar 11, 2011 5:15 pm, edited 1 time in total.
- Nathan
http://www.focalpointstudio.net

SU8, VRay 1.49
User avatar
focpt 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby thomthom » Fri Mar 11, 2011 5:13 pm

There has been some issues reported when users don't have admin rights. Or full access rights to SU's folder. Could very well be it.
Do you see a Compatibility Files button when you browse the Plugins folder?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

automatic start of any other plugins

Postby bagatelo » Tue Mar 22, 2011 12:21 pm

I was wondering if it would be possible to change this plugin to control the automatic start of any other plugins such as the 1001 bit tools, or some other little tools that we don't use often. That would make the start Sketchup faster. So by default, would start with the Sketchup few essential plugins.
0
User avatar
bagatelo 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby halroach » Wed Apr 06, 2011 3:39 pm

If I wanted to remove V-Ray Toys...
how do I get about doing that in a way that vray will load automatically? After removing the vray toys files, vray still won't load on sketchup startup. I remember you once wrote that vray toys changes one of the file names in order to prevent vray from loading... which file was it?
0
User avatar
halroach 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby thomthom » Thu Apr 07, 2011 8:18 am

Halroach wrote:If I wanted to remove V-Ray Toys...
how do I get about doing that in a way that vray will load automatically? After removing the vray toys files, vray still won't load on sketchup startup. I remember you once wrote that vray toys changes one of the file names in order to prevent vray from loading... which file was it?

What version of V-Ray do you use? (Exact version number please)
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby halroach » Thu Apr 07, 2011 7:58 pm

thomthom wrote:What version of V-Ray do you use? (Exact version number please)

I believe it is 1.49.01
0
User avatar
halroach 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby thomthom » Thu Apr 07, 2011 8:05 pm

This plugin doesn't rename any files for that version. You re-enable V-Ray from the Window > Preferences > Extension list.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby salah » Sat Apr 23, 2011 6:31 pm

Hi Guys,

I have tried the Camera Sync. Toy on Vray for SKP 6 & 8 and didn't work? Could you please let me know how to install it? I took the 2 .rb files and copied them in the plugins file in SKP! Am i doing some thing wrong? Please let me know.
Txs
0

salah 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby thomthom » Sat Apr 23, 2011 7:46 pm

Two rb files?
Are you preserving the folder stucture in the zip file. sounds like you're not...v :?:
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby vipman1102 » Thu Jun 02, 2011 9:36 am

nice Thom, thanks alot :fro:
0

vipman1102 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby sadyo » Mon Jul 18, 2011 3:50 am

Would it possible that someday this Plugin (Camera Sync-Vray Toys) can work to other Render Software like podium? ;)
0
User avatar
sadyo 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby thomthom » Fri Jul 22, 2011 11:50 am

hmm.. I'm not a Podium user. Don't know how it operates...
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby sadyo » Sat Jul 23, 2011 6:09 am

Oo, I see,

Just wondering that we can use this nice plugin for any other Rendering Software, because many rendering software have the same problem with rendering output view, like VRay
0
User avatar
sadyo 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby simrose » Mon Oct 24, 2011 1:47 pm

Dear ThomTHom .. this is such an awesome plugin.. was suggested by Gaieus ... it save s so much more than 3 - 5 seconds.. now ma files open way faster!! God Bless both of u!!! :)
0
Regards,

Simrose

simrose 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby pickprooflemon1 » Wed Nov 30, 2011 9:00 am

sadyo wrote:
thomthom wrote:
sadyo wrote:1. i've put "VRayToys folder" and VRayToys.rb in SU8 plugin folder "\Program Files\Google\Google SketchUp 8\Plugins"
2. i open the SU8, turn off the VRay toolbar and i quit SU8
3. i open the SU8 again (this way is working when i'm still SU7) and then nothing happen...

Did you just close the toolbar, or did you disable VfSU from Window > Preferences > Extensions ?
You need to do the latter.


yes, I've done both ways...
Finally, I tried to remove the VRayToys first, then put it back...
Weird, VRayToys can work again like it should :D
But, when i try to Load VRay, it takes 15-20 minute to Appear :cry:
Is there something i done wrong? please help...



I'm having the same problem...TT does tat means its not working for SU 8???? NOooooooooo......PLS HELP ME.
0

pickprooflemon1 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby pickprooflemon1 » Wed Nov 30, 2011 9:33 am

Mr thomtom,

Pls help me on my situation

This is basically what i did:

1.uncheck vray in the preference
2. put the vray toys rb n the folder into the PLUGIN folder
3. open SU 8 again, and load vray on demand. ( it loads in 40-60s)
4. vray tools appear and and i open vray render option.
-----------------------------------------------------------

i input the image aspect ratio into vray tools and click on 'set spect ratio'.
AND NOTHINGS HAPPENS, i mean no factors r generated for me to input.

"Set the V-Ray Physical Camera's Zoom property to: x.xxx'

The value remain x.xxx. It wont works no matter how many times i click on it.
----------------------------------------------------------------------------

Is this not functioning on su8? if not, is there any other way to sync the cameras.
I'm using hdir and turned off physical camera and when i render it zoom out like crazy. which is why i resort to Vray toys.
0

pickprooflemon1 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby pyroluna » Fri Aug 10, 2012 11:46 am

hmm... I'm trying this plugin for the first time... it sort of works, but when using 'Start V-ray', the toolbar doesn't show up. The editors, such as material editor etc, work fine when approached via the plugin/Vray menu, it's only the toolbar that doesn't show up.

It's been a while since this thread was active... is the plugin still up to date? I use the latest versions of SU and V-ray, which did not yet exist at time of creation of this plugin...

The auto do not load but only when I start it - is the only reason for me to use this plugin, since the other stuff can be achieved with Advanced Camera tools - correct me if I'm wrong...
0
User avatar
pyroluna 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby thomthom » Fri Aug 10, 2012 11:51 am

Pyroluna wrote:hmm... I'm trying this plugin for the first time... it sort of works, but when using 'Start V-ray', the toolbar doesn't show up. The editors, such as material editor etc, work fine when approached via the plugin/Vray menu, it's only the toolbar that doesn't show up.

That's odd - don't know why the toolbar doesn't show... :?

Pyroluna wrote:It's been a while since this thread was active... is the plugin still up to date?

I have version 2 on my computer. Along with this plugin I also have a few other updates due for release after I release Vertex Tools 1.1 in a couple of weeks.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby CharlieBarr » Mon Sep 24, 2012 8:33 am

Hi!

Don´t know if this thread is alive anymore but... I´m having troubles using the plugin together with the "photo match" tools in SU. When I add the values suggested by the "Camera sync" plugin the render stills turn out weird (V-ray just render a small part of the actual view).

I´ve tried searching for a thread on this problem but with no luck.

Thanks alot for sharing your excellent plugins with us!

/Charlie
0

CharlieBarr 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby pilger » Thu Jan 03, 2013 2:08 am

I believe SU version 8.0.16846 broke this plugin. I type in the aspect ratio on the box and I can see the grey frame on my viewport but the V-Ray zoom indicator doesn't change at all.
0
User avatar
pilger 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby thomthom » Thu Jan 03, 2013 2:00 pm

What was your previous version? Nothing in SketchUp 8.0.16846 should have affected the API it uses.

Any errors in the Ruby Console?

Also, what OS do you use? (Please add your info in your profile.)


Btw, I have version 2.0 ready to be release very shortly.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby pilger » Thu Jan 03, 2013 6:40 pm

Nothing comes up on the Ruby console. No errors or other messages.

I'm on Windows 7 x64 Ultimate edition.

Despite of the not changing field, the aspect of the viewport seems to be changed. I can get the ratio correctly on the "Output" tab of V-Ray. I tried rendering with just the aspect ratio of the Output matching the SU's (left the Zoom field of V-Ray unaltered: 1.00 ) and it kinda worked as expected.

Maybe we don't need to mess with the zoom anymore? Can you confirm that, Thom?
0
User avatar
pilger 
 

Re: [Plugin] V-Ray Toys (1.2.0) — 16 February 2010

Postby thomthom » Thu Jan 03, 2013 9:54 pm

pilger wrote:Maybe we don't need to mess with the zoom anymore? Can you confirm that, Thom?

Yes, with the newer VfS it's no longer needed to set the zoom. It'll all be clearer when I release version 2.0.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: adifalla, galiadavidov and 7 guests

Visit our sponsors: