[Plugin] Selection Toys

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby Bob James » Fri Jul 10, 2009 5:10 am

:oops:
0
i7-4930K 3.4Ghz, 2x GTX780 6GB, 32GB DDR3-1600 ECC, OCZ Vertex 4 500GB, WD Black 3TB, 32TB NAS, 4x 27" Monitors, SpaceMouse Pro, X-keys XK-60
User avatar
Bob James 
Premium Member
Premium Member
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby japanNuke » Sat Jul 11, 2009 4:19 pm

thanks thomthom!
love this plugin, one of the best for me so far :fro:
0
be cool
be bad

japanNuke 
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby CadFather » Thu Jul 23, 2009 11:27 am

Hi Thom - just to let you know, the greyed-out menus are still there on my machine.

this only appears after some time working in SU, but i have not been able to pin the pattern so far..
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby thomthom » Thu Jul 23, 2009 11:32 am

CadFather wrote:Hi Thom - just to let you know, the greyed-out menus are still there on my machine.

this only appears after some time working in SU, but i have not been able to pin the pattern so far..

I saw some weeks ago at the office, a model someone was working on caused some strange behaviour. When you kept right clicking on a selection you'd start finding menus greyed out. When you clicked outside the geometry, on empty model space, the menu's would work again.
This seemed to only happen on a particular model, and it happened on SU6 and 7 - even on a plain installation without any plugins.
Is this similar to what you see?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby CadFather » Thu Jul 23, 2009 12:27 pm

no, happens all the time, many items go grey (including native SU menus) regardless of the model.
if i restart SU it works again for a while.. time limited demo mode : )

..of course it may be clashing with other plugins, i will run a couple of empty folder test later today
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby thomthom » Thu Jul 23, 2009 12:35 pm

But removing Selection Toys instantly fixes this?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby CadFather » Fri Jul 24, 2009 2:50 am

yes Thom, all works well without....

..can't seem to detect the pesky pattern! :x i have a hunch it's something to do with groups, perhaps doing operation inside/outside etc..
keeping my eyes open anyway as your plugin is a must.. will let you know
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby thomthom » Fri Jul 24, 2009 9:38 am

Has it always been like this for you? Or is it a particular version where this started?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby CadFather » Fri Jul 24, 2009 10:36 am

not sure, i think i have noticed since the last 2 versions - but i could be wrong.. (erratic work)

don't you notice it on your machine?
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby thomthom » Fri Jul 24, 2009 11:02 am

No. I use it all the time when I work - also got co-workers that use it. Never had such problems. Which is why I'm at a loss to what it can be. If I can't reproduce it I have no idea what it could be.

Maybe it's a plugin combo?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby CadFather » Fri Jul 24, 2009 11:30 am

um.. it must be a clash then.. with all the gems in the folders we're in need of the 'new-spot-the-clash-finder-ruby-please'
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby thomthom » Fri Jul 24, 2009 11:48 am

Is there any messages in the Ruby console?

I find it very off that menu's should become disabled. Makes no sense.
Do you have SU7 installed?
Would it be possible for you to install a fresh SU6 install and add only Selection Toys and see if you still see the same thing then? That's be one way to testing for clashes without having to remove all your plugins from your work-SU version.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby CadFather » Fri Jul 24, 2009 12:49 pm

Thom, swapping the plugins folder is not a problem.. i can move them around, copy etc.. (SU 7)

the cheesed thing is the (so far) unpredictable occurrence - it doesn't happen straight away.. but 'gently' after a while..

as you know it could be anything. but it's good to know it works on your side - only need some time to look into it
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby simon le bon » Tue Jul 28, 2009 12:58 pm

Hi thomthom,
I have started with v1.5.1 and we are now with v1.12.0 !! even and even complete and useful.
Many thanks..
Simon.
0
User avatar
simon le bon 
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby thomthom » Wed Jul 29, 2009 1:54 am

CadFather: do your model often have a high number of layers?
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby CadFather » Wed Jul 29, 2009 2:13 am

not that many - say 6 to 8 for a fairly complex model - i use groups/comps more

(i'm still looking...no luck so far)
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby thomthom » Wed Jul 29, 2009 2:23 am

You running many other applications?
I'm wondering if this post has any clues to the menu issues: viewtopic.php?f=180&t=20791#p175253
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby Bob James » Wed Jul 29, 2009 8:12 am

CadFather wrote:with all the gems in the folders we're in need of the 'new-spot-the-clash-finder-ruby-please'


Amen, I'll definitely second that suggestion!!
0
i7-4930K 3.4Ghz, 2x GTX780 6GB, 32GB DDR3-1600 ECC, OCZ Vertex 4 500GB, WD Black 3TB, 32TB NAS, 4x 27" Monitors, SpaceMouse Pro, X-keys XK-60
User avatar
Bob James 
Premium Member
Premium Member
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby CadFather » Wed Jul 29, 2009 10:43 am

i see, interesting.. though i never experienced Rick's behaviour (i don't usually have many apps running in the background)
certainly i never saw an item re-appear.. would be nice to have a confirmation from google about ruby limits..

seems to mean that if selection toys (for example) had less items the problem might temporarily disappear..

i think the 'new-spot-the-clash-finder-ruby-please', if at all possible, would have to come from google.
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby thomthom » Wed Jul 29, 2009 10:54 am

CadFather wrote:seems to mean that if selection toys (for example) had less items the problem might temporarily disappear..

I'll make a deubg version for you, though, it'll have to be next week. I'm going away for a small trip.


CadFather wrote:i think the 'new-spot-the-clash-finder-ruby-please', if at all possible, would have to come from google.

it's rather an impossible task. first you have to know what the "clash" is. Meaning you have to know exactly how everything is expected to work. can't see you can program that...
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby CadFather » Wed Jul 29, 2009 11:09 am

no hurry, enjoy your trip Thom..
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby su30 » Wed Jul 29, 2009 12:48 pm

I have the same problem as CADfather had...
I only use SU6, checked every plugins and found the problem in this script (Version1.12.0), It didn't happen before in lower versions.
just after some open&close group action, the bug occurs, right-click menu Grey-out...
so if you have any thing need me feedback, don't hesitate to tell me!
0
su30

su30 
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby thomthom » Wed Jul 29, 2009 1:15 pm

Here's a debug version with the layer filters removed. Can the people that has experienced problems with the menu's try this and see if that solves the matter.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby CadFather » Wed Jul 29, 2009 2:09 pm

Right on! :)

EDIT: seems to be working now.. i need to spend more time with it but the early signs are good.. Thanks Thom! (now you can go..) ;) :thumb:
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby su30 » Fri Jul 31, 2009 10:59 am

I will try this version, if I have a problem I will feedback!
0
su30

su30 
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby CadFather » Fri Jul 31, 2009 5:17 pm

Hi Thom, wherever you are i confirm that it's working now - played for about an hour with a complex model and had no problems!!

Thanks :D
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.12.0) — 9 July 2009

Postby thomthom » Sun Aug 02, 2009 8:22 pm

Ok. It must be the number of dynamically created menus per layer that causes some kind of issue. I'll disable that feature and try to report it as a SU issue/bug.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.13.0) — 3 August 2009

Postby thomthom » Mon Aug 03, 2009 10:20 am

Updated the plugin - an update that actually removes the layer filter features added in previous versions.
Seems that there might be issues with SU and too many menu items. The layer filters added two menu items per layer - something which quickly adds up. Not sure if it's an SU issue or Windows limitation, but removing this feature seem to clear up the reported issues.

Sorry for the inconvenience.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.13.0) — 3 August 2009

Postby CadFather » Mon Aug 03, 2009 10:27 am

Thank you Thom - this is one fine plugin..
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] Selection Toys (1.13.0) — 3 August 2009

Postby thomthom » Mon Aug 03, 2009 10:37 am

Cheers.
I hope that I get the time at some point to rewrite it so the selections can also work as tools where you add/remove to the current selection. Letting you combine selection filters better. Though I'm not sure yet what the interface would be. I'm quite tempted to draw my own toolbar/menu/icons on the screen - inspired by Fredo's tools.
But at the same time I want to keep the plugin's current ability that you assign hot-keys to various filters. ...maybe some kind of macro system... Not really sure. It's a thinker.
0
Thomas Thomassen — SketchUp Monkey & Coding addict
List of my plugins and link to the CookieWare fund
User avatar
thomthom 
PluginStore Author
PluginStore Author
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

PreviousNext


 

Return to Plugins

Who is online

Users browsing this forum: asmauzir and 14 guests

Visit our sponsors: