[Plugin] SCF PowerToolbar (09.Sep.2010)

Re: [Plugin] SCF PowerToolbar v1

Postby CadFather » Mon Jan 05, 2009 12:55 pm

you can now find the video tutorials here as well http://www.youtube.com/user/VideoSketchup
1
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] SCF PowerToolbar v1

Postby me3mar » Mon Jan 05, 2009 2:13 pm

First of all many thanks for the power toolbar.
i'm having some troubles with half of the funktions of the toolbar, eventhoght there's no problem reports or warnings,
i just klick the button, nothing happens! by (devide and portrude) i fill the options, then klick devide, or portrude... nothing happens.
the same is happening by the following comands : Portrude, FFD (all 4), and Bevel.
any suggestions?
thanks again in advance
me3mar
0

me3mar 
 

Re: [Plugin] SCF PowerToolbar v1

Postby CadFather » Mon Jan 05, 2009 3:22 pm

..i need more info - are you using a mac?
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] SCF PowerToolbar v1

Postby me3mar » Mon Jan 05, 2009 4:40 pm

i am using pc windows xp pro - Sp 3 -
ram 4 g.
quad core 2,4 GH.

sketchup 7

thank you again
me3mar
0

me3mar 
 

Re: [Plugin] SCF PowerToolbar v1

Postby CadFather » Mon Jan 05, 2009 4:53 pm

if the system is good it should work - if you have multiple copies of the same plugins as the ones included in the powertoolbar (protrude etc) you can get into problems

start from this, making sure these are the only contents in the plugins folder (back up the old one)
if it works reintroduce the others by elimination

http://www.sketchucation.com/forums/scf/viewtopic.php?f=180&t=14770&st=0&sk=t&sd=a&start=15#p112166
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] SCF PowerToolbar v1

Postby me3mar » Mon Jan 05, 2009 10:13 pm

i had to move all the rubys manualy and cleanup a little, and it works fantastic!!
thanks CadFather for your help
me3mar
0

me3mar 
 

Re: [Plugin] SCF PowerToolbar v1

Postby Fletch » Tue Jan 06, 2009 8:55 pm

Great work on those tus Cadfather! :thumb:
I realized I'm working with the 'old' protrude... didn't realize it had such great improvements - gotta go get it now 8-)
0

Fletch 
Twilight Render
 

Re: [Plugin] SCF PowerToolbar v1

Postby numerobis » Tue Jan 06, 2009 10:57 pm

WOW!!! very cool! thank you! :D
0

numerobis 
 

Re: [Plugin] SCF PowerToolbar v1

Postby Edson » Wed Jan 07, 2009 8:18 pm

max,

in order to install this toolbar i removed all my plugins and started moving them back carefully in order no to have double copies. in doing so i realized that another toolbar you made (ARCHILAND toolbar) has a folder called CD_ICONS, the same name of the icons folder for the powertoolbar. my question: is it ok to have both folders with the same name? will not there be some confusion between them? what should i do?
0
edson mahfuz, architect | porto alegre • brasil
http://www.mahfuz.arq.br
User avatar
Edson 
Global Moderator
 

Re: [Plugin] SCF PowerToolbar v1

Postby Edson » Wed Jan 07, 2009 9:04 pm

after all i did not manage to install it. the same error message as BTM reported appears to me.

oddly enough, why does the ARCHLAND toolbar installs without any problems and the POWERTOOLBAR does not?

individually, all the scrips run on my mac.
0
edson mahfuz, architect | porto alegre • brasil
http://www.mahfuz.arq.br
User avatar
Edson 
Global Moderator
 

Re: [Plugin] SCF PowerToolbar v1

Postby bellwells » Thu Jan 08, 2009 4:49 am

Edson wrote:max,

in order to install this toolbar i removed all my plugins and started moving them back carefully in order no to have double copies. in doing so i realized that another toolbar you made (ARCHILAND toolbar) has a folder called CD_ICONS, the same name of the icons folder for the powertoolbar. my question: is it ok to have both folders with the same name? will not there be some confusion between them? what should i do?

Edson, there will be a problem with 2 folders the same name as you'll be asked if you want to replace the old with the new, which you do NOT want to do! What I did was simply place the contents of the PowerToolbar CD_ICONS into the other CD_ICONS folder (or vice versa) by copy all and paste.

Max, thanks for another great addition to SU!!!!
0
Ron

bellwells 
Premium Member
Premium Member
 

Re: [Plugin] SCF PowerToolbar v1

Postby CadFather » Thu Jan 08, 2009 8:44 am

hi Edson, the two plugins have different subfolders inside CD_ICONS (architect and power). you should have 1 cd_icons folder and inside it, the 2 subfolders.

i think the parsing errors reported can be easily fixed but i do not have a mac to check/fix - some kind master with a mac could look into it perhaps?

the quick other option is to disable the plugins which cause the error - if you can report the full text of the ruby console i will try later..
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] SCF PowerToolbar v1

Postby chango70 » Thu Jan 15, 2009 4:37 am

OMG, Cadfather, why can't Google hire you!? I am always amazed by how professionally thought out your tools (interface at least) are! Thank you. :ecstatic:
0

chango70 
 

Re: [Plugin] SCF PowerToolbar v1

Postby CadFather » Thu Jan 15, 2009 9:24 am

thanks Chango, though without the masters we would only have a 'nice' interface... ;)

(..there's more cooking in the oven..) ;)
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] SCF PowerToolbar v1

Postby xrok1 » Mon Jan 26, 2009 6:24 am

i think it would be great (not that its not great already, but greater yet) if we could have just one SCF Toolbar & then pick and choose which ruby's we want in it, like a visual plugin bar that could be customized with any of the tools from your series of toolbars (mix and match).

any chance of this? ;)
0
“There are three classes of people: those who see. Those who see when they are shown. Those who do not see.”

http://www.Twilightrender.com try it!

xrok1 
 

Re: [Plugin] SCF PowerToolbar v1

Postby pilou » Mon Feb 02, 2009 7:12 pm

Amazing and cool design! :fro:
A list here of Plugs used will be useful ;)
0
Frenchy Pilou
Is beautiful that please without concept!
Speedy Galerie
User avatar
pilou 
Top SketchUcator
 

Re: [Plugin] SCF PowerToolbar v1

Postby driven » Sat May 09, 2009 1:19 am

has any one got this fully running on a mac??

i get this error, functionality of some of the tools

john
0
Last edited by driven on Sat May 09, 2009 6:40 am, edited 2 times in total.
learn from the mistakes of others, you may not live long enough to make them all yourself...

driven 
PluginStore Author
PluginStore Author
 

Re: [Plugin] SCF PowerToolbar v1

Postby Chris Fullmer » Sat May 09, 2009 1:22 am

Tiffs don't work on the forum John. Use a file format more common to the web like jpg, or png works great.

Chris
0
Lately you've been tan, suspicious for the winter.
All my Plugins I've written
User avatar
Chris Fullmer 
SketchUp Team
SketchUp Team
 

Re: [Plugin] SCF PowerToolbar v1

Postby •BTM » Sat May 09, 2009 1:39 am

tiff works on the forum
...but maybe only on macs... ;)
Anyways, I had the same problem too. I no longer have the SCF powertoolbar.
0

•BTM 
PluginStore Author
PluginStore Author
 

Re: [Plugin] SCF PowerToolbar v1

Postby Chris Fullmer » Sat May 09, 2009 1:44 am

That is very interesting. I never knew that. They do not show up on PC's. Good to know,

Chris

I've never liked the tiff format and I don't know why.
0
Lately you've been tan, suspicious for the winter.
All my Plugins I've written
User avatar
Chris Fullmer 
SketchUp Team
SketchUp Team
 

Re: [Plugin] SCF PowerToolbar v1

Postby •BTM » Sat May 09, 2009 2:48 am

I don't like it much either. Same, I don't know why. I like PNG the most :thumb:
0

•BTM 
PluginStore Author
PluginStore Author
 

Re: [Plugin] SCF PowerToolbar v1

Postby modelhead » Sat May 09, 2009 3:45 am

I sat and looked at the bar a few months ago and thought it looked like a toybox. I have been playing with it like a big kid ever since then. I can't count the hours I have had good fun and adventure with it. There seem to be just endless things to explore with the power toolbar and many other tools that just keep coming from our homegrown ruby community.. Thanks for a great time!! :D
:enlight:
0

modelhead 
 

Re: [Plugin] SCF PowerToolbar v1

Postby Sir » Sat May 09, 2009 12:41 pm

the link to your website is broken btw
0

Sir 
 

Re: [Plugin] SCF PowerToolbar v1

Postby windrockwater » Sat Jul 04, 2009 12:44 am

The link for downloading this cool script is not working. Is there a working link available? TIA...
0

windrockwater 
 

Re: [Plugin] SCF PowerToolbar v1

Postby CadFather » Sat Jul 04, 2009 4:39 am

Hi, link repaired.. thanks
0
User avatar
CadFather 
PluginStore Author
PluginStore Author
 

Re: [Plugin] SCF PowerToolbar v1

Postby haroldcampbell » Wed Feb 24, 2010 6:44 pm

driven wrote:has any one got this fully running on a mac??

i get this error, functionality of some of the tools

john


Don't know if this is still an issue for anyone, but you can find a patched version that works for me.
I changed line 4921
Code: Select all
if (n1.between? (n2 - interval), (n2 + interval))
to
Code: Select all
if ( n1.between?((n2 - interval), (n2 + interval)) )
.

I'm running mac os x 6, SketchUp 7 (7.1.6859)
0

haroldcampbell 
 

Re: Errors in [Plugin] SCF PowerToolbar v1

Postby Dan Rathbun » Tue Aug 31, 2010 5:04 am

Errors in [Plugin] SCF PowerToolbar v1
The errors are caused by poor programming style.

If you run SU7 Mac (with Ruby 1.8.5-p0) OR run SU7 on PC AND have updated your Ruby interpreter DLL to Ruby 1.8.5 or higher, then certain "typos" are no longer permitted by the Ruby interpreter.
cd_power_extension_m.rb

Line 4921:

if (n1.between? (n2 - interval), (n2 + interval))

* move first "(" just after "between?" and before "(n2", so it replaces the space character. Like:
if n1.between?((n2 - interval), (n2 + interval))

cd_power_m.rb

* same fix as above, .. replace Line 4921

if (n1.between? (n2 - interval), (n2 + interval))
with:
if n1.between?((n2 - interval), (n2 + interval))

cutting_windows.rb

fix Line 610:

faces_and_heights[0].pushpull (faces_and_heights[1]), false
* add parenthesis around pushpull method's argument list, ie:
faces_and_heights[0].pushpull( (faces_and_heights[1]), false )

What is happening, is that:
  • Ruby is getting confused as to what are method argument lists, and what are arguments (delimeted with parenthesis,) within the arguemnt list.
  • For best practice in later Ruby versions, all methods should have parenthesis around the whole argument list, with NO space between end of method name and the left parenthesis of it's argument list.
  • If a method has no args, speed up Ruby by passing an empty arg list, like so:
    obj.method_name()
0
    I'm not here much anymore. But a PM will fire email notifications.
    User avatar
    Dan Rathbun 
    PluginStore Author
    PluginStore Author
     

    Re: [Plugin] SCF PowerToolbar v1

    Postby Nosonja » Mon Sep 06, 2010 8:50 pm

    Don't work with sketchup 8.
    0

    Nosonja 
     

    Re: [Plugin] SCF PowerToolbar v1

    Postby CadFather » Mon Sep 06, 2010 10:32 pm

    i'm hoping to fix the bugs soon..
    0
    User avatar
    CadFather 
    PluginStore Author
    PluginStore Author
     

    Re: [Plugin] SCF PowerToolbar v1

    Postby tina0603 » Thu Sep 09, 2010 11:47 am

    try to replace it with haroldcampbell attachments
    0

    tina0603 
     

    SketchUcation One-Liner Adverts

    by Ad Machine » 5 minutes ago



    Ad Machine 
    Robot
     

    PreviousNext


     

    Return to Plugins

    Who is online

    Users browsing this forum: JmSH, KINOMBOY, ngohung and 13 guests

    Visit our sponsors: