[Plugin] Align tool 3D (bug fix)

Re: [Plugin] Align tool 3D (bug fix)

Postby bonzi_ses » Mon May 14, 2012 11:03 am

Thank you very mauch
0

bonzi_ses 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby ZyberCool » Sun Sep 30, 2012 6:31 am

thanks bro..
0

ZyberCool 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby redgray » Wed Dec 12, 2012 7:23 am

i like align tool just like in autocad command, thanks a lot for this tool.
0

redgray 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby desunvn » Wed May 08, 2013 3:37 am

Didier Bur wrote:Hi,
Here is an updated version of my align tool with a bug fix (components were deformed when non orthogonal axis were clicked). User guide also added.
Regards,

thank for sharing
0

desunvn 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby rv1974 » Tue May 21, 2013 12:43 pm

Didier, could you please add 'multiple copy' and 'preserve original instance' options (may be with say CNTRL key pressed once)?
P.S. I hope I post in the right topic: is it Tools\Align command?
(Align, align tool, align 2D, align 3D.. I'm confused a bit).
0

rv1974 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby irwanwr » Thu Oct 10, 2013 11:24 pm

Anyone experienced groups/components axes that cannot be hidden or erased?
I've this plugin for quite long. But lately just realise that axes cannot be hidden or removed from the groups/components on the screen.
How should i clear those axes after aligning groups/components?
Thank you.
0
User avatar
irwanwr 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby cotty » Fri Oct 11, 2013 6:24 am

You can change the visibility of the component axes here:
0
User avatar
cotty 
Top SketchUcator
 

Re: [Plugin] Align tool 3D (bug fix)

Postby irwanwr » Fri Oct 11, 2013 6:56 pm

I forgot to check that :oops:
Checked Window - Preference only several times.
Seems that I forgot how to read and use SketchUp.

Thanks a lot, Cotty.
0
User avatar
irwanwr 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby JPC2j3 » Wed Jan 22, 2014 12:52 am

I recently down loaded and installed the plug-in in the zip file. I have been experimenting with the plug-in to learn how it works. When I try to use the tool, my SketchUp crashes every time. Let me explain as best as I can what happens.
I create two objects (usually two cubes or rectangles; I’m just experimenting). I pick a corner of one object and create an X and Y axis (should there be a Z axis showing at this point?). When I try to connect the origin point of the first object to the corner of the second object, I get a crash.
I have viewed the training video numerous times so I believe I am using the plug-in correctly. I’m seeking some help in understanding what I am doing wrong.
Thanks
0

JPC2j3 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby robertWan » Thu Feb 06, 2014 6:52 pm

Could you add an option to copy (Ctrl) for plugin ALIGN 3D? Now objects are moved.

Robert
0
User avatar
robertWan 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby kupono » Sun Mar 23, 2014 1:42 am

Align tool 3D doesn't want to work with SU 2014. Is this a ruby version thing? I miss being able to use it.
0
User avatar
kupono 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby otb designworks » Fri Mar 28, 2014 12:19 am

Can anyone confirm that this is not working in Su14 on a mac mavericks?

I installed the plugin both through the sketchucation plugin store and also through Didier's thread here.

Neither plugin appears in TOOLS and there is no align choice in the context menu when something is selected.

It's like the plugin doesn't exist, though it shows up in the plugin manager, and is in the user/library.../plugins location.

Thoughts?
0
Cheers, Chuck

OTB Designworks is on Youtube

6 core nMP, 32 gig RAM, (2) D700 GPU's, dual monitors

otb designworks 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby Box » Fri Mar 28, 2014 12:48 am

This might get it going for you. On the appropriate file, this is copied from the lines to tubes thread.

TIG wrote:Didier needs to rework his rb file for v2014 compatibility and republish it...

BUT you can do it temporarily for your own use, even though his script is 'packed'.
Open the file lines2tubes.rb in Notepad, and go to the end:
Change
...}.unpack("m").to_s
to read
...}.unpack("m")[0]
Save the changes.
Restart SketchUp.

The script will then load and work in v2014 !

This simple fix can be applied to any of Didier's 'packed' scripts that aren't working in v2014.

These edited scripts will also load and work in earlier SketchUp versions too... :ugeek:
1
User avatar
Box 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby kupono » Fri Mar 28, 2014 9:54 am

This is what I get when opening align_tool.rb in notepad.Bytecode?


Capture.PNG
0
User avatar
kupono 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby Box » Fri Mar 28, 2014 12:04 pm

And if you scroll to the end as Tig says do you not see the bit that needs to be changed.
0
User avatar
Box 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby otb designworks » Fri Mar 28, 2014 1:53 pm

Thanks for the response!

I changed the code to read as TIG said it should (image 1). I also tried it with a space between the ) and the [ with no difference

Now, when I start SU, I get this error message (image 2)

thoughts?
0
Cheers, Chuck

OTB Designworks is on Youtube

6 core nMP, 32 gig RAM, (2) D700 GPU's, dual monitors

otb designworks 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby Box » Fri Mar 28, 2014 2:16 pm

Sorry, I only know it works on windows.
0
User avatar
Box 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby otb designworks » Fri Mar 28, 2014 3:42 pm

Weird...

While I understand the drive to "upgrade" to Ruby 2.0, it is pretty frustrating that many old plugins don't work any more.
0
Cheers, Chuck

OTB Designworks is on Youtube

6 core nMP, 32 gig RAM, (2) D700 GPU's, dual monitors

otb designworks 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby nagrom345 » Thu Apr 24, 2014 8:19 pm

I can't get this plugin to work with Sketchup 2014. Does anyone have and ideas about this. Thanks.
0

nagrom345 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby agrazdi » Wed May 14, 2014 3:17 pm

Is it posible to update it for SU 2014 ?

Thanks
0

agrazdi 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby agrazdi » Wed May 14, 2014 11:57 pm

agrazdi wrote:Is it posible to update it for SU 2014 ?

Thanks


I didn`t read TIG's post. I followed his instructions and it works fine in su 14.

Thanks TIG
0

agrazdi 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby TIG » Tue Nov 04, 2014 5:01 pm

Didier has agreed that I might update some of his Plugins in the PluginStore so they are v2014/2015 compatible.
This is the latest version

Download

0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] Align tool 3D (bug fix)

Postby kupono » Tue Nov 04, 2014 11:59 pm

Thanks for the updates Tig. I was missing Align 3D.
0
User avatar
kupono 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby john2 » Sun Mar 01, 2015 7:41 am

this tool is not showing up in context menu. I am using version 2014 make
0
Sketchup Make 2016 (64-bit), SketchUp Make 2015 (64-bit), Vray 2.0 , Windows 8.1 – 64 bit, ATI Radeon 8570 Graphics 2GB,
User avatar
john2 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby TIG » Sun Mar 01, 2015 11:45 am

It works fine in v2014 and v2015.
It appears near the end of the Context menu as 'Align' - you must have something Selected...

What happens if you copy+paste this command into the Ruby Console + <enter> ?
load 'align_tool.rb'

The older versions <=v1.1 are NOT compatible beyond v2013, because of the Ruby upgrade.
So, are you using the very latest version [v1.1x] available from the PluginStore which was made compatible with all SketchUp versions [sorry but it's in ENglish only]...
viewtopic.php?p=76774#p76774
http://sketchucation.com/pluginstore?pln=align_tool
If NOT then please get the latest version's RBZ installed...
Report back if there are continuing issues...
0
TIG
User avatar
TIG 
Global Moderator
 

Re: [Plugin] Align tool 3D (bug fix)

Postby john2 » Sun Mar 01, 2015 1:45 pm

TIG wrote:It works fine in v2014 and v2015.
It appears near the end of the Context menu as 'Align' - you must have something Selected...

What happens if you copy+paste this command into the Ruby Console + <enter> ?
load 'align_tool.rb'

The older versions <=v1.1 are NOT compatible beyond v2013, because of the Ruby upgrade.
So, are you using the very latest version [v1.1x] available from the PluginStore which was made compatible with all SketchUp versions [sorry but it's in ENglish only]...
viewtopic.php?p=76774#p76774
http://sketchucation.com/pluginstore?pln=align_tool
If NOT then please get the latest version's RBZ installed...
Report back if there are continuing issues...



I get this

load 'align_tool.rb'
true



That's really weird. I am getting this option align in my right click menu. Restarted sketchup and wow! my option is coming.

This problem was occuring in both my PC and laptop. I am sitting on my laptop currently and the problem is gone. Didn't know what created it. Moreover on both my machines, I installed the latest version straightaway by accessing the plugin store inside sketchup via SCF plugin. Thanks for replying. :D :thumb: Maybe this ruby console has healed my problem, dont know. :D
0
Sketchup Make 2016 (64-bit), SketchUp Make 2015 (64-bit), Vray 2.0 , Windows 8.1 – 64 bit, ATI Radeon 8570 Graphics 2GB,
User avatar
john2 
 

Re: [Plugin] Align tool 3D (bug fix)

Postby TIG » Sun Mar 01, 2015 1:58 pm

If it recurs see if there are any Ruby Console messages and post them.
Maybe it was just a general glitch that needed a SketchUp restart to fix it ?
0
TIG
User avatar
TIG 
Global Moderator
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 

Previous


 

Return to Plugins

Who is online

Users browsing this forum: ni12, plus1 and 5 guests

Visit our sponsors: