Transparent objects receiving shadow

General discussion related to SketchUp Pro and Make

Transparent objects receiving shadow

Postby kelly24325 » Tue Jul 27, 2010 6:53 am

Hi,

It seems once opcity less than 100%, the object will not recieve shadow anymore...

I am kind wondering is that possilbe to have transparent object receiving shadow?
If any plugin or script able to achieve this?(without go into render process would be best.)

Thank you so much :D
0

kelly24325 
 

Re: Transparent objects receiving shadow

Postby Gaieus » Tue Jul 27, 2010 9:19 am

Hi Kelly,

Normally materials with less than 70% do not receive (or cast) shadows in SU. If you do not get this value, try to set your transparency settings in your Style dialog > In model > Edit > Face styles to medium or nicer if it is set to faster.
0
User avatar
Gaieus 
Administrator
 

Re: Transparent objects receiving shadow

Postby TIG » Tue Jul 27, 2010 11:11 am

Another trick is to make a transparent PNG and use that as a material texture - then even with its opacity=100% it will remain transparent and cast shadows [unless you remove those properties from an object]... However, like a 'transparent' material it will still not receive shadows. It can be as transparent as you like*** but with opacity at 100% and it will always cast shadows...
TransparencyStudy.PNG
***Here's a skm that is completely transparent - you can edit it's PNG material to say 10% opacity to look more like the example I showed...
TransparentDummy.skm
;)
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Transparent objects receiving shadow

Postby kelly24325 » Tue Jul 27, 2010 8:34 pm

Thanks you guys.

It seems for transparent objects to receive shadow is still hard. (I actually trying to have glass receive shadows of the bojects in the front).

And Gaiwus, I think 70% is for "casting" shadow, right? Not "receiving" shadow. Looks like when opcaity less than 95%(which still not quite transprent), object will not receive shadows.

Thank again!
0

kelly24325 
 

Re: Transparent objects receiving shadow

Postby TIG » Wed Jul 28, 2010 9:34 am

Unfortunately all transparent materials [irrespective of their opacity settings] AND all materials using a transparent png texture [again irrespective of the image's opacity settings] will not receive shadows! :(
I can't see a simple way to 'fake' it either :?
0
TIG
User avatar
TIG 
Global Moderator
 

Re: Transparent objects receiving shadow

Postby Box » Wed Jul 28, 2010 10:04 am

I had this problem and I managed to fake it by tracing around the shadows while in monochrome and adjusting that section of the face to a slightly different shade of transparent material.
It's not perfect, as the "shadows" don't move, but it helped me represent what I wanted for an image.
0
Opinions are like wives.
Those found on the internet have been known to contain varying traces of nuts!
User avatar
Box 
Top SketchUcator
 

Re: Transparent objects receiving shadow

Postby SUFractal2 » Fri Nov 30, 2012 4:25 am

TIG wrote:Another trick is to make a transparent PNG and use that as a material texture - then even with its opacity=100% it will remain transparent and cast shadows [unless you remove those properties from an object]... However, like a 'transparent' material it will still not receive shadows. It can be as transparent as you like*** but with opacity at 100% and it will always cast shadows...
TransparencyStudy.PNG
***Here's a skm that is completely transparent - you can edit it's PNG material to say 10% opacity to look more like the example I showed...
TransparentDummy.skm
;)


TIG:

I downloaded your Transparent_Dummy.skm file from an older post and have placed it where I believe it should reside, however, you can see the file icon appears extremely different than the others located there? The file/image does not appear as an option select in the material browser.

Is the file corrupt?

Thanks.
0

SUFractal2 
 

Re: Transparent objects receiving shadow

Postby Dave R » Fri Nov 30, 2012 10:25 am

The skm file is not corrupted. I just downloaded it now and put it in the Translucent folder. It shows in my Materials browser.
transdum.png

It's under the cursor in this screen grab.

I repeated it on my Mac with 10.6.8 and it worked fine there, too. The thumbnail is difficult to see on the Mac because it has no color and no border but it is there.

Is it possible you just aren't seeing the thumbnail? Did you restart SketchUp after installing it?
0
Inspecting mirrors is a job I could easily see myself doing.

3 out 4 people make up 75% of the population.
User avatar
Dave R 
Global Moderator
 

Re: Transparent objects receiving shadow

Postby Gaieus » Fri Nov 30, 2012 6:05 pm

The same way this model is "hacked" with a transprent png material (and hidden lines) for some shadow study example: http://sketchup.google.com/3dwarehouse/ ... revstart=0

Load the model straight in SU and see if it works for you.
0
User avatar
Gaieus 
Administrator
 

Re: Transparent objects receiving shadow

Postby pbacot » Fri Nov 30, 2012 7:26 pm

Isn't the original question to receive shadows, not create them? Does that apply to the 3dwh example?
0
User avatar
pbacot 
Top SketchUcator
 

Re: Transparent objects receiving shadow

Postby Gaieus » Sat Dec 01, 2012 3:27 pm

Well, the original question ws 2+ years ago. Who knows what the current issue is? :)
0
User avatar
Gaieus 
Administrator
 

Re: Transparent objects receiving shadow

Postby Dave R » Sat Dec 01, 2012 3:30 pm

I was just answering Stephen's question.
0
Inspecting mirrors is a job I could easily see myself doing.

3 out 4 people make up 75% of the population.
User avatar
Dave R 
Global Moderator
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to SketchUp Pro & Make Discussions

Who is online

Users browsing this forum: reckrec, stonangel, TommyK and 3 guests

Visit our sponsors: