Updating model to 2017 throws views out in Layout

Found a bug in LayOut? Report it here

Updating model to 2017 throws views out in Layout

Postby samyell77 » Wed Jan 18, 2017 2:24 pm

Hi,

I've just installed 2017 Pro. I have opened a layout file to test it and have found that when I save the SU file and update it in LO most of my modified views change. Any view that's been modified (where it says '(modified)' before the name in the scene dialogue) and just seems to shift to a new position throwing all my dims and annotations out. I've tried updated to an oversaved copy of the original file and have also tried re-linking to a copy of the original file saved as SU 2017 but get the same result with both.

I've attached some views to show what I mean. The one called 'On Open' shows the layout file (created in 2016) opened in LO 2017; all the dims are ok and the views are correct. The file called 'After Save and Update' shows how most of the views have changed and all the dims have been thrown off.

Having to rework my drawings to account for this view shift will be a serious pain - I often have to go back and revisit and amend old drawings from a couple of years ago.

Is this a bug or is there any way around it?

Thanks

Sam
On Open.JPG

After Save and Update - page.JPG

After Save and Update.JPG
0
SU Pro 2016
Dell Precision M4800
PC Windows 10
Intel Core i7-4900MQ @ 2.80ghz
Nvidia Quadro K2100M
16gb RAM

samyell77 
 

Re: Updating model to 2017 throws views out in Layout

Postby samyell77 » Wed Jan 18, 2017 3:52 pm

Ive done some further testing and when the file has been updated (from a modified view) it throws out the scale, changes it to perspective, moves it to a different location within the view window and consequently throws all the dims off into strange positions. If I select the viewport, change it to what I want (ortho, scale 1:10, right hand view) and then go to update the view (in scene pallet drop down) it throws everything out again despite the original view in SU having no camera associated with it.

I've tried adding my file to a new document and playing around with it and am having the same problems. I've uploaded a sequence of images to show what I mean. My SU window is shown on the left in the yellow box and the LO window on the right.

Image 01
Original setup of SU with one scene called Scene 1 that has no camera associated with it. LO files with SU model set out in LO and views manually changed to show plan, front and right.
01 Original.JPG


Image 02
Small change to SU file, elevation styles changed in LO and then context menu view update in LO to show red top.
02 Colour Change.JPG


Image 03
In SU yellow disc is added and shadows altered. In LO context menu update shows that shadows are not the same as SU because view is (modified) Scene 1 in scene pallet.
03 Shadows altered.JPG


Image 04
All views selected and changed to Scene 1 (in Scenes pallet dropdown) and now they are all perspective, all looking at the origin and all at a random super zoomed scale - this never happened before.
04 Update Modified View.JPG


I draw lots of production details and generally set one view to use for my front, plan and side views that doesn't have a camera associated with it in SU - I find this is a lot quicker and less confusing than having to set views for all the elevations in SU and allows for much quicker updates but this doesn't appear to work in LO 2017!

Can anyone shed any light on why this is happening now as its a major upheaval in the way I'll have to draw things up. Having to have a scene in SU for every view and elevation is a nightmare and makes organising a file really difficult. If I update a associate a camera with each elevation and then update a scene on a different PC where the screen is a different aspect ratio or the pallets are laid out differently (even if the pallet block is set wider or narrower) then the views all get thrown out if the view is updated from (modified) Scene X to just Scene X!

Any help very much appreciated....
0
SU Pro 2016
Dell Precision M4800
PC Windows 10
Intel Core i7-4900MQ @ 2.80ghz
Nvidia Quadro K2100M
16gb RAM

samyell77 
 

Re: Updating model to 2017 throws views out in Layout

Postby samyell77 » Wed Jan 18, 2017 4:51 pm

Link to the same topic on Sketchup Forum in case anything useful comes up on there.

https://forums.sketchup.com/t/layout-up ... yout/37567
0
SU Pro 2016
Dell Precision M4800
PC Windows 10
Intel Core i7-4900MQ @ 2.80ghz
Nvidia Quadro K2100M
16gb RAM

samyell77 
 

Re: Updating model to 2017 throws views out in Layout

Postby Play404 » Sun Jan 22, 2017 7:16 am

I have had a similar problem as the way I have always used scenes is that I have "Camera" scenes which only have the camera ticked so they can be reused, "Layer" scenes which show particular entities with the camera un-ticked. In SketchUp 2017 this workflow does not work, as Layout 2017 will disregard the camera settings once I change from a "camera" view to a "Layer" view. Previously I could set the scene to "Plan", then stack "Layer" views onto of each other and they each kept the first chosen camera scene. Now when I do this the stacked layers do not match up and it has to be done manually. The only work around is to use SketchUp 2016. I have messaged the SketchUp team and they are aware and apparently working on a solution.
0

Play404 
Premium Member
Premium Member
 

Re: Updating model to 2017 throws views out in Layout

Postby samyell77 » Sun Jan 29, 2017 11:40 pm

Thanks Play404,
Been looking at the SU forum site too and it sounds like its a bug so, like you Im hoping for a solution soon.
Cheers
0
SU Pro 2016
Dell Precision M4800
PC Windows 10
Intel Core i7-4900MQ @ 2.80ghz
Nvidia Quadro K2100M
16gb RAM

samyell77 
 

Re: Updating model to 2017 throws views out in Layout

Postby baz » Mon Jan 30, 2017 2:11 am

Pretty sure not a bug. Dave R will have to chime in here, he is the expert. But I do know never to modify scenes in Layout, That way lies madness!. Always do the mods in SU and if you dont want measurements messed up, don't change the scene position.
0
I am not an early bird or a night owl, I am some form of permanently exhausted pidgeon.
User avatar
baz 
 

Re: Updating model to 2017 throws views out in Layout

Postby samyell77 » Mon Jan 30, 2017 4:29 pm

Thanks Baz,
As far as Sketchup are concerned it is a known bug - I just got this email from Yogesh in the Sketchup team:

Hi Sam,

Thanks for your note.

We have two other post with the same issue
https://forums.sketchup.com/t/layout-scenes-and-scale-nightmare/34813
https://forums.sketchup.com/t/sketchup-2017-scenes-not-working-as-expected-in-layout/34210


And as mentioned by Marc in https://forums.sketchup.com/t/sketchup-2017-scenes-not-working-as-expected-in-layout/34210/11 we are working on a fix. Please check the release notes for the future maintenance releases of 2017 for official word that it's been fixed and also subscribe to the about forum posts for any further updates .

Please reply to this email if you need further assistance with this specific issue.

Regards,
Yogesh
The SketchUp Team at Trimble Inc.


Marc's (from Sketchup) post said the following:

This is a bug related to the graphics refactor. It will affect scenes that don't save one or more of these settings: camera, shadow, axes. We've got a fix in progress!

I've been advised by DaveR and Sonder that scenes should be used for every viewport which I'm looking into and testing on some current projects - thanks again for your advice on the other thread DaveR and Sonder. Sonder - I bought your book too. Some great templates, resources and tips in there and some new working methods for me to test out - thank you.
0
SU Pro 2016
Dell Precision M4800
PC Windows 10
Intel Core i7-4900MQ @ 2.80ghz
Nvidia Quadro K2100M
16gb RAM

samyell77 
 

SketchUcation One-Liner Adverts

by Ad Machine » 5 minutes ago



Ad Machine 
Robot
 



 

Return to LayOut Bug Reporting

Who is online

Users browsing this forum: No registered users and 1 guest

Visit our sponsors: